Dual boot can't load x64 w/o CD in boot drive.

Discussion in 'Windows 64bit' started by aimbie, May 14, 2005.

  1. aimbie

    aimbie Guest

    I have loaded x64 in a dual boot with WinXp 32 bit. The 32 bit version works
    fine, but I can't boot into the x64 version without setting bios to boot
    from the CD first and have the x64 install CD in the drive. If I don't have
    the CD in or set the computer to boot from hard drive or removeable drive I
    get the following message:

    "Windows could not start because the following file is missing or corrupt:
    <Windows root>\System32\ntoskrnl.exe. Please re-install a copy of the above

    My system specs:

    CoolerMaster CM Stacker
    Thermaltake Purepower 680W
    ASUS A8N-SLI Deluxe (Rev. 1.2) Bios 1007
    AMD 64 FX53 - ADAFX53DEP5AS
    Thermaltake Venus 12
    Corsair TWINX 1024 - 3200XL PRO
    2 x eVga 6800 Ultra PCIe
    Audigy 2
    Nvidia SATA Drives:
    WD 74GB Raptor - WinXP SP2 - nForce 6.53 - video 73.00
    WD 74GB Raptor - WinXP x64 - nForce 6.56 - video 76.71
    Maxtor Diamond 10 250GB
    2 X 80GB Seagate SATA drives-RAID 1 - Silicon Image
    Pioneer DVD-RW DVR-108
    Plextor DVDR PX-716A
    Mitsumi floppy drive
    Samsung 213T

    Any Ideas what could be causing this, it is annoying to have to keep the CD
    in the drive.
    aimbie, May 14, 2005
    1. Advertisements

  2. aimbie

    NoNoBadDog! Guest

    Just curious....did you do what the above error tells you to do?

    NoNoBadDog!, May 14, 2005
    1. Advertisements

  3. aimbie

    Guest Guest

    Aimbie, try this: in XP32 fromthe desktop go to My Computer -> Properties ->
    Advanced -> Start and Recovery -> Configuration. Then, in the pull down menu
    that appear you have one option for XP32 and another option for XP64. The one
    that shows first is the default. You can change that.
    Also you can go see those two options by pressing F11 during the post of
    your computer, without having to insert any disk or CD.

    Guest, May 14, 2005
  4. aimbie

    aimbie Guest

    No, I have not tried to replace the file it says. Then again it boots just
    fine as long as I have the CD in the DVD drive. Secondly, I see the screen
    to select XP 32 or x64 fine.

    I have done some searching on Plantamd64.com and it appears this is
    happening to others with the same motherboard and setup. Sounds like it is a
    bios issue or some problem with the Nvidia SATA controller.
    aimbie, May 14, 2005
  5. aimbie

    John Barnes Guest

    I am having the same problem. I had no problem with the beta of x64. I
    have searched for the ' missing' file from my 32-bit system and it is
    Also, the partition shows a 760 mb windows system(the loaded 64-bit system)
    , but from the install disk, it shows the partition empty when trying a

    Also, the first time I installed into a partition which had been previously

    I had to fix the boot.ini from recovery console, since there is virtually no
    time from the boot screen as it flashes and instantly went to this error.
    When fixed I can boot to my 32-bit system

    My system is an ASUS A8N-SLI Deluxe
    2 gig Corsair RAM
    AMD 3500+
    4 SATA drives
    No raid installed
    John Barnes, May 15, 2005
  6. The problem is, you've installed the 32-bit version of the file. The files in
    the system32 directory are 64-BIT FILES! (Yes, I know, it makes no sense at
    all. But there it is.) 32-bit files go in the SysWOW64 directory.
    Charlie Russel - MVP, May 15, 2005
  7. You should be able to copy that file over from the CD - it resides in the
    \amd64 directory as "ntoskrnl.ex_" -- use expand.exe to expand it and move it
    into your system32 directory.
    Charlie Russel - MVP, May 15, 2005
  8. aimbie

    aimbie Guest

    I am sure you can, but that's not the problem! The files are not corrupt
    that's just the error message you get when x64 can't find the hard drive.
    Many others with this motherboard and more than 1 SATA harddrive have the
    same issue.

    It didn't happen with the betas just the release version. I have installed
    x64 about 5 times now and it happens every time. I don't think its possible
    for the file to be missing (which it isn't because you can see it sitting
    there when you boot into WinXP 32) or corrupt (because if you boot with the
    CD in the CD rom drive as the first boot option it works fine and its not
    getting the file from the CD).

    Maybe you should reply when you have something to add.

    aimbie, May 15, 2005
  9. Whatever

    Charlie Russel - MVP, May 15, 2005
  10. aimbie

    John Barnes Guest

    I appreciate your replies, but sometimes they aren't related to the problem.
    In this case you aren't pertinent to the problem.

    The chipset is NVIDIA Nforce4
    I have the same problem as stated earlier
    I installed on a New sata hard drive I partitioned roughly 80gig each for XP
    Pro and XP 64-bit
    I ran the install program as stated above several ways and always bad
    I ran the install program with all 4 sata drives hooked up and with only the
    new drive installed. Same results. (the only difference is the drive, and
    it is a new Hitachi Sata II drive 300gb (I know it is no faster, so no
    sarcasm please) for info, in case this is the same with others, and there is
    something about the SATA II specs and this operating system that makes it
    not able to be a boot drive.
    In frustration, I decided to install on a partition I knew I could boot from
    after copying the drive.
    It installed perfectly in that partition and I was able to complete the
    The operating system is useless to me since no one (would be useful if
    Microsoft would) has provided the name of a dial-up modem with 64-bit
    support. Your sarcasm about HS is useless. Per the only DSL supplier in my
    area, my section will get DSL ' when pigs fly'
    John Barnes, May 15, 2005
  11. aimbie

    John Barnes Guest

    No I haven't. Please read additional info in the reply below.
    Windows x64 does the install.
    The ' missing' file is installed in the right place by the install program,
    but is not seen when the reboot takes place.
    I know the file it there since I can boot to my 32-bit system and LOOK.
    John Barnes, May 15, 2005
  12. aimbie

    Dennis Pack Guest

    I don't have an answer to the drive or installation concern. For the 56k
    dial-up modem concern the USRobotics5610B modem driver installs with the
    operating system. The modem works and I use it to FAX documents but my AT&T
    dial-up program doesn't recognize the x64 operating system yet.

    I hope this will help.
    Dennis Pack, May 15, 2005
  13. aimbie

    John Barnes Guest

    Thanks. I will go order one.

    John Barnes, May 15, 2005
  14. aimbie

    Randy Guest

    Per your dial-up problem, have you tried a simple SMC or DLink router with a
    serial (and parallel) server(s) built-in? Any system on your LAN that makes
    a TCP call automatically starts an attached serial modem dialing out, or you
    can log in via web browser interface and manually dial out or hang up (or
    let it hang up or time out). Doesn't require any modem driver, at least with
    Win98SE, XPHome, or 2000Pro (Or WinCE 2 or 3 or Mac OS 7, 8, or 9).

    They used to sell for about $40 new... maybe a few years ago when they were
    more popular. BestData makes a router with the modem built-in, but it needs
    reset fairly often and I wouldn't recommend it unless you have patience &
    high tolerance levels. ;~)

    If you "don't do" networking, just set each system's NIC up with TCP/IP and
    DHCP, and the routers manage the rest.

    Oh, and pigs do fly, in Cincinnati. Right on the river.
    Randy, May 15, 2005
  15. aimbie

    John Barnes Guest

    If NewEgg is up to their usual standards, I will at least have a mostly
    useful operating system. My Cannon printer won't work, with no estimate
    from them, but at least an old Lexmark works, with a small annoying quirky
    problem. Also anyone know of any reasonable scanners that are 64-bit ready.
    Then that leaves software. arrrrgggg
    Start with Nero, Virtual Drive of some sort, etc, etc
    John Barnes, May 15, 2005
  16. My Microtek V6UPL is NOT 64 bit ready but by installing their
    ScanWizard program, version 5.991 and then manually "decorating" the
    ..inf file as per the article here:
    The scanner installed and works.

    My guess is that any Microtek scanner that uses a USB connection and
    ScanWizard 5.991 to install might work if the INF file is decorated?
    David R. Norton MVP, May 15, 2005
  17. Hello,
    What is in the boot.ini file?

    Also boot to the x64 cd and go into Recovery Console.
    Run "map arc"
    Report back what is displayed.
    This is reporting the arc paths for the drives in the system.
    I want to see if booting to the x64 cd is reporting back the drives any
    differently than what is in the boot.ini file.

    Darrell Gorter[MSFT]

    This posting is provided "AS IS" with no warranties, and confers no rights
    Darrell Gorter[MSFT], May 16, 2005
  18. aimbie

    aimbie Guest


    [boot loader]
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
    Professional" /fastdetect /NoExecute=OptIn
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows XP Professional x64
    Edition" /noexecute=optin /fastdetect

    result of running "map arc" from the recovery console:
    D:NTFS 70896MB multi(0)disk(0)rdisk(1)partition(1) [this is the
    partition with x64]
    E:NTFS 239366MB multi(0)disk(0)rdisk(2)partition(1)
    C:NTFS 70896MB multi(0)disk(0)rdisk(0)partition(1) [this is
    the partition with Win32]
    A: \Device\Floppy0
    G: \Device\CdRom0
    H: \Device\CdRom0

    I suspected that this would be ok because when you use the CD drive to boot
    x64 loads fine. Is there anyway to get this information when you boot from
    the removable drive or the harddrive as that is when it doesn't work?

    aimbie, May 17, 2005
  19. Hello,
    This is strange.
    Both Arc paths are the same so you are correct, that is not the issue. It
    couldn't be that easy could it.
    So the only different is the boot code itself.
    When you boot from the CD, the boot code on the cd is read and if a key is
    not pressed, the boot it passed to the hard drive that is next in the boot
    order to load NTLDR..
    If yoy boot hard drive, you use the boot code and pass to NTLDR.
    So the only difference then is the boot code in the MBR and Boot Sector.
    We either load them from the CD in which case we work, or we load them from
    the hard drive is which case we fail.
    So the uniqueness is in what we are loading from the hard drive on these
    systems that prevents boot.
    Darrell Gorter[MSFT]

    This posting is provided "AS IS" with no warranties, and confers no rights
    Darrell Gorter[MSFT], May 17, 2005
  20. aimbie

    Guest Guest

    Wow, fixed this issue on my PC by setting the BIOS to boot from the Win XP
    Pro 32bit drive rather than the 64bit drive. Seems Windows installed a dual
    boot .ini file on the 32bit drive and nothing on the 64bit drive. I can
    select either at bootup and both work now with no CD mounted.

    Guest, May 19, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.