DSL issue on 3640 router with ADSL WIC

Discussion in 'Cisco' started by Gary, Feb 18, 2004.

  1. Gary

    Gary Guest

    We have an ADSL WIC in a 3640 with a T1 which is normal mode of use unless
    the T1 fails. We cannot seem to bring up a connection with the ADSL line and
    see this all the time.

    00:19:59: Vi1 CHAP: I CHALLENGE id 241 len 38 from "RASI1NRP2.Ilford2"
    00:19:59: Vi1 PPP: Sent CHAP SENDAUTH Request to AAA
    00:19:59: Vi1 PPP: Received SENDAUTH Response from AAA = FAIL
    00:19:59: Vi1 CHAP: Unable to authenticate for peer
    00:19:59: Vi1 PPP: Authorization NOT required
    00:20:01: Vi1 PPP: Authorization NOT required
    00:20:05: Vi1 CHAP: I CHALLENGE id 16 len 38 from "RASI1NRP2.Ilford2"
    00:20:05: Vi1 PPP: Sent CHAP SENDAUTH Request to AAA
    00:20:05: Vi1 PPP: Received SENDAUTH Response from AAA = FAIL
    00:20:05: Vi1 CHAP: Unable to authenticate for peer
    00:20:05: Vi1 PPP: Authorization NOT required
    00:20:07: Vi1 PPP: Authorization NOT required

    We are a UK based company connecting through BT, so some settings will be
    different from the US.

    When T1 is up we see

    Interface IP-Address OK? Method Status
    Protocol
    ATM0/0 unassigned YES NVRAM up
    up
    FastEthernet0/0 213.214.215.1 YES NVRAM up
    up
    Serial0/1 213.214.215.1 YES unset up
    up
    Virtual-Access1 unassigned YES unset up
    down
    Dialer0 unassigned YES NVRAM up
    up


    When T1 is own we see
    Interface IP-Address OK? Method Status
    Protocol
    ATM0/0 unassigned YES NVRAM up
    up
    FastEthernet0/0 213.214.215.1 YES NVRAM up
    up
    Serial0/1 213.214.215.1 YES unset up
    down
    Virtual-Access1 unassigned YES unset up
    down
    Dialer0 unassigned YES NVRAM up
    up

    SO Dialer is coming up OK, but does not get an IP from our ISP's radius
    server ?

    Config below.
    interface ATM0/0
    no ip address
    no ip mroute-cache
    atm vc-per-vp 256
    no atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    no fair-queue
    hold-queue 224 in
    !
    interface FastEthernet0/0
    description Handoff to Internal Network
    ip address 213.214.215.1 255.255.255.0
    no keepalive
    duplex auto
    speed auto
    !
    interface Serial0/1
    ip unnumbered FastEthernet0/0
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    !
    interface Dialer0
    no ip address
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp pap sent-username password 0 password
    !
    ip nat inside source list 1 interface Dialer0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0/1
    ip route 0.0.0.0 0.0.0.0 Dialer0 230
    no ip http server

    ip pim bidir-enable


    dialer-list 1 protocol ip permit


    We do not see any authentication attempts on the radius server at all ?

    Any help appreciated.

    Gary
     
    Gary, Feb 18, 2004
    #1
    1. Advertisements

  2. Gary

    Gary Guest

    Might have made things better - I now get

    nterface IP-Address OK? Method Status
    Protocol
    ATM0/0 unassigned YES NVRAM up
    up
    FastEthernet0/0 213.214.215.1 YES NVRAM up
    up
    Serial0/1 213.214.215.1 YES unset up
    down
    Virtual-Access1 unassigned YES unset up
    up
    Dialer0 unassigned YES NVRAM up
    up

    I removed
    and added
    ppp chap hostname
    ppp chap password 0 password

    Virtual Access 1 looks like this

    Virtual-Access1 is up, line protocol is up
    Hardware is Virtual Access interface
    MTU 1500 bytes, BW 56 Kbit, DLY 100000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    DTR is pulsed for 5 seconds on reset
    Interface is bound to Di0 (Encapsulation PPP)
    LCP Open
    Bound to ATM0/0 VCD: 1, VPI: 0, VCI: 38
    Cloned from Dialer0
    Last input 00:10:16, output never, output hang never
    Last clearing of "show interface" counters 00:54:45
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 1/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    2691 packets input, 47162 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    3029 packets output, 47436 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions

    HELP !

    Gary
     
    Gary, Feb 18, 2004
    #2
    1. Advertisements

  3. Gary

    teggs Guest

    Gary,

    try this:

    Router#(config)interface dialer0
    Router#(config-if)ip address negotiated

    Teggs
     
    teggs, Feb 19, 2004
    #3
  4. Gary

    Gary Guest

    Thanks - Did the Job !
     
    Gary, Feb 19, 2004
    #4
  5. Gary

    teggs Guest

    Glad to be of assistance

    Teggs
     
    teggs, Feb 19, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.