Drive in Raid Array not recognised?

Discussion in 'Computer Support' started by Julie Burnsine, Sep 26, 2003.

  1. System is:- xp pro, asus a7v333 with modfied promise onboard raid
    controller, giving full raid.

    striped array consisted of 2 x 60gb maxtor 7200rpm each set as master on the
    promise channel.

    The system has been working for the last 6 months but suddenly now when it
    boots and scans the raid array, it reports that the array is offline?

    It goes on to say check the cable and the drive.

    I downloaded maxtors powermax and run the utilty on both drives (advanced
    check) and it reports both drives 100% fit?

    I have tried swapping the ide cables about, but with no luck.. i dont want
    to loose the data on these striped drives... please can someone shine a
    little light here for me..

    Many thanks all

    Julie
     
    Julie Burnsine, Sep 26, 2003
    #1
    1. Advertisements

  2. Julie Burnsine

    Stevo Guest

    What do you mean when you say 'modified promise onboard raid controller'?

    If you disconnect those drives and attach replacements, are they recognised
    on that controller?

    With the data being important to you, I'd be trying either another
    motherboard with a similar raid controller, or plugging in an addon card
    with RAID 0/1 capability to see if the drives are recognised correctly (but
    there is some risk involved, because the RAID array will need to be set up
    in those scenarios - provided you have the correct information about your
    existing RAID that shouldn't be too hard to do though).
     
    Stevo, Sep 27, 2003
    #2
    1. Advertisements

  3. Stevo,

    I am using lumberjacker hacked bios, which gives full raid functionality...

    Unfortunately Steve, I dont have replacement drives to swap...

    Thanks for your advice all the same

    regards

    Julie
     
    Julie Burnsine, Sep 27, 2003
    #3
  4. I have just tried out a pci raid card and both drives are recognised by the
    new card but the data cannot be read?
     
    Julie Burnsine, Sep 28, 2003
    #4
  5. After weeks of worry... solution at last...

    Both drives in the array tested mechanically sound with Maxtor's powermax
    diagnostics,,,, so i decided to rebuild the the stripe array by choosing the
    exact same settings as before, with reference to the cluster size and the
    slave/master configerations.... this i thought was the last resort.....

    The raid bios set the stripe array, rebooted and voila - all my data was
    there!!!

    Looks like some of the array info was corrupt on one of the drives but now
    the file seemingly has been rewritten and all systems are go!!!


    Thanks to all that offered advice...

    Cheers

    Julia
     
    Julie Burnsine, Oct 2, 2003
    #5
  6. dear julie,

    i was faced with the same trouble. the raid-0 array just got "offline"
    and now one of the disk is not assigned to the array anymore but just
    "free".

    I read about a hint saying just delete the array and then re-create it
    with same parameters. after just it is supposed to work.

    I did not try because I really need my data.

    let me know once you find a solution on that

    regards
    andrea
     
    Andreas Brandt, Oct 16, 2003
    #6
  7. Julie Burnsine

    Jools Guest

    Andreas,

    The final solution was make or break for me...

    I did NOT reformat the drive that went offline, but merely rebuilt it in the
    raid bios, ensuring that the cluster size was exact, as before (64k).

    This has remedied my predicament, as the drive is now up again and best of
    all, I didnt loose any data!

    Just make sure that you duplicate all the settings, as per the original
    setup,,

    Good Luk

    Julie
     
    Jools, Oct 21, 2003
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.