Dos command help

Discussion in 'Computer Information' started by JJ, Apr 23, 2008.

  1. JJ

    JJ Guest

    I've installed a new and larger 2nd internal hard drive and am trying to
    copy my old drive onto it. I then was going to swap them around and use the
    old as the slave and boot from the new one.one. I thought I would use the
    Xcopy function in Dos.
    I made a MS-Dos floppy startup disk and booted using that. It comes up A:\
    and I cannot get it to change to the C directory.
    I've tried cd and cdir commands to C C: C:\ C:/ and I keep getting invalid
    error. Its been 20 years since I had to use Dos commands and I wasn't very
    good at it back then. A little help please.

    Thanks,
    Joe
     
    JJ, Apr 23, 2008
    #1
    1. Advertisements

  2. You must set the drives as Slave or Master as appropriate. The boot drive is
    the Master. Then you have to connect the ribbon cable correctly because the
    motherboard is going to look for the slave and master according to which
    connector goes where.

    Your command should have taken you to C. You can try DIR C:\ to see if the
    drive can be read.
     
    Jeff Strickland, Apr 23, 2008
    #2
    1. Advertisements

  3. JJ

    JJ Guest

    It's a Dell, so the drives are controlled by the ribbon cable position and
    the jumpers are both set to that.

    But that doesn't do me any good anyway. I tried DIR C:\ and I still get
    "Invalid Drive Specification" yet if I take out the floppy and reboot the
    everything comes up normally. Obviously there is a valid C drive there, why
    the heck wouldn't it read it in Dos? I'm running XP Pro and used that to
    make the boot disk.

    Thanks,
    Joe
     
    JJ, Apr 23, 2008
    #3
  4. Invalid drive spec means the drive is not there. I get that it is physically
    there, but the computer does not see it, therefore it is not there.

    Set the drives back to normal, and boot from the floppy and see if you can
    pull a directory of C.

    From your original post, you should be able to get to C simply by typing c:.
    You can also type cd c:, or any of the other combintations you attempted.
    Everything you have told me says the you have no Drive C. Have you tried to
    see if you have Drive D?
     
    Jeff Strickland, Apr 23, 2008
    #4
  5. I gave that answer by checking the response from a machine that comes up
    properly and actually runs the OS. Since you are booting from a floppy, you
    may not have enough of an OS to run the commands. I can't imagine how that
    could be true, but it's a thought ...
     
    Jeff Strickland, Apr 23, 2008
    #5
  6. JJ

    JJ Guest

    I'm in the original configuration, just that I added a second drive as a
    slave. The C drive is the original because I haven't been able to access C
    to begin the xcopy process. Like I said, if I remove the floppy and boot,
    everything is normal. If I go to MY Computer, it shows both drives C & new
    blank F and of course A. When I boot from the floppy, I still get the
    invalid drive specification error when I try to switch to C: I tried to
    switch to the F directory and get the same error.
    I don't know the problem, but I'm glad I at least thought I remembered how
    to switch directories in Dos and I'm not losing my mind!

    Thanks for your time!!
    Joe
     
    JJ, Apr 23, 2008
    #6

  7. Then you don't have enough of an OS on the floppy.

    Can't you boot to C, start Win XP, go to the command prompt and xcopy from
    there, then set the new drive as the Master and boot to it and dump the old
    files on the original C (which would be a slave by this point).

    I just typed XCOPY and got the error that there are not enough parameters,
    so the command works if I put in enough stuff.
     
    Jeff Strickland, Apr 23, 2008
    #7
  8. JJ

    JJ Guest

    OK, great idea. I thought I had to be out of Windows to copy the entire
    drive.

    Now what is the correct syntax? I tried xcopy C: F: but then it only copied
    six files. That is a space between the : and F.
    Then I tried xcopy C:\ F:\ and get the same 6 files copied over. Again,
    there is a space between them.

    Thanks for your patience Jeff!
    Joe
     
    JJ, Apr 23, 2008
    #8
  9. JJ

    JJ Guest

    I'm doing more research and came across this note:
    If you have a disk that contains files in subdirectories and you want to
    copy it to a disk that has a different format, you should use the xcopy
    command instead of diskcopy. Since the diskcopy command copies disks track
    by track, it requires that your source and destination disks have the same
    format. Xcopy has no such requirement. In general, use xcopy unless you need
    a complete disk image copy. However, xcopy will not copy hidden or system
    files such as IO.SYS and MSDOS.SYS. Therefore, use diskcopy to make copies
    of system disks.

    I assume i need to do an diskcopy then if I want a complete, bootable backup
    of the C drive?

    Thanks,
    Joe
     
    JJ, Apr 23, 2008
    #9

  10. I don't know the answer to that one.

    Did you try xcopy c:\*.* f:

    Copy, or xcopy, c: may constrain the copy operation to the files on C, but
    copy *.* should include the subdirectories.

    It's been a very long time since I did this, I was probably still using DOS
    and not Windoze.
     
    Jeff Strickland, Apr 23, 2008
    #10
  11. JJ

    JJ Guest

    Wouldn't work.
    I tried all of those and none worked. Is this normal...instead of the
    prompt C:\ I get C:\> and that is where I'm typing my commands. Now this
    is XP so I don't know if something changed in DOS but I sure don't remember
    the > symbol being on the command line years ago.
    Thanks,
    Joe
     
    JJ, Apr 23, 2008
    #11
  12. Back in the Stone Age, you could use the DOS Prompt Command to define the
    prompt as C:\ and stick in extra characters like the >. Your command prompt
    will be C:\WINDOWS\> or C:\Program Files\> or whatever. The > character
    comes from the Prompt Command. I don't remember clearly, but you can
    experiment with PROMPT $P$G. I don't think Windows cares what the command
    prompt is.
     
    Jeff Strickland, Apr 23, 2008
    #12
  13. JJ

    Mike Huskey Guest

    If your C drive is formatted NTFS, then dos can't read it.
     
    Mike Huskey, Apr 24, 2008
    #13
  14. JJ

    Neil Green Guest

    Xcopy simply won't do what you want in Win XP.
    You need someting like Acronis True Image or Norton
    Ghost, either that or do a clean install of XP on the
    new drive then copy your critical data over to it.
     
    Neil Green, Apr 24, 2008
    #14
  15. JJ

    tony sayer Guest

    Mine manages OK?..
     
    tony sayer, Apr 24, 2008
    #15

  16. DOS , that means real DOS, the type he is going to by booting off a
    floppy, (e.g. a windows 98 boot disk, actually counts as real dos)
    cannot read NTFS (without 3rd party utilities).
    When a drive e.g. C, is not partitioned, you cannot even do C:
    You get an error message
    If the drive is partitioned NTFS, then you can do C:, but cannot do
    DIR, DOS cannot read it. You can a different error message.

    The DOS Prompt, the command prompt, can read NTFS.
    Real DOS cannot, you need something like NTFS PRO, or NTFS4DOS, for
    that.
    (I am not sure if I tried NTFS4DOS, it is free I think).

    I think the invalid media type error might be when doing DIR on an
    NTFS drive, as I think jeff suggests.
     
    jameshanley39, Apr 24, 2008
    #16
  17. JJ

    tony sayer Guest

    We use an old machine running WIN 2000 pro for old legacy programming
    services and it reads and operates DOS very well..
     
    tony sayer, Apr 24, 2008
    #17
  18. Win 2000, like Win XP, has a COMMAND PROMPT, it "operates" that very
    well. And reads NTFS no problems.
    But once you boot from a floppy disk, you are no longer running
    Windows NT(2K or XP).

    What you are doing is using the command prompt.

    And if you were using a DOS/Win9X boot disk, then that is no longer
    windows 2000. And it would not read NTFS either.

    note- Win9X does not read NTFS without 3rd party utilities. Either a
    9X boot disk (which is infact DOS, just without many standard DOS
    utilities included), or Win 9X itself.
     
    jameshanley39, Apr 24, 2008
    #18
  19. <snip>

    Meaning you are either in Windows 2K, using the command prompt. Or you
    are using a boot disk, so you are in DOS.

    It may be that you can boot off a floppy disk and get to a command
    prompt, i.e. you are in DOS. And you can read your C drive fine. But
    that would mean that your C drive is not NTFS.
    It may also be that in windows, your C drive is NTFS, but you also
    have a drive, that is not NTFS, D or F or whatever. And when you boot
    to DOS, DOS cannot see your regular C drive, since it is NTFS. So it
    sees the first FAT16/32 drive (a drive windows calls D or F) and it
    calls it C.
     
    jameshanley39, Apr 24, 2008
    #19
  20. JJ

    Baron Guest

    DOS Doesn't understand NTFS !
     
    Baron, Apr 24, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.