Does the Asus RT-AC66U require ICMP for anything

Discussion in 'Network Routers' started by Robert Peirce, Jan 29, 2015.

  1. As mentioned in a prior post I am having a problem connecting to
    Verizon'a mail servers. In researching this I find I get as far as the
    gateway to Verizon's internal servers but no further. I was told the
    next server is probably blocking ICMP.

    I can ping but not

    I can connect to Verizon's mail servers with my old Linksys router but
    not with the Asus.

    The Asus seems to do everything else with zero problems. It just won't
    let me connect to verizon mail.

    I can't see why blocking ICMP should be an issue unless the Asus somehow
    requires it in the process of trying to connect to Verizon's servers.
    Robert Peirce, Jan 29, 2015
    1. Advertisements

  2. Robert Peirce

    Char Jackson Guest

    That's a fair assumption. For the most part, I suggested traceroute to
    verify that the connection attempt isn't dying at your router, on the way
    Same behavior here, but I can telnet equally well to both of them on port
    465. I don't have login credentials, so my experiment ends there.
    What if you change the order of the list of email accounts, or if you add a
    dummy account to the end of the list? If that works, it rules out the
    Some admins disable ICMP replies. It doesn't mean anything more than that.

    I mentioned it before, but I'll bring it up again. If you have access to a
    packet capture utility and know how to use it, you can track the problem
    down that way. Wireshark for the PC comes to mind, but I think you mentioned
    Mac, so I'm not sure what you have available.

    Google to the rescue:
    Looks like Mac may be supported after all.
    Char Jackson, Jan 29, 2015
    1. Advertisements

  3. I just tried to post a reply and it didn't go! I will try again if I
    can remember what I said before.

    Telnet 465 times out for me, probably because I am
    being blocked by an intermediate server.
    I cannot seem to do either.

    I am at a loss as to how to re-order the list and it may not even be
    possible. It seems to be kept in alphabetical order, which would make
    it tough to come up with something below Verizon!

    I cannot create a fictitious account because mail checks it before
    creating it. Trying to create a duplicate doesn't seem to do anything.

    An extra account below Verizon would be an interesting way to see if the
    router is doing something.
    I don't have one and have never used one so it probably wouldn't help me
    much. The only reason I could use traceroute and telnet was I have used
    them before and just had to refresh my memory from the man pages.
    Robert Peirce, Jan 29, 2015
  4. Robert Peirce

    Char Jackson Guest

    No worries. I'm just about out of ideas. Circling back to DNS for a moment,
    it's possible that the two routers are configured to use different DNS
    servers, and it's possible that you have your computers configured to use
    whatever the router is using. If both of those conditions are true, one of
    the two DNS servers could be resolving to the wrong IP
    address, but that doesn't help to explain anything regarding the list of
    mail servers and the odd behavior by the one that happens to be last in the

    It's also possible that there are two issues in play because one part of the
    problem description does point to the router (you swap it and the problem
    goes away) while the other part of the problem description clearly points to
    the computers (last email server in the list).

    For me, resolves to this:


    If you get something different on the computer that can't connect, try
    changing your DNS server and see if you get a different answer.
    Char Jackson, Jan 29, 2015
  5. It turns out to be worse than that. My IP was causing the problem but
    it did it gradually instead of instantly. Initially I could use my
    Linksys router, a direct connection to the modem or an unprotected WiFi
    network in the area but not my Asus router. Eventually I could not
    connect on anything but the local hotel network.

    The WiFi network in a nearby hotel worked fine because it was on a
    different block of addresses. When I got my ISP to move me to a
    different block the problem went away.

    What I can't figure out is why this happened gradually. If my address
    was being blacklisted I think it should have just turned off. The
    gradual fade led my down many blind alleys I could have avoided.
    Robert Peirce, Feb 2, 2015
  6. Robert Peirce

    Char Jackson Guest

    That's an interesting final twist to the story. Thanks for sharing, and good
    luck going forward.
    Char Jackson, Feb 3, 2015
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.