Does Google Play keep an archive of the *old* (free) versions?

Discussion in 'Wireless Internet' started by James P. Doolittle, Nov 24, 2014.

  1. Does Google Play keep an archive of the *old* (free) versions?

    Apparently MetaGeek inSSIDer 4.0.2.9 (July 23, 2014) is now payware.

    I reset my Android phone to factory defaults, but, much to my chagrin,
    when it came time to re-install the inSSIDer freeware, what used to be
    free, apparently isn't free anymore.

    Did the MetaGeek inSSIDer freeware suddenly (without warning) go payware?
    http://www.inssider.com/

    When I look on Google Play, it's no longer freeware:
    https://play.google.com/store/apps/details?id=com.metageek.inSSIDer&hl=en

    However, I can easily find inSSIDer on other sites, e.g., Techspot:
    http://www.techspot.com/downloads/5936-inssider.html

    It's also free at Global APK, but can I trust these sites?
    http://globalapk.com/android-apps/5540-inssider-v40112.html

    I'd rather get inSSIDer from Google Play, which used to provide it for
    free (since I used it up until I re-imaged my phone).

    Does Google Play keep an archive of the *old* (free) versions?
     
    James P. Doolittle, Nov 24, 2014
    #1
    1. Advertisements

  2. James P. Doolittle wrote, on Mon, 24 Nov 2014 04:12:34 +0000:
    I wish I had saved the original apk download of inSSIDer, because it's no
    longer freeware, but, it *was* freeware when I had last installed it.

    Since I had backed up my apps with Kies3 on Windows just yesterday, I
    tried to open the 1,505KB "net.metageek-1.apk" which Kies3 in Android,
    but, Android simply gave the error message:
    "Describe error. There is a problem parsing the package".

    In fact, *all* the apk files backed up by Kies3 on Windows gave that same
    error when I copied them over to the Android "Downloads" directory and
    tried to open them on Android.

    So, going to Kies3 on Windows, I went to the Kies3 "Backup/Restore" tab,
    and selected the entry titled "inSSIDer 1.47MB":
    http://i60.tinypic.com/2igeywh.gif

    This immediately elicited the warning: http://i57.tinypic.com/23k99q0.gif
    "Instructions for restoring an application. The App Verification setting
    for blocking the installation of malicious applications has been enabled
    on your device. Disable the [Verify apps] setting in the [Settings] menu
    before continuing."

    Back on the Android phone, I went to "Settings > More > Security", and
    unchecked the setting labeled "Verify apps. Block or warn before
    installing apps that may cause harm."

    I also noted that the Android setting was checked titled:
    "Unknown sources. Allow installation of apps from sources other than the
    Play Store."

    Then, back on Windows Kies3, I hit the "Restore" button:
    http://i62.tinypic.com/vwpp95.gif

    Voila!
    http://i58.tinypic.com/35k3nma.gif

    The result was that the older (freeware) version of inSSIDer was,
    thankfully, re-installed onto the Android device! Woo hoo!

    I'm glad you guys talked me into using Kies3 as a backup solution.

    Good news? Kies3 worked to restore the freeware inSSIDer version!
    Bad news? Why didn't just clicking on the Kies3 apk file work?
     
    James P. Doolittle, Nov 24, 2014
    #2
    1. Advertisements

  3. James P. Doolittle wrote, on Mon, 24 Nov 2014 06:05:29 +0000:
    This unfortunate change of inSSIDer from freeware to 10-dollar-ware
    brings the following two questions to the fore.

    Q1: Why didn't Android install directly from the apk that Kies3 saved?

    From now on, I want to save the apk when I download from Google Play.
    That brings up the second related question:

    Q2: How can we save a working apk when we install from Google Play?
     
    James P. Doolittle, Nov 24, 2014
    #3
  4. James P. Doolittle wrote, on Mon, 24 Nov 2014 06:16:13 +0000:
    Nobody?
     
    James P. Doolittle, Nov 25, 2014
    #4
  5. James P. Doolittle

    Farshad Guest

    Nothing wrong with inssider, but if you can't reinstall the old freeware
    version from your kies backup apk, then just replace inssider with fritz!
    app wlan freeware, from avm gmbh.
     
    Farshad, Nov 25, 2014
    #5
  6. James P. Doolittle

    Farshad Guest

    Farshad, Nov 25, 2014
    #6
  7. This assume Android 4.1.1 and File Manager. Your procedure might be a
    bit different.

    HowTo:

    [This assumes that you already have created a folder 'MyAPKs' on your
    SD-card.]


    File Manager -> Internal (or SD card) -> tap four-squares icon at the
    bottom -> switches to category mode -> Applications -> Installed ->
    <app> -> tap -> Copy to -> '<' on top of page -> SD card -> MyAPKs ->
    Save.

    After doing this, rename the .apk extension part (I use .pka) because
    some 'cleaning' tools - such as CCleaner - will think that these .apk
    files are not needed and will offer to remove them or even remove them
    silently.
     
    Frank Slootweg, Nov 25, 2014
    #7
  8. IIRC, you have a recent Samsung device. Also your mention of "my
    default "My Files" file manager", seems to confirm that.

    (Besides the Android 4.1.1 / 'File Manager' device,) I also have a
    recent Sasung Galaxy Tab4 (10.1"), so I could help you, *if* I knew how
    to operate the bloody device! :) It's not so much the difference in
    Android versions, but the 'menu' (three horizontal bars) key being
    'replaced' by the 'Recent' key, that's giving me problems ("I don't want
    to see the bloody list of bloody 'recent' programs, I want to see the
    bloody *menu*!" (And no, long-pressing the 'Recent' key doesn't do
    anything either!)).

    So let me describe *what* should be done, and then you can try to
    figure out *how* to do that with the "My Files" app, or any other file
    manager.

    - As said, first create a folder 'MyAPKs' (or similar) on your SD-card.

    - In the 'My Files' app, the left panel will say 'Favorite folders',
    'Folders', 'Categories' and 'Apps'.

    - Open the 'Categories' list (by tapping the down-arrow to its right).

    - One of the categories is 'Downloaded apps'. Open/tap that.

    - The right panel will show your downloaded/installed apps (i.e. not the
    'built-in' apps).

    - Your mission - should you accept it :) - is to select and *copy* the
    (APK of the) desired app to the 'MyAPKs' folder.

    [This is the part I don't know how to do. I can *select* it (by
    long-pressing the icon of the app), but I see no way to *copy* it. The
    only option I get is 'Delete' (in the upper-right corner), nothing
    else. *Damn*, I want my 'Menu' key back!]

    Hope this helps.

    Did I already say that I want my 'menu' key back!? :)
     
    Frank Slootweg, Nov 26, 2014
    #8
  9. Frank Slootweg wrote, on Wed, 26 Nov 2014 21:23:34 +0000:
    It's a Galaxy S3 that I bought used for $75 last month.
    I haven't put an external sd card in it yet.
    The S3 has the permanent keys, with the "Back" button on the
    bottom right of the Samsung Galaxy S3 and the "Menu" button
    on the bottom left.
    Aha! I never saw that. When I open "My Files".

    By default, this is what I see in "My Files":
    http://i60.tinypic.com/vdem49.png

    Then, when I press the "Menu" button, I can see the settings:
    http://i60.tinypic.com/fmur2h.png

    But, nothing in the settings seems to show categories better:
    http://i60.tinypic.com/w8tdzb.png

    Maybe it only works with the sdcard, which I will try to buy
    and install anyway.
     
    James P. Doolittle, Nov 26, 2014
    #9
  10. This is what I find so annoying about Android: All these versions are
    totally different and the newest versions may be the 'latest', but by
    no means the 'greatest'.

    (As said,) My 'File Manager' app is part of Android 4.1.1 (at least on
    my phone, a Huawei). It's (probably) 'old', but *can* do what you want.
    I could not find any version or other identifying information for this
    (bundled) app.

    My 'My Files' app is part of Android 4.2.2 (at least on my Samsung
    Galaxy Tab4). It is new(er), but probably can *not* do what you want.
    After my previous posting, I tried some normal files (i.e. not apps) and
    for those I *did* get options to copy (or move) them. So for the moment
    it looks like 'my' 'My Files' app can *not* make a copy of an APK. So
    much for 'progress'! :-(

    Your 'My Files' app seems to be somewhere in the middle, not as bad as
    my - probably newer - 'My Files' app, but also not as good as my *old*
    'File Manager' app.

    So besides my 'Menu' button, I want my 'File Manager' back! :-(
     
    Frank Slootweg, Nov 27, 2014
    #10
  11. Frank Slootweg wrote, on Thu, 27 Nov 2014 19:14:18 +0000:
    This is a surprising (to me) weakness in Android, that you can't
    easily get the proper version of an app that you, at one time,
    installed from Google Play:

    1. Take, for example, this app with the "Guy Fawkes" icon:
    http://i57.tinypic.com/2iiv4tv.png

    2. When I run the app, there is no "Help > About" anywhere:
    http://i58.tinypic.com/w8l44i.png

    3. "Manage Applications" isn't anywhere in the "App Drawer":
    http://i60.tinypic.com/11ipjr6.png

    4. The name "Manage Applications" wasn't ever downloaded:
    http://i62.tinypic.com/xe0jts.png

    5. Even Google Play doesn't show it was ever installed:
    http://i60.tinypic.com/1zp5ooh.png

    6. Sander Troffin kindly explained how to figure out what app
    was this Guy Fawkes icon:
    "An Android app may have two Launcher icons.
    It looks as if that app does.
    That app is "Permission Manager" from Appaholics,
    com.appaholics.applauncher.
    Export "Permission Manager" to an apk file;
    unzip the apk (it is a zip file with an apk extension)
    and you will find that "Guy Fawkes mask" image inside."

    7. Frank Slootweg also kindly suggested this procedure:
    "Assuming it is a *downloaded* app ...
    Play Store app -> <three bars in upper-left> -> My apps ->
    'ALL' tab -> find app without known origin -> tap it ->
    tap on info panel (*not* on UNINSTALL or OPEN) ->
    You will now get the Play Store entry for the app which
    should list the 'DEVELOPER'.

    8. Trying this helpful suggestion out, I go to "My Apps":
    http://i60.tinypic.com/sbou1x.png

    9. Then, in Google Play "My Apps", I go to the "All" tab:
    http://i60.tinypic.com/nn74tc.png

    10. But, again, this fails to show me either the name of
    "Manage Permissions" or the "Guy Fawkes" icon:
    http://i59.tinypic.com/2mwff9k.png (top half)
    http://i57.tinypic.com/r1jyhd.png (bot half)

    The *only* (known) way to figure out that what the "Guy Fawkes" app
    really is, without unpacking the apk zip file, is by Google
    Play trial and error on (all) the *other* similar apps that
    are currently installed, using a process of elimination.

    Either that, or I'd have to snapshot all my apps, and then
    uninstall all my apps, until this particular "Guy Fawkes Manage
    Applications" app dissappeared.

    Then I'd know what the app was!

    IMHO, that's just crazy (but, it is, what it is).
     
    James P. Doolittle, Nov 28, 2014
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.