DNS error on home wireless network after suspend/resume

Discussion in 'Computer Support' started by Lenny H, Jan 8, 2005.

  1. Lenny H

    Lenny H Guest

    Greetings to All,

    I need help with a wireless networking (I think) problem. I live in a shared
    house and just recently we got ADSL and one of the housemates set up a
    router so that we can all connect to the network using either wired or
    wireless means. I have a centrino laptop, so I connect wirelessly and it
    works fine. Really fast. Finds the connection automatically every time I
    boot up. However, when I go in to "stand by" mode (Windows XP Home) and
    later "resume", although the connection is made successfully to the router
    (I can see the icon in the system tray without the "X" and I can see all
    sorts of ip addresses showing up when I do _ipconfig_ at the command line),
    when I fire up a browser and attempt to visit a web page it comes up with a
    DNS error page, that is to say, it is unable to resove web addresses into ip
    addresses. I get the same thing when I ping or tracert.

    Of course, I can simply reboot, and everything is fine. But after a while,
    that starts to get rather annoying. I don't know why this is happening, and
    my understanding of how DNS works is a bit vague, but I imagine there must
    be a DNS server somewhere with an ip address and that somehow it ceases to
    be accessible after I suspend and resume. Whether the DNS server is local or
    remote, I'm not sure. I have tried doing things like
    ipconfig /flushdns
    ipconfig /renew
    ipconfig /release
    ipconfig /registerdns
    but none of them seems to make much difference. I have also tried switching
    the modem off and on using the hardware switch on the side of the laptop.

    I would be most grateful if anyone could shed any light on this problem. Can
    it be fixed? Is it a problem with my machine or with the network? I'd be
    most grateful for any replies.

    Many thanks.
     
    Lenny H, Jan 8, 2005
    #1
    1. Advertisements

  2. Lenny H

    Duane Arnold Guest

    You should do an ipconfig /all when you have a valid connection and note
    the IP(s) for DNS Servers that are at the ISP's location. When you wake
    the laptop up, you should do ipconfig /all to see what the DNS IP(s) are
    at that point.

    You should be able to do and ipconfig /release and ipconfig /renew to get
    the connection to the ISP and access to the ISP's DNS Servers. I don't
    know why that's not working for you.

    You should use a wire connection to the laptop and connect to the router
    letting the machine go into stand by mode and wake it up and see what
    happens.

    If you have a personal firewall on the machine, it could be that the FW
    is suspending all inbound traffic when the machine wakes up and you're
    not aware that it's doing it. I have heard of that problem with some PFW
    (s) and the machine has lost the connection to the ISP.

    Duane :)
     
    Duane Arnold, Jan 8, 2005
    #2
    1. Advertisements

  3. Lenny H

    Lenny H Guest

    Maybe I didn't do them in that order. I'll try that next time.
    I do have Zone Alarm. I was thinking that may be the problem after I posted.
    I'll try disabling that as well and see what happens. Many thanks for your
    trouble. Much obliged. I'll see how it goes and post back.

    best, Lenny
     
    Lenny H, Jan 9, 2005
    #3
  4. Lenny H

    Lenny H Guest

    Hi Duane,

    That worked. Many thanks. Here's what happened.

    I did a quick suspend and resume last night and there was no problem. When I
    resumed this morning, however, there was the usual problem (DNS error page
    in browser). So I checked the ip address of the DNS Server and it didn't
    seem to have changed. In fact, nothing seemed to have changed except the
    Lease Obtained and Lease Expires dates. So then I tried what you suggested
    with ipconfig, namely /release and /renew in that order, and tracert could
    now resolve web addresses find its way to bbc.co.uk.

    What surprised me was at this point the browser still couldn't find the web
    page, but instead of coming up with the DNS error page it came up with a
    small message box saying something like, Sorry web page unavailable, both in
    Mozilla and IE. It was at this point that I decided to close ZoneAlarm. That
    did the trick. Everything worked fine. I opened ZoneAlarm again and it still
    worked fine. So I guess it's going to be /release, /renew, close and open
    ZoneAlarm every time, but I'm going to have to take a closer look at the
    ZoneAlarm documentation and see what I can find.

    Many thanks for all your help.

    best, Lenny
     
    Lenny H, Jan 9, 2005
    #4
  5. Lenny H

    Duane Arnold Guest

    You are welcome.

    You shouldn't have to do the ipconfig /release and /renew. You may want
    to look at using another FW like the free Kerio 2.15 or Sygate and see
    what they do in the situation. I myself use BlackIce on the wireless
    laptop and it doesn't cause an issue when the laptop comes out of stand
    by mode.

    Duane :)
     
    Duane Arnold, Jan 9, 2005
    #5
  6. Lenny H

    Lenny H Guest

    Great. Thanks for the fast reply. Do you guys never sleep? :) I'm off to
    look at some of those other PFW's.

    Thanks!

    Lenny
     
    Lenny H, Jan 9, 2005
    #6
  7. Lenny H

    Duane Arnold Guest

    I am usually out here for a little bit in the AM. There is at least one
    *clown* out here that eats, sleeps and shits the Internet 24/7 365. ;-)

    Later!

    Duane :)
     
    Duane Arnold, Jan 9, 2005
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.