DMA for LPT port

Discussion in 'A+ Certification' started by Dave Hardenbrook, Jan 16, 2008.

  1. I had this issue (I may have posted about it before) with a client with
    a HP OfficeJet All-In-One using LPT1. She could print but not scan, and
    even when she printed, she got the message, "Communication Test Failed",
    & when I looked at the port settings for LPT1, "Enable bi-directional"
    was grayed out. My sleuthing had led me to conclude that there is an
    issue with Printer-to-PC data flow, but addressing the problem further
    has been difficult because she won't let me take the printer to test it
    on another system.

    What I did do is go into BIOS to verify that ECP was enabled (it was),
    and then, in what I have to admit was a wild grasp at straws, I changed
    the DMA from channel 3 to channel 1. Lo and behold, scanning now works!

    What I don't understand is WHY changing the DMA worked -- As I say, I
    was just trying anything at that point. Can anyone cast some light on
    this? My other concern is that even though scanning now works, the
    "Communication Test Failed", error still comes up when anything is
    printed, and "Enable bi-directional" is still grayed out. So I'm
    concerned that the problem isn't really solved and that the scanning
    issues will recur.

    Any thoughts?

    Dave Hardenbrook, Jan 16, 2008
    1. Advertisements

  2. Dave Hardenbrook

    NitsBits Guest

    May be you resolved a conflict.
    Have you tried uninstalling, then re-scanning and subsequently re-
    installing the LPT port?

    Good Luck,

    NitsBits, Jan 16, 2008
    1. Advertisements

  3. Dave Hardenbrook

    smackedass Guest


    While I admire your concern and curiosity as to why this worked, every once
    in a while you've got to say to yourself:

    "All's well that ends"

    The chances of you ever running into this problem again are miniscule. File
    this away, on paper, in the event that this ever does rear its head, you'll
    remember what to do.

    Who ever uses parallel ports these days, anyway? The problem could have
    been just as easily solved by going USB. Not to diminish your efforts, I
    would have done the same thing that you would have done, and then probably
    have asked the same question, but hey, there's something to be said for
    following the path of least resistance.

    smackedass, Jan 17, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.