Dialtone with Asterisk and IXJ and Nortel Venture

Discussion in 'VOIP' started by Dennis Spexet, Feb 25, 2005.

  1. I've got a Asterisk 1.0.5 server with an Internet PhoneJack PCI card
    installed.

    Connected to the PhoneJack PCI card is a Nortel Venture phone. My
    phone.conf file has "mode=dialtone", "format=slinear", "echocancel=off",
    "txgain=100%", "rxgain=1.0", and "device => /dev/phone0". No other changes
    have been made to the configuration.

    When I pick up the phone and go off-hook, I get a dialtone. However, if I
    hang up the phone immediately, the line indicator still shows that the line
    in use. (It looks like the line isn't disconnecting at the Asterisk
    server.) It's a real nuisance, because on the Venture phone, you have to
    press an extra button if you want to join a call that is "in progress"...you
    can't just "pick up the phone".

    The behavior is different, however, depending on what else I do when the
    phone is off-hook. If I pick up the phone and get dialtone, and dial 500 to
    run the "about to try Digium" demo, and THEN hangup while the demo message
    is playing, I'll get a hangup on the line. This is confirmed while running
    "asterisk -vr".

    Is there a configuration setting that I can change in order to fix this?
    I've tried swapping phones, and the other phone I tried (an old Trimline)
    seems to work just fine. But I really like my Nortel Venture phone.

    Thanks much...-Dennis Spexet,
     
    Dennis Spexet, Feb 25, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.