Dialout via RS-232 cable attached to analog modem?

Discussion in 'Cisco' started by Sutto, Oct 16, 2003.

  1. Sutto

    Sutto Guest

    I have a V.90 modem and use it to dial my ISP attached to AUX of a 2500.

    I just scored an RS-232 cable.

    The AUX method uses an Async virtual interface to encapsulate the traffic.
    Does anyone know of a way to dialout via the serial using the 232 cable? Do
    I still use the Async, or a Dialer interface, or am I way off?

    Thanks in advance...

    Sutto
     
    Sutto, Oct 16, 2003
    #1
    1. Advertisements

  2. ~ I have a V.90 modem and use it to dial my ISP attached to AUX of a 2500.
    ~
    ~ I just scored an RS-232 cable.
    ~
    ~ The AUX method uses an Async virtual interface to encapsulate the traffic.
    ~ Does anyone know of a way to dialout via the serial using the 232 cable? Do
    ~ I still use the Async, or a Dialer interface, or am I way off?
    ~
    ~ Thanks in advance...
    ~
    ~ Sutto

    Use the aux. Set the aux to 38400bps. If your ISP gives
    you a single IP address from a pool, then you'll need to
    use "ip address negotiated" and NAT overload, which means
    you'll need relatively recent IOS (11.3 that is - recent
    by 2500 standards.)

    Here's an example. This assumes that you LAN
    is 10.0.0.0/8. If you don't have a DHCP server
    on your LAN, you may want to configure an IOS
    DHCP server. debugs:

    debug dialer
    debug chat line 1
    debug modem
    debug ppp negotiation

    Aaron

    ---

    ip nat inside source list 100 interface Async1 overload
    chat-script callout "" AT OK "ATDT\T" TIMEOUT 60 CONNECT \c\p
    !
    interface Ethernet0
    ip address 10.0.0.1 255.0.0.0
    ip nat inside
    !
    interface async 1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 900
    dialer string 14085703933
    dialer hold-queue 20
    dialer-group 1
    async dynamic address
    async mode interactive
    no peer default ip address
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username cisco password 0 whatever
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Async1 permanent
    ip route 0.0.0.0 0.0.0.0 Null0 200
    !
    access-list 100 permit ip any any
    dialer-list 1 protocol ip permit
    !
    line 1
    modem inout
    speed 115200 ! 38400 if an aux port
    script dialer callout
    flowcontrol hardware
    stopbits 1
     
    Aaron Leonard, Oct 17, 2003
    #2
    1. Advertisements

  3. Sutto

    Sutto Guest

    Thanks Aaron, it works!

    Do you know if there is a way working around the AUX limitation of 38400?
    (ie: use a serial?)

    Cheers,
    Sutto
     
    Sutto, Oct 19, 2003
    #3
  4. The 2500 aux port is limited to 38400 bps;
    there is no workaround. (Newer routers -
    1700s, 2600s, 36/3700s etc. - have 115200 bps
    aux ports.)

    The 2500 serial interfaces only support synchronous
    operation, not async, so there's no way to use them
    with an async modem.

    So - in your case, what you've got now is
    the best you're going to be able to do.

    Aaron

    ---


    ~ Thanks Aaron, it works!
    ~
    ~ Do you know if there is a way working around the AUX limitation of 38400?
    ~ (ie: use a serial?)
    ~
    ~ Cheers,
    ~ Sutto
    ~
    ~ ~ >
    ~ > ~ I have a V.90 modem and use it to dial my ISP attached to AUX of a 2500.
    ~ > ~
    ~ > ~ I just scored an RS-232 cable.
    ~ > ~
    ~ > ~ The AUX method uses an Async virtual interface to encapsulate the
    ~ traffic.
    ~ > ~ Does anyone know of a way to dialout via the serial using the 232 cable?
    ~ Do
    ~ > ~ I still use the Async, or a Dialer interface, or am I way off?
    ~ > ~
    ~ > ~ Thanks in advance...
    ~ > ~
    ~ > ~ Sutto
    ~ >
    ~ > Use the aux. Set the aux to 38400bps. If your ISP gives
    ~ > you a single IP address from a pool, then you'll need to
    ~ > use "ip address negotiated" and NAT overload, which means
    ~ > you'll need relatively recent IOS (11.3 that is - recent
    ~ > by 2500 standards.)
    ~ >
    ~ > Here's an example. This assumes that you LAN
    ~ > is 10.0.0.0/8. If you don't have a DHCP server
    ~ > on your LAN, you may want to configure an IOS
    ~ > DHCP server. debugs:
    ~ >
    ~ > debug dialer
    ~ > debug chat line 1
    ~ > debug modem
    ~ > debug ppp negotiation
    ~ >
    ~ > Aaron
    ~ >
    ~ > ---
    ~ >
    ~ > ip nat inside source list 100 interface Async1 overload
    ~ > chat-script callout "" AT OK "ATDT\T" TIMEOUT 60 CONNECT \c\p
    ~ > !
    ~ > interface Ethernet0
    ~ > ip address 10.0.0.1 255.0.0.0
    ~ > ip nat inside
    ~ > !
    ~ > interface async 1
    ~ > ip address negotiated
    ~ > ip nat outside
    ~ > encapsulation ppp
    ~ > dialer in-band
    ~ > dialer idle-timeout 900
    ~ > dialer string 14085703933
    ~ > dialer hold-queue 20
    ~ > dialer-group 1
    ~ > async dynamic address
    ~ > async mode interactive
    ~ > no peer default ip address
    ~ > no cdp enable
    ~ > ppp authentication pap callin
    ~ > ppp pap sent-username cisco password 0 whatever
    ~ > !
    ~ > ip classless
    ~ > ip route 0.0.0.0 0.0.0.0 Async1 permanent
    ~ > ip route 0.0.0.0 0.0.0.0 Null0 200
    ~ > !
    ~ > access-list 100 permit ip any any
    ~ > dialer-list 1 protocol ip permit
    ~ > !
    ~ > line 1
    ~ > modem inout
    ~ > speed 115200 ! 38400 if an aux port
    ~ > script dialer callout
    ~ > flowcontrol hardware
    ~ > stopbits 1
    ~
     
    Aaron Leonard, Oct 20, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.