Dialer profiles on an 827 ADSL router

Discussion in 'Cisco' started by Paul S. Brown, May 29, 2004.

  1. Does anybody know if it's possible to use multiple dialer profiles on an 827
    for connecting to different DSL endpoints?

    I'm trying to use time-based ACLs to connect it to my work VPN connection
    during business hours and to my residential DSL provider after hours, but
    as far as I can tell it will only let me use the Dialer0 profile. The
    instant the time based ACL kicks in and tries to use the Dialer1 profile I
    start getting a string of "No dialer string defined" if I do "debug dialer"

    The IOS rev is C820-K8OSY6-M 12.2(2)T4

    My current configuration is below.

    P.







    Current configuration : 2715 bytes
    !
    ! Last configuration change at 22:42:42 BST Fri May 28 2004
    ! NVRAM config last updated at 21:03:28 BST Fri May 28 2004
    !
    version 12.2
    no parser cache
    no service single-slot-reload-enable
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname spark
    !
    logging buffered 4096 debugging
    logging rate-limit console 10 except errors
    enable secret 5 <DELETED>
    enable password 7 <DELETED>
    !
    clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00
    ip subnet-zero
    no ip domain-lookup
    ip domain-name <DELETED>
    ip name-server 195.129.15.2
    ip name-server 212.13.197.5
    !
    ip ssh time-out 120
    ip ssh authentication-retries 3
    no ip dhcp-client network-discovery
    !
    !
    interface Ethernet0
    ip address 192.168.1.251 255.255.255.0
    ip nat inside
    ip route-cache same-interface
    no ip mroute-cache
    no cdp enable
    hold-queue 32 in
    ip rsvp bandwidth 128 64

    interface ATM0
    no ip address
    no ip mroute-cache
    no atm ilmi-keepalive
    pvc 0/16 ilmi
    !
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    bundle-enable
    dsl operating-mode auto
    hold-queue 224 in
    !
    interface Dialer0
    ip address negotiated
    ip nat outside
    encapsulation ppp
    no ip mroute-cache
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname <DELETED>
    ppp chap password 7 <DELETED>
    !
    int Dialer1
    ip address negotiated
    encaps ppp
    no ip mroute-cache
    dialer pool 1
    dialer-group 2
    no cdp enable
    ppp pap chap callin
    ppp pap sent-username <USERNAME> password <PASSWORD>
    ppp chap hostname <DELETED>
    ppp chap password 7 <DELETED>

    ip nat inside source list 101 interface Dialer0 overload
    ip classless
    ip route profile
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 0.0.0.0 0.0.0.0 192.168.1.253 64
    ip route 192.168.0.0 255.255.255.0 192.168.1.254
    no ip http server
    !
    logging trap warnings
    logging facility local6
    logging source-interface Ethernet0
    logging 10.1.0.4
    logging 192.168.0.3
    access-list 101 permit ip 192.0.0.0 0.255.255.255 any
    access-list 102 remark ACL for Work Time
    access-list 102 permit ip any any time-range only-during-work-hours
    access-list 103 remark ACL for Play Time
    access-list 103 permit ip any any time-range playtime
    dialer-list 1 protocol ip list 103
    dialer-list 2 protocol ip list 102
    no cdp run
    !
    line con 0
    exec-timeout 120 0
    stopbits 1
    line vty 0 4
    exec-timeout 0 0
    password 7 <DELETED>
    login
    !
    scheduler max-task-time 5000
    sntp server 192.168.0.254
    time-range only-during-work-hours
    absolute start 00:00 01 January 2004
    periodic weekdays 8:30 to 18:30
    !
    time-range playtime
    absolute start 00:00 01 January 2004
    periodic weekdays 0:00 to 8:30
    periodic weekdays 18:30 to 23:59
    periodic Saturday 0:00 to 23:59
    periodic Sunday 0:00 to 23:59
    !
    end
     
    Paul S. Brown, May 29, 2004
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.