Dial Backup from 1750 into a 3640

Discussion in 'Cisco' started by computertech33, Jun 21, 2006.

  1. Hi all....I could really use some help on this one.

    I have one remote site using a 1750 cisco router. Our HQ uses a 3640
    router with a 24port Mica modem module that allows inbound connections.
    I have a 3com external modem attached to the 1750 for dial backup if
    the E0 int goes down. When I disconnect the e0, the modem dials out to
    our 3640 and connects. At that poing, I can ping the 170.1.1.16
    address from my workstation. I can't ping anything on the HQ network
    from the router,hub, or client on the 1750 network. I also have the
    backup interface command pointing to my Async5.


    Here are my configs.

    Thanks
    1750 config

    interface Async5
    ip address 170.1.1.16 255.255.255.0
    encapsulation ppp
    keepalive 10
    dialer in-band
    dialer idle-timeout 300
    dialer string 1800xxxxxxx
    dialer-group 1
    fair-queue
    ppp authentication chap
    !
    interface Dialer1
    no ip address
    no cdp enable

    ip nat inside source route-map nonat interface Ethernet0 overload
    ip kerberos source-interface any
    ip classless
    no ip forward-protocol udp netbios-ns
    no ip forward-protocol udp netbios-dgm
    ip forward-protocol udp netbios-ss
    ip forward-protocol udp xxxxx
    ip route 0.0.0.0 0.0.0.0 gateway of ISP
    ip route 0.0.0.0 0.0.0.0 Async5 200
    no ip http server

    access-list 3 permit any
    access-list 110 deny ip 192.168.16.0 0.0.0.255 172.16.0.0 0.0.255.255
    access-list 110 deny ip 192.168.16.0 0.0.0.255 172.17.0.0 0.0.255.255
    access-list 110 permit ip 192.168.16.0 0.0.0.255 any
    access-list 120 permit ip 192.168.16.0 0.0.0.255 172.16.0.0 0.0.255.255
    access-list 120 permit ip 192.168.16.0 0.0.0.255 172.17.0.0 0.0.255.255
    access-list 121 permit ip 192.168.16.0 0.0.0.255 172.16.0.0 0.0.255.255
    access-list 121 permit ip 192.168.16.0 0.0.0.255 172.17.0.0 0.0.255.255
    priority-list 1 protocol ip high
    dialer-list 1 protocol ip permit
    route-map nonat permit 10
    match ip address 110
    ********************************************
    3640 config

    dialer map ip 170.1.1.16 name test
    ip route 170.1.1.16 255.255.255.255 192.168.16.1 200
    ip route 192.168.16.0 255.255.255.0 170.1.1.16 200

    ********************************************************

    Any help would be greatly appreciated.
     
    computertech33, Jun 21, 2006
    #1
    1. Advertisements

  2. Which physical interface do you have the modem connected to on the
    1750?
     
    Robert B. Phillips, II, Jun 21, 2006
    #2
    1. Advertisements

  3. The AUX port


     
    computertech33, Jun 21, 2006
    #3
  4. OK good. Try adding 'async default routing' on the Async interface. I
    know this is required for a routing protocol to run over the link, not
    sure if it also required for routing in general.
     
    Robert B. Phillips, II, Jun 22, 2006
    #4
  5. You may need to add the 'async default routing' command on the
    Group-Async interface on the 3640 as well.
     
    Robert B. Phillips, II, Jun 22, 2006
    #5
  6. Frequently, this behavior is due to the called router not detecting the need
    to use the dial link to get back to the remote site. You don't show the
    primary route interfaces, so there is no way to tell how your dial backup
    even is supposed to work.

    Hint: for dial backup to work, you need to detect the need to dial (loss of
    primary link), have a mechanism to dial based on that failure (dialer watch
    based on routing protocol exchanges is usually the preferred solution), and
    a mechanism so that all routers involved know to use the new route rather
    than the old route. Depending on the approach, you may also need something
    extra when to switch back to insure that everything goes back the way it is
    supposed to.

    Good luck and have fun! A show ip route at each end while on dial backup
    will probably point you in the right direction for a fix.
     
    Vincent C Jones, Jun 28, 2006
    #6
  7. My Internal network behind the 3640 is 172.17.0.0 and 172.16.0.0.

    If on the 1750, I do an ip route 0.0.0.0 0.0.0.0 async5, won't that
    route all interesting traffic over the async5 interface?
     
    computertech33, Jun 28, 2006
    #7
  8. But what is the route on the 3640 to get back to the 1750? That is where
    most static routed dial backup schemes get it wrong. Have you done a "show
    ip route" at both routers while on dial backup as I suggested in my
    previous response?

    Good luck and good hunting!
     
    Vincent C Jones, Jun 29, 2006
    #8
  9. computertech33

    RC Guest

    You should be using dynamic routing, EIGRP. I did a 20+ site solution using
    these same routers with multiple T1s and ISDN BRI to PRI dialup. Worked
    perfect and I haven't had to change it in years. My client never even
    noticed when one of the T1s went down and the traffic was rerouted through
    another site, thank God I had it configured to notify my syslog or they may
    have stayed that way.

    I do have a question, are you using VoIP? The 1750 is a VoIP router and I
    don't thinks it's going to work very well over a modem connection.


    --
    RC
    rcohen _ "at" _ cominc _ "dot" _ net remove all _ and spaces

    The only thing I guaranty about my free advice is that it's mine and it's
    free.
     
    RC, Jul 1, 2006
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.