Diagnose faulty on-board ethernet port?

Discussion in 'NZ Computing' started by Lodi, Nov 7, 2008.

  1. Lodi

    Lodi Guest

    Hi all...Anyone ever come across a faulty on-board ethernet port.

    Yesterday had me trying to get my niece's desktop back on-line.
    She uses Vista Home and a wired connection to a DSL-302G (the old xtra

    No problem getting my laptop online via the 302-G so the problem wasn't
    with xtra, the modem or the ethernet cable.

    I booted up her desktop using both the SystemRescue Live CD and Knoppix
    5.1 Live DVD but neither would go on-line. "ifconfig eth0" gave, not (the 302-G default).

    As I was pressed for time (and as the 302-G has both ethernet and USB
    options) I got her back online via USB. She's happy.

    I have the feeling I'm missing something as plugging the ethernet cable
    into the ethernet port activates the port's TX/RX "light" (the one which
    blinks off and on really fast when you're receiving/transmitting on-line)
    so I'm guessing that indicates the hardware isn't dead, just that
    something has gone awry.

    I'm heading back to my nieces next week so does anyone have any pointers
    as to how I can diagnose the state of an ethernet port. I can only think
    of "dmesg | grep eth" which isn't much, or ifconfig which may totally
    screw things up. Could BIOS settings be at fault (not likely I know).
    Does Vista eat ethernet ports.

    Both MS and Linux suggestions appreciated.

    Lodi, Nov 7, 2008
    1. Advertisements

  2. Lodi

    Murray Symon Guest

    In Linux check the output of 'dmesg' when plugging and unplugging
    the ethernet. I discovered that on my machine eth0 was disabled by
    "e100_watchdog" whenever the cable was unplugged. This was causing
    the default networking of VMWare server to stop working because it
    relied on eth0 for its bridge.

    Different drivers may well behave differently in this respect.

    unplugging and the replugging gives the following output:
    e100: eth0: e100_watchdog: link down
    e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex

    Murray Symon, Nov 7, 2008
    1. Advertisements

  3. Lodi

    Tony in Oz Guest

    Just swap it for a new card. What are they about 10 bucks? It will
    confirm the diagnosis, and solve the problem.
    Tony in Oz, Nov 8, 2008
  4. Lodi

    Enkidu Guest

    ifconfig lo should show, not ifconfig eth0. is the
    address of the network (assuming the usual netmask) so the
    IP address should be or something.


    Enkidu, Nov 8, 2008
  5. Lodi

    Lodi Guest

    Wish it were that easy but, as the subject says, it's on-board.

    Lodi, Nov 8, 2008
  6. this is what I'd do in windows:

    1- go to the device manager and make sure the device has been detected
    and has the right driver for it installed (shows up and doesn't have a
    yellow exclamation mark next to it).
    2- open a shell, and type ipconfig /all
    3- if it's working and you get a result back, you should now be able to
    ping the router on whatever it shows up as, be it in the 192.168.x.x or
    10.10.x.x range.

    Weird shit happens some times, I reinstalled winxp on a rebuilt box a
    couple of weeks ago and wondered why the win activation didn't work, nor
    did anything else network~ --- then found that the network card had been
    overlooked during the installation by the installer, even though the
    lights were happily blinking away. Go figure. I reseated it in a
    different pci slot and it was duly detected, driver auto-installed and
    everything was go.
    In another case I had to run the motherboard chipset installer for the
    onboard network controller (nvidia) off a memory stick before it became
    active and was detected by windows. This may be your best bet if the
    onboard chip isn't blown.

    The fact that both ~nix and ~doze don't manage to get a network
    connection up bodes ill, though, I suspect.

    Peter Huebner, Nov 8, 2008
  7. Lodi

    Enkidu Guest

    You can have more than one NIC.


    Enkidu, Nov 8, 2008
  8. Lodi

    ~misfit~ Guest

    Somewhere on teh intarwebs "Lodi" typed:
    You can disable it in BIOS and then use a PCI NIC instead.


    DISCLAIMER: If you find a posting or message from me
    offensive, inappropriate, or disruptive, please ignore it.
    If you don't know how to ignore a posting, complain to
    me and I will be only too happy to demonstrate... ;-)
    ~misfit~, Nov 9, 2008
  9. Lodi

    Enkidu Guest

    You don't even need to disable it.


    Enkidu, Nov 9, 2008
  10. Lodi

    ~misfit~ Guest

    Somewhere on teh intarwebs "Enkidu" typed:
    No, but I would.

    DISCLAIMER: If you find a posting or message from me
    offensive, inappropriate, or disruptive, please ignore it.
    If you don't know how to ignore a posting, complain to
    me and I will be only too happy to demonstrate... ;-)
    ~misfit~, Nov 9, 2008
  11. Lodi

    peterwn Guest

    On this topic, just check that it has not been disabled in the BIOS by

    This is what I would have done after verifying that the ethernet setup
    worked OK with a laptop. However full marks to the OP for the way she
    or he has set about diagnosing the problem.

    Even though it may not be necessary to BIOS disable a suspect onboard
    ethernet 'circuit', this would be 'best practice' since it better
    isolates suspect hardware, frees up resources in general and avoids
    the possibility of having two ethernet cards showing which could cause
    peterwn, Nov 9, 2008
  12. Lodi

    Lodi Guest

    He, last time I looked.

    Thanks to all who replied. Most appreciated.

    Lodi, Nov 9, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.