DHCP: Suddenly "Acquiring IP Address" always fails

Discussion in 'Wireless Networking' started by james.lungu, Oct 17, 2006.

  1. james.lungu

    james.lungu Guest

    I have the following situation ...

    I am running MS Windows XP Pro SP2(+) and recently started using a
    Linksys PCMCIA wireless network card while travelling for work. I was
    using the Linksys connection Manager and Windows Wireless Zero
    Configuration was automatically starting @ login. Everything was
    running fine for nearly a month when I suddenly was unable to acquire
    an IP address via DHCP. I am only attempting to attach to unsecured
    networks (hotels, hotspots and the like). No software was installed by
    me and I have run checks for malware, adware, etc using SpySweeper and
    Ad-Aware - nothing was found (gotta give a plug to Avast! anti-virus).

    I have no problem on my home network (wired) where the IP is static. I
    am able to connect to the hotel's wireless network by assigning a
    static IP, DNS and Gateway ... so I know the card is good.
    Unfortunately, I'm not always privvy to this information when
    connecting to a hotspot @ the airport, work or other locations.

    After failing to acquire an IP via DHCP, it defaults to one of the IPs
    provided by the Windows OS 169.x.x.x and a subnet mask of 255.255.0.0.
    I recently set up an "Alternate Configuration" with static IP
    information for the hotel in which I am staying so I don't have to futz
    w/ it there. The IP now defaults to the "Alternate Configuration" for
    all wireless connection attempts (only working @ the hotel of course)
    after failure to acquire an IP via DHCP.

    Things I have tried without any results:
    ** Rebooting ... oh, have I been @$#^&! rebooting.
    ** Repair from the taskbar icon.
    ** Release / renew using ipconfig
    ** netsh int ip reset resetlog.txt
    ** Running LSPfix.exe (no problems found)
    ** Running WinSockXPfix.exe 1.2
    ** Disabling on-access virus protection
    ** Disabling the Windows firewall
    ** Removing the Linksys Connection Manager and reinstalling.
    ** Reinstalling drivers only and using Windows Wireless Zero
    Configuration
    ** Disabling Wireless Zero Configuration and Using only the Linksys
    Connection Mgr
    ** Using the T-Mobile WiFi Connection Manager (w/ and w/o Wireless Zero
    Configuration enabled)
    ** applying Microsoft Patch KB884020 and setting the following registry
    key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\IPSec]
    "AssumeUDPEncapsulationContextOnSendRule"=dword:00000002

    So my guess is that there's something in the registry which has somehow
    gotten hosed and none of the above solutions is fixing it. Basically
    I've done everything (I believe) short of repairing or re-installing
    the OS. While I'm certain that would work, that's not an answer I'm
    interested in. I can't believe there isn't a way to FIX the problem.
    This has always been one of my primary complaints regarding MS products
    - I do not consider re-installing the product as "fixing" the problem
    (that's like telling me to buy a new car every time it stalls).

    Thanks in advance for any suggestions.
     
    james.lungu, Oct 17, 2006
    #1
    1. Advertisements

  2. Hi

    In principle, you should Not use Windows Zero Configuration (WZC), and the
    Original (or any other Wireless manager) at the same time.

    By use, I mean that if you prefer the Original Brand manger log to Windows
    services and disable the WZC service.

    If you prefer the easiness and elegancy of WZC, make sure that the original
    Brand Wireless utility is out of the system. You can leave the software
    installed on the Hard Drive, but make sure that none of the utility parts
    loads at Startup, or and starts its own service.

    Could be that by now some thing is already conflicting in the registry. You
    can try to uninstall the Linksys Utility. Disable WZC, take out (or disable
    the Wireless card) reboot once without Wireless, run a Registry cleaner, and
    reinstall the wireless from scratch.

    WZC service management here, http://www.ezlan.net/wzc.html

    Method to control StartUp, and see what actually run in background here,
    http://www.ezlan.net/infestation#startup

    Jack (MVP-Networking).


     
    Jack \(MVP-Networking\)., Oct 17, 2006
    #2
    1. Advertisements

  3. james.lungu

    james.lungu Guest

    Jack,

    BINGO!! You nailed it. Clean the registry after turning off /
    disabling all conx mgrs. There were only a couple of entries in there
    that appeared related to wireless, but all it takes is one.

    Should've thought of that one myself ... Thanks for the nudge!

    James
     
    james.lungu, Oct 18, 2006
    #3
  4. james.lungu

    MHPNW STAFF Guest

    Given that you are running windows xp, you might 1st try system restore next
    time you have a problem with your system. faster to go back a few hours ,
    than to spend a few hours installing , and uninstalling..

    Just a thought,

    Dennis
     
    MHPNW STAFF, Oct 18, 2006
    #4
  5. james.lungu

    Mike Hyndman Guest

    I'm having a similar problem with my Belkin Router and a wireless laptop
    card, it will be given an IP address, sometimes after quite a while, run for
    a few minutes, then lose it again. I am only three feet away from the
    router!
    I tried the link , http://www.ezlan.net/wzc.html and I already have the
    DWORD "start" set to 2 in the registry, yet the WZC is running on the
    taskbar along with the Belkin utility. If I disable the WZC from the
    taskbar, I lose the Belkin and the only way I can get it back is via a
    system restore. (Service.msc shows it set to automatic and starting manually
    does not start it.

    MH
     
    Mike Hyndman, Oct 18, 2006
    #5
  6. Hi
    It is hard to account to every "ploy" that is used by many Brands. I am not
    familiar with the Belkin's Utility. May be it is not a stand alone
    application and needs WZC. Log to Belkin's Support site, and try to find
    the exact description of the software, and their recommendations.
    Jack (MVP-Networking).

     
    Jack \(MVP-Networking\)., Oct 18, 2006
    #6
  7. james.lungu

    Guest Guest

    Hi James
    What tool did you use to clean the registry and what entrie was the problem

    with kind regards
    John
     
    Guest, Oct 19, 2006
    #7
  8. In the Belkin Utility, tick the box that says Use the Windows XP wireless
    utility and 'save'. Then using 'msconfig', under 'startup' disable the entry
    that has the model/part number of your belkin adapter. Reboot, and you
    should be able to use the WZC system. However, if you try to load the Belkin
    utility at any stage, you will cut yourself off again until you reboot.

    Mike Bernstein

     
    Mike Bernstein, Oct 22, 2006
    #8
  9. james.lungu

    Alan Guest

    As a side note, don't use anything other than Internet Explorer
    to access the Belkin router to make changes to the configuration.
     
    Alan, Oct 22, 2006
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.