Dell NAS 2003 r2 64 bit server NFS mapping

Discussion in 'Windows 64bit' started by Guest, Aug 16, 2006.

  1. Guest

    Guest Guest

    I cannot get any UNIX accounts (other than root) to have permissions to
    access an NFS mount.

    I have copied to the NAS the passwd and group file that is the same for all
    *NIX machines. Can mount as root and create files, but other users have
    permission denied when trying to navigate into mount.
    In the past I have chmod 777 the mount directory before mounting to it to
    ensure all users have permission to use the mount point. When I mount the
    share, the directory changes to drwx----- and the UID/GID changes to numeric
    numbers.

    Microsoft Services for NFS settings:
    User Name Mapping Server:
    localhost
    User Name Mapping :
    Use Password and Group files
    Simple Mapping:
    Unchecked
    User Maps:
    1-to-1 mapping of root and a single user account.
    Group Maps:
    root=>Administrators
    user=>Users
    Server for NFS:
    Default settings

    Share properties:
    Sharing Permissions:
    Everyone - Full control
    NFS Sharing:
    Allow anonymous access is unchecked.
    Permissions:
    All Machines Read-Write
    Allow root access is checked.

    Here is my current configuration:
    Network:
    Peer-to-Peer configuration no domain controllers or NIS servers.
    Hardware:
    Brand new PowerEdge 2950 with Windows 2003 R2
    Fedora Core 4 servers trying to mount as clients

    Does anyone have a step by step example using the new R2 controls to perform
    the simple task?

    We have tried all configurations we can think of and are stuck.

    Thanks- Rick
     
    Guest, Aug 16, 2006
    #1
    1. Advertisements

  2. Richard -
    A classic example of an authentication problem, as I'm sure you know.
    I'm actually in the middle of re-writing my popular SFU Authentication
    whitepaper for R2, but it won't be out and available for at least a month.
    And I honestly haven't done any work at all with a NAS box or much with R2
    yet. But your best bet is to post this on the
    microsoft.public.servicesforunix.general newsgroup, even though it's a 64bit
    box.

    I'm betting, from your description, that you're somewhere between using User
    Name Mapping and using the native AD controls of R2, and neither is working.
    The R2 controls are purely Active Directory, so if you're running this in a
    non-domain setting, you must use User Name Mapping and you'll also need to
    use Server for NFS Authentication, since you won't get the plus of Server
    2003 AD. To use UNM, follow the exact steps in the old SFU3 authentication
    whitepaper
    (http://www.microsoft.com/technet/interopmigration/unix/sfu/nfsauth.mspx).
    From the sounds of things, your .maphosts may not be configured, or you may
    not have Server for NFS Authentication installed, but start by reading the
    whitepaper, and then move this discussion over to the SFU newsgroup.
     
    Charlie Russel - MVP, Aug 16, 2006
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    Thanks for the quick response.
    I have followed threads that mention the re-write.
    I will be able to look into your response later in the day.
    I will send feedback to the group after that.
    Thanks-
    Rick
     
    Guest, Aug 16, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.