DDR with dialer profiles

Discussion in 'Cisco' started by Steve H, Jan 20, 2004.

  1. Steve H

    Steve H Guest

    Hi All,

    I've been working my way through the CiscoPress CCNA Library, and I'm
    stuck on something.

    In the ICND book, there's an example of using a Dialer Profile with 2
    BRIs for DDR to multiple remote sites (p. 357). The config follows:

    ip route 172.16.3.0 255.255.255.0 172.16.2.1
    ip route 172.16.4.0 255.255.255.0 172.16.2.3
    !
    username LosAngeles password Clark
    username GothamCity password Bruce
    !
    isdn switch-type basic-ni1
    !
    access-list 101 permit tcp any host 172.31.3.1 eq 80
    access-list 101 permit tcp any host 172.31.4.1 eq 21
    !
    dialer-list 2 protocol ip list 101
    !
    interface dialer 0
    ip address 172.16.2.2 255.255.255.0
    encapsulation ppp
    ppp authentication chap
    dialer idle-timeout 300
    dialer fast-idle 120
    dialer map ip 172.16.2.1 broadcast name LosAngeles 1405551234
    dialer map ip 172.16.2.3 broadcast name GothamCity 1999999901
    dialer-group 2
    dialer pool 3
    !
    interface bri0
    encapsulation ppp
    ppp authentication chap
    isdn spid1 555555111101
    isdn spid2 555555222202
    dialer pool-member 3
    !
    interface bri1
    encapsulation ppp
    ppp authentication chap
    isdn spid1 555555333301
    isdn spid2 555555444402
    dialer pool-member 3
    !
    router igrp 6
    network 172.16.0.0
    !


    It's all ok, except for trying to add the dialer map to the dialer 0
    interface - "dialer map" is not a valid statement in the configuration
    context.

    Is there something I'm doing wrong, or is this a mistake in the book?
    I haven't found anything in the book's errata regarding this....

    I've had a look at CCO and the only examples I can find of using a
    pool of BRIs to connect to multiple different sites use a dialer
    interface per remote subnet and consequently don't need dialer maps,
    as they can just use dialer strings instead.

    (btw I've tried this on an aging 4000-M with NP-4B-S/T running IOS
    12.1(22), and also on 2610 with NM-4B-S/T running 12.2(3))

    Many TIA of any help received.

    Steve
     
    Steve H, Jan 20, 2004
    #1
    1. Advertisements

  2. As far as I know dialer maps are not supported on dialer interfaces. So
    I think it is a mistake in the book.
     
    Helmut Ulrich, Jan 20, 2004
    #2
    1. Advertisements

  3. Dialer maps are permitted on dialer rotary interfaces (aka
    "legacy dialer"), but not on dialer profiles.

    Indeed, the configuration below is quite incorrect. To dial
    two remote sites, EITHER use a separate dialer profile to
    dial each site (which is what I'd recommend), or ELSE use
    one dialer rotary interface with two dialer maps.

    Aaron

    ---

    ~ As far as I know dialer maps are not supported on dialer interfaces. So
    ~ I think it is a mistake in the book.
    ~
    ~
    ~ Steve H schrieb:
    ~ > Hi All,
    ~ >
    ~ > I've been working my way through the CiscoPress CCNA Library, and I'm
    ~ > stuck on something.
    ~ >
    ~ > In the ICND book, there's an example of using a Dialer Profile with 2
    ~ > BRIs for DDR to multiple remote sites (p. 357). The config follows:
    ~ >
    ~ > ip route 172.16.3.0 255.255.255.0 172.16.2.1
    ~ > ip route 172.16.4.0 255.255.255.0 172.16.2.3
    ~ > !
    ~ > username LosAngeles password Clark
    ~ > username GothamCity password Bruce
    ~ > !
    ~ > isdn switch-type basic-ni1
    ~ > !
    ~ > access-list 101 permit tcp any host 172.31.3.1 eq 80
    ~ > access-list 101 permit tcp any host 172.31.4.1 eq 21
    ~ > !
    ~ > dialer-list 2 protocol ip list 101
    ~ > !
    ~ > interface dialer 0
    ~ > ip address 172.16.2.2 255.255.255.0
    ~ > encapsulation ppp
    ~ > ppp authentication chap
    ~ > dialer idle-timeout 300
    ~ > dialer fast-idle 120
    ~ > dialer map ip 172.16.2.1 broadcast name LosAngeles 1405551234
    ~ > dialer map ip 172.16.2.3 broadcast name GothamCity 1999999901
    ~ > dialer-group 2
    ~ > dialer pool 3
    ~ > !
    ~ > interface bri0
    ~ > encapsulation ppp
    ~ > ppp authentication chap
    ~ > isdn spid1 555555111101
    ~ > isdn spid2 555555222202
    ~ > dialer pool-member 3
    ~ > !
    ~ > interface bri1
    ~ > encapsulation ppp
    ~ > ppp authentication chap
    ~ > isdn spid1 555555333301
    ~ > isdn spid2 555555444402
    ~ > dialer pool-member 3
    ~ > !
    ~ > router igrp 6
    ~ > network 172.16.0.0
    ~ > !
    ~ >
    ~ >
    ~ > It's all ok, except for trying to add the dialer map to the dialer 0
    ~ > interface - "dialer map" is not a valid statement in the configuration
    ~ > context.
    ~ >
    ~ > Is there something I'm doing wrong, or is this a mistake in the book?
    ~ > I haven't found anything in the book's errata regarding this....
    ~ >
    ~ > I've had a look at CCO and the only examples I can find of using a
    ~ > pool of BRIs to connect to multiple different sites use a dialer
    ~ > interface per remote subnet and consequently don't need dialer maps,
    ~ > as they can just use dialer strings instead.
    ~ >
    ~ > (btw I've tried this on an aging 4000-M with NP-4B-S/T running IOS
    ~ > 12.1(22), and also on 2610 with NM-4B-S/T running 12.2(3))
    ~ >
    ~ > Many TIA of any help received.
    ~ >
    ~ > Steve
     
    Aaron Leonard, Jan 20, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.