DDR misconfiguration leads to strange single-ping?

Discussion in 'Cisco' started by nemo, Mar 9, 2006.

  1. nemo

    nemo Guest

    I've recently resolved a strange symptom on a 2600 configured for DSL,
    PPoE, and PAT. I'm still getting up to speed on Cisco, and I know this
    is a "duh" on my part, but in hindsight I'm curious why we observed the
    particular symptom we did. My understanding of ATM is vague here, as
    well as DDR as it applies to ATM / DSL.

    The problem was that Dialer1 did not have a dialer-group entry, and
    correspondingly there was no dialer-list set up. DDR didn't occur to me
    immediately because I'm accustomed to seeing DDR on circuit-switched
    links (ISDN), not packet/cell-switched lines. (Why do you need
    interesting traffic for a line that's always on?)

    With the absence of dialer-group and dialer-list, we'd observe hosts
    that could ping any destination *once*, followed by timeouts. The 2600
    itself could ping all day long, and any hosts configured for NAT
    instead of PAT. So here's where I'm also confused - why is one ICMP
    packet getting through? Is the call coming up and immediately being
    torn down? (And not in a timing sense, but in an actual layer 3 sense?)

    Or is there something more that I'm yet still missing?

    Thanks for feedback!

    ! Edited for relevancy, anonymity.
    !
    version 12.2
    hostname foo
    !
    vpdn enable
    !
    vpdn-group pppoe
    request-dialin
    protocol pppoe
    !
    voice call carrier capacity active
    !
    mta receive maximum-recipients 0
    !
    interface ATM0/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    no fair-queue
    hold-queue 224 in
    !
    interface ATM0/0.1
    point-to-point
    pvc 0/35
    pppoe-client dial-pool-number 1
    !
    interface FastEthernet0/0
    ip address 10.0.0.1 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    duplex auto
    speed auto
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username foo password 0 bar
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    !
    access-list 1 permit any
    dialer-list 1 protocol ip permit
    !
    call rsvp-sync
    !
    no mgcp timer receive-rtcp
    !
    mgcp profile default
    !
    dial-peer cor custom
    !
    end
     
    nemo, Mar 9, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.