damn loop

Discussion in 'Cisco' started by John Smith, Mar 14, 2005.

  1. John Smith

    John Smith Guest

    Hi,





    I have a new cisco 2970 switch.

    I need to turn off all non IP and non arp traffic.



    I have cdp turned off with no cdp run.

    I have spanning tree gone with

    no spanning-tree vlan 1



    I still see this loopback protocol on each port every 10 seconds.



    How do I turn it off.?

    I tried the documented commands but they don't work.

    No spanning-tree loopguard disable

    spanning-tree loopguard disable

    no spanning-tree loopguard enable



    I tried a few other ones but can't stop the traffic.



    I am running ios 12.1





    I used to always buy cisco but I am definitely seeing my support from them
    drop in quality. Has anyone else considered major migrations away from
    cisco products to either hatachi , HP, juniper , or whatever? Cisco works
    or used to work well when all the equipment is cisco and at the same IOS.
    But I can't maintain a pure cisco network at the same ios.





    Sorry for the rant but simple configs should be simple to do.



    Thanks in advance
     
    John Smith, Mar 14, 2005
    #1
    1. Advertisements

  2. John Smith

    Dan Daniels Guest

    Router(config-if)no keepalive
     
    Dan Daniels, Mar 14, 2005
    #2
    1. Advertisements

  3. I still see this loopback protocol on each port every 10 seconds.

    interface (mumble)
    no keepalive

    This is not a spanning tree packet. This is a packet used by Cisco routers
    from the beginning of time to test for soft network failures.

    Why do you want the device to send no traffic at all?
    If you have some specific examples you'd like to tell me about, drop a note
    to .
    Can you be more specific? Is the fact that different product lines
    (switches routers) run different versions of code the issue? How so?
    I agree. Usually, it is not a good idea to turn off all diagnostic packets,
    but I assume you have a business reason for the switch to be dead silent.
    You just run some risks doing that, including looped links (no spanning
    tree), soft-link failures (no loopback), or invisibility to management
    stations (no CDP).
     
    Phillip Remaker, Mar 14, 2005
    #3
  4. John Smith

    Zee Guest

    the catalyst switch series doesn't send it, at least not by default.
    To measure distributed application traffic and capture it during tests.
    Also a few other reasons.
    Try doing an etherchannel between one of the catalyst 2900's that were end
    of lifed last November to the new 2970 series. It will work for a while but
    then the old catalyst will start receiving a lot of errors and become
    unusable. It will only work with one cable. Yes, I pinned both sides to
    100/ full
    I agree in a large network this is a very bad idea. But when testing
    equipment ,software and taking measurements you really need a easy way to
    make a switch to spew anything that you'll have to keep track of.

    Just a suggestion from a user.

    Ending on an up side the web interface is getting better in the new
    switches.
     
    Zee, Mar 17, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.