D-Link DSL-200 rev.B1 and IPCop 1.4.5

Discussion in 'NZ Computing' started by Dany P. Wu, May 9, 2005.

  1. Dany P. Wu

    Dany P. Wu Guest

    Hi everyone,

    My old faithful Alcatel Speedtouch is dead/dying and I've been given the
    abovementioned modem.

    I downloaded a whole bunch of synch.bin files (55 of them) and haven't got a
    clue which one to use. Has anyone successfully got this modem working with
    IPCop in New Zealand? If so, which synch.bin file did you use? Or am I
    doomed to have to try all 55 of them? I'm just about on my knees hoping
    somebody on here has successfully got it working...........

    TIA
    Dany.
     
    Dany P. Wu, May 9, 2005
    #1
    1. Advertisements

  2. Dany P. Wu

    Malcolm Guest

    Hi
    What is the problem with the Speedtouch?
     
    Malcolm, May 9, 2005
    #2
    1. Advertisements

  3. Dany P. Wu

    Dany P. Wu Guest

    It's physically buggered - or getting that way fast. At the moment it's held
    together with duct tape. Unfortunately it had a nasty encounter with a heavy
    box :(

    It will probably survive for ages but I'd rather have a backup handy in case
    it dies.

    Speaking of the other D-Link one I have just tried all 55 synch.bin files
    with no success.

    D.
     
    Dany P. Wu, May 9, 2005
    #3
  4. Dany P. Wu

    Malcolm Guest

    Send me an email and will see if can sort out a new case for you.
     
    Malcolm, May 9, 2005
    #4
  5. Dany P. Wu

    Dave Taylor Guest

    FWIW
    IPCop 1.4.6 is coming very soon. It is in beta at the moment; I don't
    see specific VPN stuff though 8( :

    From the dev list


    As usual, this version can be installed as an update from previous v1.4.x
    versions or with a ready-to-go ISO for a fresh install.
    Install update and restart connection to make the new dnsmasq version
    run.

    Sourceforge site
    http://prdownloads.sourceforge.net/ipcop/ipcop-1.4.6test1.iso
    http://prdownloads.sourceforge.net/ipcop/update-1.4.6test1.tgz.gpg
    http://prdownloads.sourceforge.net/ipcop/sources-ipcop-1.4.6test1.tgz
    http://prdownloads.sourceforge.net/ipcop/fcdsl-1.4.6test1.tgz

    Alternate download site
    http://g.esp.free.fr/download/ipcop/ipcop-1.4.6test1.iso
    http://g.esp.free.fr/download/ipcop/update-1.4.6test1.tgz.gpg
    http://g.esp.free.fr/download/ipcop/sources-ipcop-1.4.6test1.tgz
    http://g.esp.free.fr/download/ipcop/fcdsl-1.4.6test1.tgz

    MD5: 753b00658a996de625c779334768d0a6 fcdsl-1.4.6test1.tgz
    MD5: b83eed991e392dd8346171088aac9fb8 ipcop-1.4.6test1.iso
    MD5: 99bc31079b1b7be5d94b22d388b04b3b sources-ipcop-1.4.6test1.tgz
    MD5: d083bb952ccfefa6b3f98ed881dbec45 update-1.4.6test1.tgz.gpg

    For frizt dsl modems, fcdsl-1.4.6.tgz has nothing changed from
    fcdsl-1.4.5/1.4.4.

    Short changes summary
    - Upgrade to snort-2.3.3 and use oinkmaster-1.2 to update rules.
    Use /var/ipcop/oinkmaster.conf if you want to keep a particular rule
    setting even with rules update.
    - Fix tcpdump CAN-2005-12{78|79|80} denial of service,
    - Fix gzip CAN-2005-1128 with gunzip -N,
    - Fix vim CAN-2004-1138,
    - Fix ibod - Advisory #10 No System Group
    - In setup, don't abort but use english when (zh,lt,ro,ru,th) is selected
    from web interface SF1178604
    - For a static IP (not with PPP), remove default gateway before applying
    again in case it was changed SF1175052
    - Remove sitefinder workaround no more necessary and the address is
    reused
    SF1178122
    - Fix dhcpc.cgi unable to add or edit fixed DHCP leases SF1174069
    - Fix undesired reconnection when persist option was used with timeout,
    and
    dial on demand in now in use SF1171610
    - Fix 'other countries' selection with eagle-usb interface
    - Allow easydns and zoneedit to update without a HOSTNAME
    - Fix dyndns ip behind router not updated correctly SF1168178
    - Disable HTTP OPTIONS method
    - Fix wrong firmware selection during upload with speedtouch SF1185503 &
    1185818
    - Fix start squid if enabled on blue or green SF1144280
    - Fix various typo with vpnmain.cgi, a possible crash of the interface on
    a
    click on erase
    - Fix DDNS erase ipcache file when force update is launched SF1158510
    - Upgrade dnsmasq to 2.22 to fix bugs introduced in 2.21
    - Remove in rc.netaddress.up call to dsnmask and ipsecctrl (fix SF11752
    ??)
    - Add a Snort log section in System logs
    - Stop and clear module help on reboot for Conexant PCI and usb adsl
    SF1185833
    - Display Internet IP in index.cgi in case of dyndns use and behind a
    router
    - Upgrade to bind-9.2.5,dnsmasq-2.22, pppt-1.6.0, wireless-tools.27.

    More details on doc/ChangeLog or on CVS

    !!! Install only add-ons compatible with v1.4.4 and later. !!!

    Report success or failure on the devel list, in particular if you use a
    VPN.
    Final version is programmed for the 10 May
    All that I can promise to tester if that they should be able to directly
    install final update-1.4.6 if something more is fixed before the 10.



    -------------------------------------------------------
    This SF.Net email is sponsored by: NEC IT Guy Games.
    Get your fingers limbered up and give it your best shot. 4 great events,
    4
    opportunities to win big! Highest score wins.NEC IT Guy Games. Play to
    win an NEC 61 plasma display. Visit http://www.necitguy.com/?r=20
    _______________________________________________
    IPCop-devel mailing list

    https://lists.sourceforge.net/lists/listinfo/ipcop-devel
     
    Dave Taylor, May 9, 2005
    #5
  6. Dany P. Wu

    SteveM Guest

    Dany, Try:
    http://eciadsl.flashtux.org/modems.php?modem=65

    Looks like it uses a beta version of a different sync.bin than the
    other ECI based DSL modems.

    SteveM
     
    SteveM, May 9, 2005
    #6
  7. Dany P. Wu

    Dany P. Wu Guest

    Thanks for that Steve - unfortunately I've tried that one too. Uploading the
    new file, unplugging/replugging the modem didn't bring the ADSL light on at
    all. I'm assuming that's all I have to do, of course....

    D.
     
    Dany P. Wu, May 9, 2005
    #7
  8. Dany P. Wu

    SteveM Guest

    No!
    You need to completely restart IPcop. The upload of the sync.bin file to
    the DSL modem takes place during the boot process.

    What I used to do......
    1 Upload new Sync.bin in IPCop
    2 Save config
    3 shutdown IPCop box (and turn off power)
    4 Cycle ADSL modem power
    5 Restart IPCop
    With my Dynalink 070 modem, During the boot process the DSL light would
    flash and then go solid when it had synced with the DSLAM. The boot
    process will wait for this to happen, unless it takes too long (cause I
    was using the wrong file), and times out. It would go on to boot but
    would never sync.

    I have not used the DLink unit you have, but the main thing to look for
    is the modem syncing during the boot process. If the DSL light goes solid
    you are probably OK!

    SteveM
     
    SteveM, May 9, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.