CW LMS 2.2

Discussion in 'Cisco' started by Michael Schubbert, Jan 19, 2004.

  1. I don't see routers behind a ISDN leased line in the topology services of
    the campus manager. is this possible? "jump router boundaries" is checked
    and i see all the other equipment.

    Michael
     
    Michael Schubbert, Jan 19, 2004
    #1
    1. Advertisements

  2. Michael Schubbert

    Brian V Guest

    Hi Michael,

    As long as you can see it via CDP it will show up in CM. CM relies on
    CDP for it's discovery. One word of caution before enabling CDP on an ISDN
    link is that it will keep the line up forever. If your paying by the minute
    this will be a big shock when you get the bill.
    The other thing that it can be is that when CM is scheduled to do it's
    minor and major aquisitions(sp?) that the link is down. I think defaults on
    CM for discovery are 4hrs for major, 1hr for minor.
    Good luck,
    Brian
     
    Brian V, Jan 19, 2004
    #2
    1. Advertisements

  3. Thanks Brian,

    because it's a leased line the link is up for 24 hours/day. i have enabeled
    CDP on both sides and i the see with "show cdp neigh details" both sides
    with its correct ip address. this ip can be reached from the ani-server, the
    snmp communities are correct and the device is in the device list of the
    managed (!) device list of rme. the configs are updated through rme and they
    are in the archiv. only the second router and devices on this side are not
    displayed in the campus manager topology. so it looks for me that i have to
    "enabled" discovery over isdn links. any ideas?

    Thanks
    Michael
     
    Michael Schubbert, Jan 20, 2004
    #3
  4. Michael Schubbert

    Brian V Guest

    Hi Michael,

    Was CDP on prior to this or did you just enable it? Did you try right
    clicking the topology map and force a rediscovery?
    If it's in the RME database it should be on the topology map unless
    someone deleted it from the saved view. To verify this create a temporary
    user acount..... Server configuration>>setup>>security>>users then log in as
    that user, look at the map and see if you see the ISDN device.
    ISDN without a doubt works fine thru CM as I have that working at dozens
    of customer sites.
    Couple other things to try.....
    1, bump up the discovery performance settings to about 75%....Server
    config>>setup>>ani server admin>>performance settings. After you set it at
    75% reboot the CW server.
    2, You can try sync'n from RME since the device is in RME. Server
    config>>ani server admin>>device sync>>sync from essentials tab then check
    off receive from essentials, click apply, then click run
    Good luck,
    Brian
     
    Brian V, Jan 20, 2004
    #4

  5. Michael,

    As well as the steps that Brian suggested, also have a look at your
    DNS (or hosts file on your CW server if you don't use DNS).

    CW is very touchy about name resolution. We have a complete mess with
    ours at the moment because the responsibility for DNS has been
    transferred (temporarily I hope) to another team (because DNS has been
    incorporated in AD) and they have made lots of mistakes in the DNS
    setup.

    If the devices at the other end of the leased line aren't in your DNS,
    it could be causing some of your problems.

    Pete
     
    Pete Mainwaring, Jan 21, 2004
    #5
  6. Hi Brian,
    No, the devices were never in the view. i tried to create a new user, no
    device.
    i have had the performance settings at 115 (max 145), cause its a
    multi-cpu-machine.
    i did this, i get a reply "finish bulk syncgrisization from essentials"
    immediately, but i'am not shure, if CW did it. perhaps i have to wait a
    while.
    i don't understand this, is it my bad english? i do a "cdp run" in global
    mode on both routers and a"cdp enable" on the interfaces bri0. show cdp
    neigh works fine on both devices
    the only devices, i have these problems are the remote-isdn-devices (3
    sites, Cisco 801). the rest (280 devices) with no problems, i will try
    another router-model (26xx) in my lab at weekend.

    i will tell the result here.

    thanks
    Michael
     
    Michael Schubbert, Jan 21, 2004
    #6
  7. Hi Pete,

    we use DNS and it works fine, but i have no device-names in the DNS or in my
    lokal HOST-File, only the name of the CW-Server is there.

    The other devices works fine (280), only the 3 isdn remote-router make
    problems.
    Which name have i to put in the DNS? the hostname/sysname of the router?

    I will try this. I will tell the result here.

    Thanks
    Michael
     
    Michael Schubbert, Jan 21, 2004
    #7
  8. now i found the sync in the anysync.log. its well done and the 3
    isdn-remote-router are sync too but still not in any device tabel of campus.
     
    Michael Schubbert, Jan 21, 2004
    #8
  9. Michael Schubbert

    Brian V Guest

    If it's showing up in the logs, it should be in the topology.
    Last ditch efforts:
    1, make sure you have all the cw patches applied, there's about 12 of them
    right now for LMS2.2. They need to be done in a specific order or basically
    your screwed and you will need to fully reload CW. Make sure you read all of
    the release notes, it will tell you what order and what the
    prereqiusits(sp?) are.
    2, If they were ever in the topology try a restore from a backed up
    database.
    3, Reload CW. Don't just do a repair, but uninstall, delete all the old
    files.
    4, Call TAC
    Good luck!
    -Brian
     
    Brian V, Jan 22, 2004
    #9
  10. i will tell the result here.

    i did many hours in the lab:

    here is the result:
    i do not see the remote side in any view, when there is a 801-801 isdn
    leased line.
    when i have the remote 801 as a seed device, it is discovered as
    "unconnected devices", the switch on the remote side is not discovered,
    until its a seed device too.
    a remote 80Xer and the switch is discovered, when there is a isdn dial-line
    (not leased line) or a x21 leased-line.

    the cdp, snmp, dns stuff is correct and there are no problems with the other
    equipment. the missing 801er-isdn-leased-line is for many years, since cisco
    works 2000, cisco works lms Cd one 4th, 5th and now cisco lms 2.2 with
    update 1 and several patches and idus. i have several ios for the 801er
    (12.0-12.2)

    has someone this enviroment (801er-801er leased line with hdlc or ppp) and
    no probs?
    any ideas???? thanks
    Michael
     
    Michael Schubbert, Jan 29, 2004
    #10
  11. Michael Schubbert

    Brian V Guest

    Michael,
    Post your configs for the 801's
    -Brian

     
    Brian V, Jan 29, 2004
    #11
  12. Central-Side: Heckenstr_R1
    Remote-Side: Heckenstr_R2
    Remote-Side: Heckenstr_SW1

    In the Topology Layer 2 View i see only Heckenstr_R1

    when i set Heckenstr_R2 as seed device it is discovered but displayed in
    "Inconnected Devices View" with no(!) neighbors. I don't see the switch.

    Michael

    here are the configs:

    Central-Side:

    version 12.1
    no service single-slot-reload-enable
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    !
    hostname Heckenstr_R1
    !
    logging rate-limit console 10 except errors
    enable secret X
    !
    username Heckenstr_R2
    clock timezone cet 1
    ip subnet-zero
    !
    no ip domain-lookup
    no ip finger
    isdn switch-type basic-net3
    isdn voice-call-failure 0
    isdn leased-line BRI0 128
    !
    !
    !
    interface Ethernet0
    ip address 10.1.252.5 255.255.252.0
    !
    interface BRI0
    ip address 10.1.112.9 255.255.255.252
    fair-queue 64 16 0
    !
    no ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.1.252.1
    ip route 10.1.136.0 255.255.252.0 10.1.112.10
    !
    logging trap debugging
    logging source-interface Ethernet0
    logging 10.0.0.100
    logging 10.0.0.101
    dialer-list 1 protocol ip permit
    snmp-server community X
    snmp-server community X
    snmp-server chassis-id X
    !
    line con 0
    password X
    logging synchronous
    login
    transport input none
    stopbits 1
    line vty 0 4
    password X
    logging synchronous
    login
    !
    no rcapi server
    !
    !
    end

    Heckenstr_R1#sh cdp neigh det
    -------------------------
    Device ID: Inter_Intra_Sw
    Entry address(es):
    IP address: 10.251.0.27
    Platform: cisco WS-C3548-XL, Capabilities: Trans-Bridge Switch
    Interface: Ethernet0, Port ID (outgoing port): FastEthernet0/19
    Holdtime : 145 sec

    Version :
    Cisco Internetwork Operating System Software
    IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5.3)WC(1),
    MAINTENANCE INTERIM SOFTWARE
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Mon 30-Apr-01 07:51 by devgoyal

    advertisement version: 2

    -------------------------
    Device ID: Heckenstr_R2
    Entry address(es):
    IP address: 10.1.112.10
    Platform: Cisco C801 , Capabilities: Router
    Interface: BRI0, Port ID (outgoing port): BRI0
    Holdtime : 146 sec

    Version :
    Cisco Internetwork Operating System Software
    IOS (tm) C800 Software (C800-Y6-MW), Version 12.1(5)T9, RELEASE SOFTWARE
    (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Sun 24-Jun-01 19:35 by cmong

    advertisement version: 2

    Remote-Side:

    version 12.1
    no service single-slot-reload-enable
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    !
    hostname Heckenstr_R2
    !
    logging buffered 8000 debugging
    logging rate-limit console 10 except errors
    enable secret X
    !
    username Heckenstr_R1
    clock timezone cet 1
    ip subnet-zero
    !
    no ip domain-lookup
    no ip finger
    isdn switch-type basic-net3
    isdn voice-call-failure 0
    isdn leased-line BRI0 128
    !
    !
    !
    interface Ethernet0
    ip address 10.1.136.1 255.255.252.0
    ip helper-address 10.0.1.1
    ip helper-address 10.0.1.2
    ip helper-address 10.0.1.3
    !
    interface BRI0
    ip address 10.1.112.10 255.255.255.252
    fair-queue 64 16 0
    !
    no ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.1.112.9
    !
    logging 10.0.0.101
    logging 10.0.0.100
    dialer-list 1 protocol ip permit
    snmp-server community X
    snmp-server community X
    snmp-server chassis-id X
    !
    line con 0
    password X
    login
    transport input none
    stopbits 1
    line vty 0 4
    password X
    login
    !
    no rcapi server
    !
    !
    end

    Heckenstr_R2#sh cdp neighbors det
    -------------------------
    Device ID: Heckenstr_SW1
    Entry address(es):
    IP address: 10.1.139.1
    Platform: cisco WS-C2924-XL, Capabilities: Trans-Bridge Switch
    Interface: Ethernet0, Port ID (outgoing port): FastEthernet0/24
    Holdtime : 172 sec

    Version :
    Cisco Internetwork Operating System Software
    IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 12.0(5.3)WC(1),
    MAINTENANCE INTERIM SOFTWARE
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Mon 30-Apr-01 07:34 by devgoyal

    advertisement version: 2

    -------------------------
    Device ID: Heckenstr_R1
    Entry address(es):
    IP address: 10.1.112.9
    Platform: Cisco C801 , Capabilities: Router
    Interface: BRI0, Port ID (outgoing port): BRI0
    Holdtime : 159 sec

    Version :
    Cisco Internetwork Operating System Software
    IOS (tm) C800 Software (C800-Y6-MW), Version 12.1(5)T9, RELEASE SOFTWARE
    (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Sun 24-Jun-01 19:35 by cmong

    advertisement version: 2
     
    Michael Schubbert, Jan 29, 2004
    #12
  13. Michael Schubbert

    Brian V Guest

    Mike,

    Is Heckenstr_R1 showing up in the topology database?

    Whats it's ethernet port plugged into? Got a config for it?

    -Brian
     
    Brian V, Jan 29, 2004
    #13
  14. Hi Brian,

    yes Heckenstr_R1 State is "reachable". State of Heckenstr_R2 is "reachable"
    too.

    here is the config (shorten) of the switch that sees Heckenstr_R1:

    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    !
    hostname Inter_Intra_Sw
    !
    logging buffered 80000 debugging
    enable secret X
    !
    clock timezone cet 1
    !
    ip subnet-zero
    no ip domain-lookup
    !
    !
    interface FastEthernet0/19
    description Heckenstr
    duplex half
    speed 10
    switchport access vlan 30
    spanning-tree portfast
    !
    interface GigabitEthernet0/1
    description Trunk 3508-4-Port2
    duplex full
    switchport access vlan 59
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface VLAN1
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    interface VLAN101
    ip address 10.251.0.27 255.255.0.0
    no ip directed-broadcast
    no ip route-cache
    !
    ip default-gateway 10.251.0.1
    no ip http server
    logging trap debugging
    logging source-interface VLAN101
    logging 10.0.0.100
    logging 10.0.0.101
    snmp-server engineID local X
    snmp-server community X
    snmp-server community X
    !
    line con 0
    exec-timeout 0 0
    password X
    login
    transport input none
    stopbits 1
    line vty 0 4
    exec-timeout 120 0
    password X
    login
    line vty 5 15
    password X
    login
    !
    ntp clock-period 11259129
    ntp server 10.251.0.1
    end

    sh cdp neigh det (shorten)

    Device ID: Heckenstr_R1
    Entry address(es):
    IP address: 10.1.252.5
    Platform: Cisco C801 , Capabilities: Router
    Interface: FastEthernet0/19, Port ID (outgoing port): Ethernet0
    Holdtime : 166 sec

    Version :
    Cisco Internetwork Operating System Software
    IOS (tm) C800 Software (C800-Y6-MW), Version 12.1(5)T9, RELEASE SOFTWARE
    (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Sun 24-Jun-01 19:35 by cmong

    advertisement version: 2
    Duplex: half

    here is the config (shorten) of the switch that sees Heckenstr_R2:

    version 12.0
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    !
    hostname Heckenstr_SW1
    !
    enable secret X
    !
    !
    clock timezone cet 1
    !
    ip subnet-zero
    !
    !

    interface FastEthernet0/24
    spanning-tree portfast
    !
    interface VLAN1
    ip address 10.1.139.1 255.255.252.0
    no ip directed-broadcast
    no ip route-cache
    !
    ip default-gateway 10.1.136.1
    logging 10.0.0.100
    logging 10.0.0.101
    snmp-server engineID local X
    snmp-server community public
    snmp-server community secret
    !
    line con 0
    password X
    login
    transport input none
    stopbits 1
    line vty 0 4
    password X
    login
    line vty 5 15
    login
    !
    ntp clock-period 22518251
    ntp server 10.251.0.1
    end

    Heckenstr_SW1#sh cdp neighbors det
    -------------------------
    Device ID: Heckenstr_R2
    Entry address(es):
    IP address: 10.1.136.1
    Platform: Cisco C801 , Capabilities: Router
    Interface: FastEthernet0/24, Port ID (outgoing port): Ethernet0
    Holdtime : 156 sec

    Version :
    Cisco Internetwork Operating System Software
    IOS (tm) C800 Software (C800-Y6-MW), Version 12.1(5)T9, RELEASE SOFTWARE
    (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Sun 24-Jun-01 19:35 by cmong

    advertisement version: 2
    Duplex: half


    Michael
     
    Michael Schubbert, Jan 30, 2004
    #14
  15. Hi Brian,

    yes Heckenstr_R1 State is "reachable". State of Heckenstr_R2 is "reachable"
    too.

    here is the config (shorten) of the switch that sees Heckenstr_R1:

    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    !
    hostname Inter_Intra_Sw
    !
    logging buffered 80000 debugging
    enable secret X
    !
    clock timezone cet 1
    !
    ip subnet-zero
    no ip domain-lookup
    !
    !
    interface FastEthernet0/19
    description Heckenstr
    duplex half
    speed 10
    switchport access vlan 30
    spanning-tree portfast
    !
    interface GigabitEthernet0/1
    description Trunk 3508-4-Port2
    duplex full
    switchport access vlan 59
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface VLAN1
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    interface VLAN101
    ip address 10.251.0.27 255.255.0.0
    no ip directed-broadcast
    no ip route-cache
    !
    ip default-gateway 10.251.0.1
    no ip http server
    logging trap debugging
    logging source-interface VLAN101
    logging 10.0.0.100
    logging 10.0.0.101
    snmp-server engineID local X
    snmp-server community X
    snmp-server community X
    !
    line con 0
    exec-timeout 0 0
    password X
    login
    transport input none
    stopbits 1
    line vty 0 4
    exec-timeout 120 0
    password X
    login
    line vty 5 15
    password X
    login
    !
    ntp clock-period 11259129
    ntp server 10.251.0.1
    end

    sh cdp neigh det (shorten)

    Device ID: Heckenstr_R1
    Entry address(es):
    IP address: 10.1.252.5
    Platform: Cisco C801 , Capabilities: Router
    Interface: FastEthernet0/19, Port ID (outgoing port): Ethernet0
    Holdtime : 166 sec

    Version :
    Cisco Internetwork Operating System Software
    IOS (tm) C800 Software (C800-Y6-MW), Version 12.1(5)T9, RELEASE SOFTWARE
    (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Sun 24-Jun-01 19:35 by cmong

    advertisement version: 2
    Duplex: half

    here is the config (shorten) of the switch that sees Heckenstr_R2:

    version 12.0
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    !
    hostname Heckenstr_SW1
    !
    enable secret X
    !
    !
    clock timezone cet 1
    !
    ip subnet-zero
    !
    !

    interface FastEthernet0/24
    spanning-tree portfast
    !
    interface VLAN1
    ip address 10.1.139.1 255.255.252.0
    no ip directed-broadcast
    no ip route-cache
    !
    ip default-gateway 10.1.136.1
    logging 10.0.0.100
    logging 10.0.0.101
    snmp-server engineID local X
    snmp-server community X
    snmp-server community X
    !
    line con 0
    password X
    login
    transport input none
    stopbits 1
    line vty 0 4
    password X
    login
    line vty 5 15
    login
    !
    ntp clock-period 22518251
    ntp server 10.251.0.1
    end

    Heckenstr_SW1#sh cdp neighbors det
    -------------------------
    Device ID: Heckenstr_R2
    Entry address(es):
    IP address: 10.1.136.1
    Platform: Cisco C801 , Capabilities: Router
    Interface: FastEthernet0/24, Port ID (outgoing port): Ethernet0
    Holdtime : 156 sec

    Version :
    Cisco Internetwork Operating System Software
    IOS (tm) C800 Software (C800-Y6-MW), Version 12.1(5)T9, RELEASE SOFTWARE
    (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Sun 24-Jun-01 19:35 by cmong

    advertisement version: 2
    Duplex: half


    Michael
     
    Michael Schubbert, Jan 30, 2004
    #15
  16. Michael Schubbert

    Brian V Guest

    Morning Mike,

    Can the CW server ping 10.1.112.10 (The bri int of Heckenster_R2) ?

    Only thing I'm seeing out of the norm is that Heckenster_R1's ethernet
    interface is in vlan 30. How many routed interfaces are in between the CW
    server and Heckenster_R1's ethernet interface?

    Do you got a visio of your full network? If so, don't post it
    here...harley_1966_<at>comcast.net ......remove the underscores

    -Brian

    -Brian
     
    Brian V, Jan 30, 2004
    #16
  17. Hi Brian,
    2 VLANs
    VLAN CW (59) - VLAN WAN (30)

    In this VTP-Domain are about 70 VLANs. Its a big central side. Many Switches
    and workgroups, the switches are all trunked (ISL/dot1q)
    No, i work with the topology-map of campus.

    do you have run 80x and see other cisco stuff behind?

    i have tried many to solve the problem, i think the design and
    implementation is ok, so my result is: you don't see anything behind a 80X.

    next days i will try
    a) 2621 - X21 - 2621 -- 2924.
    b) 2621 - X21 - 805 - 2924

    i can try the same config for the 2621 in the middle and the 805 and i think
    a) i see 2924
    b) i will not see 2924

    Nicely weekend
    Michael
     
    Michael Schubbert, Jan 30, 2004
    #17
  18. Michael Schubbert

    Brian V Guest

    Hi Mike,

    I'm a consultant...yes, I have CW working for many of my customers with the
    80X series router, it's a very popular router for the small office.

    I cannot see why it's not being seen. It's only 3 hops away from the CW
    server, should be fine.

    Are you sure that you have the java package installed for the 80X series?
    Grasping at staws here, but I'm at a loss!

    Without actually being on the server or seeing the network firsthand I don't
    know what else to have you try.

    Have you tried opening a TAC case?

    -Brian
     
    Brian V, Jan 30, 2004
    #18
  19. Hi Brian,
    i don't have installed any packages for any device since upgrade to lms 2.2,
    cause all of our hardware is displayed in the topo, incl. the 80xer at the
    central side.

    but what is an "java package" for a device to install for CW? do you have a
    link, what you mean? when i look at Server Configuration --> About the
    Server --> About Ani Server --> Devices Support i see the 801,802, 803 and
    so on, and i see something looking like a mib-var for example
    ".1.3.6.1.4.1.9.1.212" for the 801. when i ask with getif for the snmp-var
    i get "enterprises.9.1.212" for the SysObjectID for the 801, so it looks
    very good.

    i have the problem since the first verson "cisco 2000 for nt", then i do a
    clean installation of lms cd-one 4th, then update to 5th, then update to lms
    2.2 with update 1, now i have no ideas more. you say its not the 80x series,
    the configs should be ok, its not isdn (dial nor leased), not the layer2
    protocol (hdlc, ppp), not cw cause i tried several versions over years. not
    the ios of 80x cause i tried 12.0, 12.1, 12.2. not snmp.

    its not dramatically, cause there are only 3 remote-sides with 80x and i
    plan to test a 17xx for the future, but i want to know what it is, when it
    should work, this drives me crazy!
    i cannot open a TAC case for software, its a contract problem, perhaps i pay
    for it, have to talk with my boss.

    next week i try the rest of my ideas (2621 - 805 with 100% same config) ,
    but i have no hope.

    thanks brian
    Michael
     
    Michael Schubbert, Jan 31, 2004
    #19
  20. Michael Schubbert

    Brian V Guest

    Hi Mike,

    In Device View>> View Installed Packages. Make sure the 800 series is in
    there. It is a default platform, so it should be there. Just another thing
    to check.

    This might be a dumb one....You have clicked Edit>>Rediscover devices when
    you have the Network Topology Layer 2 view open...right?

    -Brian
     
    Brian V, Jan 31, 2004
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.