cut'n paste problem with characterset

Discussion in 'NZ Computing' started by Craig Sutton, Jan 16, 2006.

  1. Craig Sutton

    Craig Sutton Guest

    I'm having trouble cut'n pasting items off some news sites

    When pasted often things like Quotations marks and apostrophe's come out
    replaced with question marks.I'm mostly pasting from IE but I have the same
    problem with Firefox.

    "We will play the matches at a neutral venue in April this year and 75 per
    cent of the proceeds will go to earth-quake victims of Pakistan and the rest
    to the people affected in India," he was quoted.

    will come out as this

    ?We will play the matches at a neutral venue in April this year and 75 per
    cent of the proceeds will go to earth-quake victims of Pakistan and the rest
    to the people affected in India,? he was quoted.

    Does anyone have any ideas?
     
    Craig Sutton, Jan 16, 2006
    #1
    1. Advertisements

  2. Craig Sutton

    Steve Guest

    It's a character set thing. The original text contained weird characters
    that aren't a straight ' or " but look like them. I see it a lot from
    Mac users.
     
    Steve, Jan 16, 2006
    #2
    1. Advertisements

  3. Craig Sutton

    Richard Guest


    What are you pasting into?

    Try notepad, but before you paste go file save as and change the encoding to
    unicode and see if you have better luck pasting. Also change the font in
    whatever you are pasting to for one with a full character set like arial. Also
    check the characters you need are in the font you are pasting into.
     
    Richard, Jan 16, 2006
    #3
  4. Craig Sutton

    steve Guest

    I see the same thing.

    a '-' (dash) is typically rendered as a '?' (question mark).
     
    steve, Jan 17, 2006
    #4
  5. Craig Sutton

    Craig Sutton Guest

    Does it in notepad as well. Also Notepad in win 98 hasn't got the option you
    refer to.

    Its Really annoying anyway, as I Cutnpaste quite a bit of news content for
    my website.
     
    Craig Sutton, Jan 17, 2006
    #5
  6. Craig Sutton

    Richard Guest

    Well that will be the problem, win98 doesnt handle unicode at the OS level, its
    up to the applications to convert it, and most things dont bother.
     
    Richard, Jan 18, 2006
    #6
  7. Craig Sutton

    Craig Sutton Guest

    Good infor thanks for that.
     
    Craig Sutton, Jan 18, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.