Cox cable - Linksys router - SSH access via port-forwarding.

Discussion in 'Network Routers' started by Earnric, Nov 12, 2005.

  1. Earnric

    Earnric Guest

    Ok, I'm not the best network guy so I need some help.

    Configuration:

    I have cox cable coming into a Toshiba cable modem. That connects to a
    Linksys BEFW11S4 gateway/router.

    I have 3 systems on my LAN: 2 Windoze boxes and a Linux box -- all with
    Static IPs: 192.168.1.101,102,103

    The Linux box has LAN IP 192.168.1.102

    I have port-forwarding on the Linksys set to forward port 22 requests
    for UDP/TCP to 192.168.1.102 ... I also have "Block WAN Requests"
    disables on the advanced page for router setup.

    My router's status page says my "WAN IP" is 192.168.251.103 ... and if
    I SSH to that IP, voila -- it works fine. I can also SSH directly to
    192.168.1.102 ... so the ssh daemon is working as advertised.

    Here's the tricky part... www.whatismyip.com says my "external" IP
    address is 70.162.42.201... and if I SSH to that IP I get a timeout...
    My router log doesn't show any incoming requests so I don't think I'm
    even reaching it.

    If I SSH (from work say, somewhere outside my LAN) to 192.168.251.103
    (what the router says is my WAN IP) I get a timeout (can't find the
    IP).

    So, ... help?! Any idea what's going on? Somehow my router thinks I
    have one WAN IP and the rest of the world thinks I have another. What
    am I missing?

    Rick
     
    Earnric, Nov 12, 2005
    #1
    1. Advertisements

  2. Earnric

    BobC Guest

    Sounds like your cable modem is also a NAT/Router gateway device which is
    assigning the non-routable private address 192.168.251.103 to your router.
    This private address can not be routed to from the Internet. The whatsmyip
    reported address is the public address of your modem/NAT/Router device. You
    will need to forward port 22 in that device to your ssh computer. Maybe try
    setting your router to act as a switch and let the modem/NAT/Router do the
    port forwarding. Or turn off the NAT/Router in the modem if possible.
     
    BobC, Nov 13, 2005
    #2
    1. Advertisements

  3. Earnric

    Earnric Guest

    Hey Bob... that sounds like what's happening.

    Unfortuneately, I can't seem to access the html/config pages on the
    modem. They are password protected and cox says they don't have the
    password. The modem documentation says that only the cable provide is
    'supposed' to access the config pages.

    I think you've diagnosed it, now I just need to get the damn modem to
    forward port 22 to my router (which is currently configured as a
    gateway -- should I switch it to router mode?)

    Thanks again.
     
    Earnric, Nov 14, 2005
    #3
  4. Earnric

    Earnric Guest

    No luck in finding out how to configure the router... Anyone know how
    to configure a Toshiba PCX2200 cable modem? The documentation at
    Toshiba says the cable company does it... but there must be a way.

    R
     
    Earnric, Nov 14, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.