Couldn't access to some WebSites with cisco 831

Discussion in 'Cisco' started by Stefan Weber, Aug 5, 2004.

  1. Stefan Weber

    Stefan Weber Guest

    Hello,

    I've got today my new cisco router type series 831. There was no problem to
    install and configure them with the connection-strings. But something is
    wrong: On some websites, I've absolutly no problem to access, other websites
    are not able to access.

    To some websites, I couldn't access, it's possible to send a ping and get
    answer, other (existing) sites not.

    But there is no problem to acess to all working websites, without the
    router. The problems are with firewall and without.

    Any Idea, how to selv the problem?????

    Thanks and best regards ....
     
    Stefan Weber, Aug 5, 2004
    #1
    1. Advertisements

  2. Stefan Weber

    Hansang Bae Guest

    Allow ICMP through. Or at the very least ICMP type 3 code 4.

    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Aug 7, 2004
    #2
    1. Advertisements

  3. Stefan Weber

    PES Guest

    If using pppoe, a lot of ISP's block the packets necessary for ip mtu
    discovery to work properly. PPPOE is troublesome because of the additional
    header information it packs. In most cases, this can be resolved for by
    adjusting the tcp mss. To do so try the command "ip tcp adjust-mss 1452" on
    your internet facing interface.
     
    PES, Aug 7, 2004
    #3
  4. Stefan Weber

    Don Mega Guest

    I had to troubleshoot a similar problem once. The problem was the IP
    MTU was adjusted but the TCP MSS (Max Segment Size) was not.

    Connections to those sites (that did not work) had the 'do not
    fragment' bit set during the initial TCP/IP negotiations between the 2
    host (LAN PC and external Web Server). Users needed to recieve larger
    packets through than allowed by the clients router and the router
    tried to fragment (responce data - on the way back in). Since the
    Don't Fragment bit was set between the 2 host (LAN PC and external Web
    Server) the connection hung up since the data offset was not 0 in the
    packets (fragmented).

    *** a tell tell sign (besides using a sniffer of course), was whenever
    I tried to browse to linux.org the screen would turn yellow
    (background) but none of the graphics would display.***

    Play around with the MTU and TCP MSS settings, if possible.
    the 831's have 2 ethernet interfaces right? if you can post the
    config, but take all your sensitive settings out (IP, passwds, etc)

    either that or the isp's dns server that you are using is
    broke.........


    Don Mega
     
    Don Mega, Aug 8, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.