controlling the 'eth0' device that gets detect by ifconfig

Discussion in 'Linux Networking' started by Jim Anderson, Jul 27, 2012.

  1. Jim Anderson

    Jim Anderson Guest

    I used to run Kubuntu linux and my network addresses would be detected
    properly during startup. I have switched to crunchbang linux and my
    network runs ok except on one PC the OS is not detecting the correct
    port for eth0 and I don't know how to fix the problem.

    The network has two routers, one wireless and one wired using ethernet
    ports. The wired router is connected to a DSL line so all of the wired
    PCs should be directed to that router to connect to the world.
    Unfortunately, the problem PC detects the wireless router for the
    'eth0' device.

    When I run the route command, the default address is 192.168.2.1, the
    address of the wireless router, not 192.168.0.1, the address of the
    wired router. If I disconnect the wireless router and reboot, then I
    think it is detected the correct router, but when I run ifconfig, the
    ethernet address is in inet6, not an inet4 address.

    If there a way to force the inet4 address of the wired router to be
    detected?

    Jim Anderson
     
    Jim Anderson, Jul 27, 2012
    #1
    1. Advertisements

  2. gksu ifconfig wlan0 down

    Alastair
     
    Alastair Black, Jul 27, 2012
    #2
    1. Advertisements

  3. It sounds like you've got both routers acting as a DHCP server for the
    same bit of network. There's no way that's going to be reliable.
    IPv6 addresses often contain modified forms of the MAC address; that's
    normal.
     
    Richard Kettlewell, Jul 28, 2012
    #3
  4. The following message is a courtesy copy of an article
    that has been posted to comp.os.linux.networking as well.


    Jim> If there a way to force the inet4 address of the wired router to be
    Jim> detected?

    Alastair> gksu ifconfig wlan0 down

    A more permanent fix would be to blacklist the wifi driver in a file
    such as /etc/modprobe/local-blacklist.conf.

    --
    Ian Zimmerman
    gpg public key: 1024D/C6FF61AD
    fingerprint: 66DC D68F 5C1B 4D71 2EE5 BD03 8A00 786C C6FF 61AD
    http://www.gravatar.com/avatar/c66875cda51109f76c6312f4d4743d1e.png
    Rule 420: All persons more than eight miles high to leave the court.
     
    Ian Zimmerman, Jul 28, 2012
    #4
  5. Jim Anderson

    Jorgen Grahn Guest

    Well, the thing is, if you have IPv6 enabled, each interface will have
    at least a "Scope:Link" IPv6 address. It's not the presence of that
    one but the absence of the IPv4 one that's important.

    /Jorgen
     
    Jorgen Grahn, Jul 28, 2012
    #5
  6. Jim Anderson

    Gordon Guest

    Sure, make the address of your network card on the PC, static. Say
    192.168.2.103, which is outside the DHCP range of the router.

    If you have only one LAN. Then as another poster has hinted at drop the
    second DHCP. Having two DCHPs battle it out is not really the way to go.
     
    Gordon, Aug 10, 2012
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.