Connecting two WinXPPro machines: can ping but can't share files

Discussion in 'Home Networking' started by c.j[DOT]w, Jul 22, 2003.

  1. c.j[DOT]w

    c.j[DOT]w Guest

    Hello,

    I am having problems connecting two Win XP Pro computers in a network. I
    have set the IP adresses to 192.168.0.1 and 192.168.0.2. I can ping both
    computers from both computers. From 0.1 I can see the files shared on
    the 0.2 computer, but not the other way around.

    The workgroups are the same. When I from computer 0.2 choose Run...
    "\\192.168.0.1" I get the error message "Can't find network
    search-path". Neither "\\computername\" works. And I do have shares on
    the 0.1 computer, a harddrive with the resource name "E" with full
    access for user-group "All".

    Any help is appreciaetd.
     
    c.j[DOT]w, Jul 22, 2003
    #1
    1. Advertisements

  2. c.j[DOT]w

    Mike Yates Guest

    I hope you are setting up the PCs manually, not using the "wizard" which
    makes a floppy to set up the others. That is only suitable for
    client-server setups, while you want peer-to-peer, or do you?
    "Sharing" with Windows is notoriously insecure, so you might be better
    off to keep one machine as a client (especially if it's portable) and
    only share a special "public" folder on the other, though which you
    transfer files. Security may not be a problem, though, especially if you
    only dial-up to the Internet, so you could share one PC's "My Documents".
    With WinXP there is no need to "map" a drive-letter to the remote
    resource (is that what you mean by "a harddrive with the resource name
    "E"" ?) because it will be "remembered" in "Network Places".
    Make sure that the "netBEUI" protocol is enabled at both ends.

    Hope that helps
     
    Mike Yates, Jul 22, 2003
    #2
    1. Advertisements

  3. c.j[DOT]w

    c.j[DOT]w Guest

    No, I set them up manually.

    That is only suitable for
    I'm not quite sure what the difference is to be honest, but as far as I
    know, I have never defined any of the computers as being the "server" or
    the "client", so I guesse it is peer-to-peer.
    I just find it so much easier to share the harddrives so that I can
    access both computers' files from both computers, so that is the way I'd
    like to do it.

    Security may not be a problem, though, especially if you
    Yes, probably.

    because it will be "remembered" in "Network Places".

    Yes, but still it is more convenient to be able to access the other
    harddrive by just a drive letter than having to go to Network Places.
    I'm running a TCP/IP network, thinking that is the best. Isn't it? At
    least it is the most used.


    Thanks for your reply - now with the additional info, any idea what is
    wrong?
     
    c.j[DOT]w, Jul 22, 2003
    #3
  4. c.j[DOT]w

    Conor Guest

    Check your shares. Make sure the user account on each machine has
    access to the other.

    --
    ________________________
    Conor Turton

    ICQ:31909763
    ________________________
     
    Conor, Jul 22, 2003
    #4
  5. c.j[DOT]w

    Mike Yates Guest

    Yes, there are lots of security levels to set. Don't be afraid of
    "Advanced" buttons, they're only to deter thick Yanks.
    This must be a sharing problem if you can ping each other - either
    protocol-linking (NetBEUI over TCP/IP) or access rights at the user or
    the folder level.
     
    Mike Yates, Jul 22, 2003
    #5
  6. c.j[DOT]w

    Rob Morley Guest

    So is the user account on 0.2 a member of the "All" group on 0.1?
     
    Rob Morley, Jul 22, 2003
    #6
  7. c.j[DOT]w

    Rob Morley Guest

    There's nothing wrong with the installed protocols, because the sharing
    works one way, so it must be a permissions problem (always assuming that
    the client and server services are running on both machines).
     
    Rob Morley, Jul 22, 2003
    #7
  8. c.j[DOT]w

    c.j[DOT]w Guest

    See my reply to Morley. Can you tell me how to check this? When I start
    Windows, no login-window appear. And since I am the only user of the
    computers I'd like it to be that way. But maybe this is the problem.
     
    c.j[DOT]w, Jul 22, 2003
    #8
  9. c.j[DOT]w

    c.j[DOT]w Guest

    I'm rather new to XP and there are LOADS of settings - any tip where to
    start looking, or what exact setting it could be?

    Thanks everybody for the help so far.
     
    c.j[DOT]w, Jul 22, 2003
    #9
  10. c.j[DOT]w

    Rob Morley Guest

    The easiest way to do it is to make sure that the local user has an
    account on the remote machine - have you got a "Log off XXX ..." option
    on your Start Menu where XXX is the username? If so just set up an
    account on the remote machine using the same username and password, and
    give that user the permissions required.
     
    Rob Morley, Jul 22, 2003
    #10
  11. c.j[DOT]w

    ahood Guest

    This is a rather easy problem to solve, it has a lot to do with how XP
    handles sharing - first thing to do is go into the network connection
    properties and disable any wireless security that it might be trying to use.

    The second and most important is that you have to actually use the file
    sharing wizard to be able to share files between the two pcs. First of all,
    go into explorer and Tools > Folder Options, View tab, and at the bottom you
    can re-enable simple file sharing, this isn't permanent, just turn it on for
    now. Then go into properties for something like the C drive and the sharing
    tab for that. There should be a hyperlink sort of thing where the sharing
    options should be which will open up a wizard to enable file sharing. Once
    you've gone through this wizard and it's done giving you all its cautions,
    disable simple file sharing again.

    I'm guessing you've already enabled the guest account or set stuff up so
    they've both got the same password so that shouldn't be a problem.
     
    ahood, Jul 23, 2003
    #11
  12. c.j[DOT]w

    Conor Guest

    Go into Control Panel, Users. Enable guest account. See if it works.


    --
    ________________________
    Conor Turton

    ICQ:31909763
    ________________________
     
    Conor, Jul 23, 2003
    #12
  13. c.j[DOT]w

    c.j[DOT]w Guest

    It is enabled.
     
    c.j[DOT]w, Jul 23, 2003
    #13
  14. c.j[DOT]w

    c.j[DOT]w Guest

    I've tried to set up two new accounts with the same username and
    password on both machines, but without results. Still the same problem.
    Any other idea?
     
    c.j[DOT]w, Jul 23, 2003
    #14
  15. c.j[DOT]w

    Rob Morley Guest

    Does the computer that doesn't work show up in its own "My Network
    Places"?
     
    Rob Morley, Jul 23, 2003
    #15
  16. c.j[DOT]w

    c.j[DOT]w Guest

    Yes.

    The computer that reaches the other computer shows both computers. The
    computer that doesn't reach the other computer shows just itself.
     
    c.j[DOT]w, Jul 23, 2003
    #16
  17. c.j[DOT]w

    ahood Guest

    Well - it's possible that windows decided not to install useful things like
    Client for Microsoft Networks and File and Print sharing. Also I did mean
    the "activate IEEE 802.1x" checkbox, it should be unticked, as I've seen it
    cause problems on a friend's machine. Especially when there's no wireless
    networking stuff attached.
    To install the Client for MS networks and F&P sharing, go into the
    properties for the network connection - and install them, they should in
    Clients and Services respectively.

    Another thing to check (as I've also seen this happen) is that the Server
    service is running, go into computer management > services. The server
    service should always run, so if it's not running then that may also be the
    cause of it.

     
    ahood, Jul 24, 2003
    #17
  18. c.j[DOT]w

    Rob Morley Guest

    If they weren't installed then the other machine wouldn't be able to see
    it, and the dodgy machine wouldn't see its own share.
    If the server service wasn't running, or the client wasn't properly
    installed, then the share wouldn't show up even on the local machine.
    Whereas if the local machine can see it but the remote machine can't
    then it's a network or permissions problem. It's not the browse master
    selection, because accessing by \\machine\share should work even if the
    browse master doesn't show it. And it's not a basic TCP/IP problem
    because they can ping each other. Maybe the NetBIOS over TCP/IP
    setting? But more likely a security policy setting somewhere, as we
    seem to have eliminated the basic user account permissions stuff.
     
    Rob Morley, Jul 24, 2003
    #18
  19. c.j[DOT]w

    c.j[DOT]w Guest

    I checked it, and it is installed.
    I unchecked it, didn't help.
    Yep, checked that too, didn't help either.


    Thanks everybody for all the help! But still the problem is unsolved.
     
    c.j[DOT]w, Jul 25, 2003
    #19
  20. c.j[DOT]w

    c.j[DOT]w Guest

    Another thing to check (as I've also seen this happen) is that the Server
    I found it, and read that it should be "activated" when using a static
    IP (which I do). I changed it to "active", but it didn't help.

    But more likely a security policy setting somewhere, as we
     
    c.j[DOT]w, Jul 25, 2003
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.