Connected to Telia/Skanova using 837 but with oddities

Discussion in 'Cisco' started by Christer Bergstrom, Jul 24, 2005.

  1. Dear Sirs

    I have now managed to connect with my 837 Router.
    Previosly I had problem with the CRWS-interface due to
    the M*******t Java engine, when I got the CRWS running it was possible
    to make an config that enable me to connect.

    Oddly when I run <IPCONFIG> my computer shows as: 81.226.84.128
    and not 192.168.0.xxx same oddity for the DHCP-server, it have the
    address: 81.226.84.1 and not something inside my private net.

    Also it is only possible to connect to the 837 with one computer, the
    one where I wrote the configuration. Any other computer will receive
    no IP-address from the router.

    Is there some kind person willing to help an beginner?

    sh ru gives:

    Current configuration : 1262 bytes
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    logging queue-limit 100
    enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    !
    ip subnet-zero
    no ip domain lookup
    ip dhcp excluded-address 192.168.0.1
    !
    ip dhcp pool balja
    import all
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    lease 0 2
    !
    !
    ip audit notify log
    ip audit po max-events 100
    no ftp-server write-enable
    !
    !
    !
    !
    !
    bridge irb
    !
    !
    interface Ethernet0
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    bridge-group 1
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    ip nat outside
    no atm ilmi-keepalive
    pvc 8/35
    encapsulation aal5snap
    !
    dsl operating-mode auto
    bridge-group 1
    !
    interface BVI1
    ip address dhcp client-id Ethernet0
    ip nat outside
    !
    ip nat inside source list 1 interface BVI1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 BVI1
    no ip http server
    no ip http secure-server
    !
    access-list 1 permit 192.168.0.0 0.0.0.255
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    no modem enable
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    login
    !
    scheduler max-task-time 5000
    !
    end

    best regards

    Christer Bergström
    Viker
    Sweden
     
    Christer Bergstrom, Jul 24, 2005
    #1
    1. Advertisements

  2. Christer Bergstrom

    Peter Guest

    Hi Christer,
    This appears to be because you have configured your Router into BRIDGE
    mode, and the Router is taking no part in any DHCP negotiation, so the
    DHCP Client on your PC is getting its reply from your ISP's DHCP
    Server. The net result is that your WAN IP address is actually
    appearing on your PC.
    That is probably because your ISP only allows one IP address per
    Client connection, and its locked to the single address by Bridging.

    All this is happening because you have your Router set up to BRIDGE
    your WAN link to your LAN segment, and no IP info is used on the
    Router! I suggest that you remove ALL bridging statements and you
    should then be close to getting going, although it is unclear exactly
    what MODE your ISP is using to handle traffic between your Router and
    their end. The usual method of doing this is to use some form of PPP
    but its not clear what your ISP is using...

    Without Bridging configured you can remove this entire interface
    configuration section -
    If your ISP is delivering a PPP connection, then you need to set up a
    Dialer interface tied to the PVC on the ATM channel, and the Dialer
    interface is the outside of your NAT operation.
    This can go too...

    That's a start but more info is need, unless you can work out the
    rest................;-)

    Cheers.................pk.
     
    Peter, Jul 25, 2005
    #2
    1. Advertisements

  3. I don't think I'd go quite as far a Peter from auckland suggests in
    another post, since the bridge configuration seems to be close to right.

    Try taking Ethernet0 out of the bridge group, and remove the default
    route pointing to BVI1, e.g.

    !
    interface Ethernet0
    no bridge-group 1
    !
    interface ATM0
    no ip nat outside
    !
    no ip route 0.0.0.0 0.0.0.0 BVI1
    !

    Now, with luck, the IP address from the ISP will end up assigned to BVI1,
    and your PC(s) will be getting a 192.168.0.0/24 address instead. The
    router should also create a default route for the default router address
    it gets from the ISP DHCP server.

    You may have to leave the router switced off for a while, perhaps
    overnight to let the ISP forget about the MAC address of your PC.

    Rgds,
    Martin
     
    Martin Gallagher, Jul 25, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.