Connect printer to router via USB

Discussion in 'NZ Computing' started by Gib Bogle, Sep 21, 2012.

  1. Gib Bogle

    Gib Bogle Guest

    Maybe I'm missing something obvious. According to the info, it should
    be possible to connect a USB printer to the USB port on my Vodafone ADSL
    router. I can set up the router with the Canon PIXMA iP3000 connected,
    but there seems to be no way to get Windows 7 to detect the printer. I
    spent a couple of hours trying every avenue, then a Vodafone tech
    support person spent another half hour. I've now pretty much convinced
    myself that it will not work, but I'd like to know why.

    Does the printer need some extra capabilities (ethernet?) to work when
    plugged in to the router? My aim is to be able to access the printer
    wirelessly without the Windows 7 machine needing to be awake.

    Thanks
    Gib
     
    Gib Bogle, Sep 21, 2012
    #1
    1. Advertisements

  2. Gib Bogle

    victor Guest

    Autodetection doesn't always work.

    I think your router has a cups print server so what you do on the client
    device you want to print from is use "add network printer" with the url
    http://192.168.1.1:631/printers/myprinter where myprinter is the name of
    the printer you enter in the share printer page of the router web ui.
     
    victor, Sep 21, 2012
    #2
    1. Advertisements

  3. Gib Bogle

    Gib Bogle Guest

    Yes, that's what Vodafone says. I've done that (a few times) and the
    Vodafone tech support gal did it too. I've also tried following this
    guy's procedure:
    (but with 192.162.1.1:631). All such attempts lead nowhere.

    Interestingly with the current situation when I try to print something
    it doesn't give an immediate error, the print queue status is
    "Printing", but the printer doesn't react - no lights flash, nothing -
    and after a while the status changes to "Error-Printing". It looks as
    if the router thinks it is sending data to the printer, but the printer
    doesn't receive anything. I've tried a couple of different USB sockets
    on the router - it isn't clear which should be used, or if there is a
    difference.

    Do you think any USB printer should work?
     
    Gib Bogle, Sep 21, 2012
    #3

  4. Some of these Routers don't support printers but Storage.

    I have a Dlink router DIR 655 with the same option and it does support
    Printers, but it not that clear if I can use it with WiFi and the PC not
    running, just the other day grabbed all the latest stuff to try it..

    From what I can gather the Router sores the printer driver.?
     
    Frank Williams, Sep 21, 2012
    #4
  5. Gib Bogle

    Gib Bogle Guest

    According to the Vodafone docs a printer can be connected (as I said).
     
    Gib Bogle, Sep 21, 2012
    #5
  6. Gib Bogle

    Malcolm Guest

    Hi
    Is the printer configured for wireless and have an IP address? Firewall
    on the windows machine blocking the ipp port?
     
    Malcolm, Sep 21, 2012
    #6
  7. It is commonly assumed that the access to the router is 192.168.1.x

    My Belkin router requires 182.168.2.x
    All the network identities require 192.168.2. x or xx or xxx.

    Run > cmd > ipconfig /all and look at the default gateway value.

    This may be your problem.
     
    [email protected], Sep 21, 2012
    #7
  8. Gib Bogle

    Gib Bogle Guest

    The Vodafone docs specify 192.168.1.1:631
     
    Gib Bogle, Sep 21, 2012
    #8
  9. Gib Bogle

    Gib Bogle Guest

    Since the printer is connected to the router via a cable I don't see the
    significance of wireless. As to the printer having an IP address,
    according to Vodafone it is accessed via 192.168.1.1:631, where the
    router address is 192.168.1.1. I confess that I don't understand the
    :631. If a firewall were blocking the port I presume I wouldn't see the
    router.
     
    Gib Bogle, Sep 21, 2012
    #9
  10. Gib Bogle

    victor Guest

    If the router is detection the printer and showing it in the web ui that
    end should be OK
    In Windows 7 you may have to go to the control panel programs and
    features select windows features, print services and turn on lpd print
    service monitor and lpr port monitor.
     
    victor, Sep 21, 2012
    #10
  11. Gib Bogle

    Gib Bogle Guest

    Before I check that avenue, here is some more info. On the Vodafone
    forums I found a link to this instruction video, specifically for Windows 7:

    I followed the steps, and it all seemed to work as expected, until I
    tried to print a test page. Not a peep from the printer.

    On the same forum thread, there is a note about needing to install the
    latest router software:

    Hi All,

    As the title suggests we have released new firmware for the HG556a (VBC).

    This firmware is compatible with Vodafone Easy Office devices.

    Please find the link for the new firmware bellow:

    http://tinyurl.com/d729t6v

    Best Regards,

    Nigel

    This strikes me as odd - why use tinyurl for a link? The tinyurl takes
    you to a file:
    http://testvf.co.nz/files/hg556a/HG556aV100R001C12B037.bin
    (10 Mb) which I've downloaded. Now I need to find out how to install it.
     
    Gib Bogle, Sep 21, 2012
    #11
  12. Gib Bogle

    victor Guest

    And tick lpr in the windows printer driver.
     
    victor, Sep 21, 2012
    #12
  13. Gib Bogle

    Gib Bogle Guest

    I did these things. When I tick LPR, under LPR Settings it expects a
    Queue Name - without one it says "The Queue name is not valid"
     
    Gib Bogle, Sep 21, 2012
    #13
  14. Gib Bogle

    victor Guest

    Try LPT1 as the queue name
     
    victor, Sep 22, 2012
    #14
  15. Gib Bogle

    Gib Bogle Guest

    "An error occurred during port configuration. Operation could not be
    completed (error 0x000000aa)."

    BTW I just discovered that I can print from a Windows XP machine that
    connects wirelessly to the router. So XP/wireless works, but W7/cable
    does not. WTF???
     
    Gib Bogle, Sep 22, 2012
    #15
  16. Gib Bogle

    Gib Bogle Guest

    I just had to empty the print queue to stop that error. So it is now
    configured LPR. Still doesn't print.
     
    Gib Bogle, Sep 22, 2012
    #16
  17. Gib Bogle

    victor Guest

    victor, Sep 22, 2012
    #17
  18. Gib Bogle

    victor Guest

    The queue name could also be printers/myprintername
     
    victor, Sep 22, 2012
    #18
  19. Gib Bogle

    Enkidu Guest

    Your router has more than one USB socket? Usually there is only one.
    What model is it?

    Cheers,

    Cliff
     
    Enkidu, Sep 22, 2012
    #19
  20. Gib Bogle

    Enkidu Guest

    :631 is the printer port number. The router is normally accessed from a
    browser on the PC usually port 80 or 443 (http://... or https://....).
    It is possible (but not likely) that the router could block port 631
    (hence printer access) but not the browser access on port 80 or 443.

    Cheers,

    Cliff

    Cheers,

    Cliff
     
    Enkidu, Sep 22, 2012
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.