Configuring two routers

Discussion in 'Network Routers' started by Steve°, Dec 13, 2004.

  1. Steve°

    Steve° Guest

    I have an ADSL modem router that has worked fine for 18 months.
    I have added a wireless router.
    I know I should have got an access point but this router has a media port I wish to use.
    Internet access from both routers works fine.

    I would like the two routers to behave as if it were one network.

    The problem I have is that a PC on the first router can not see a PC on the other router.
    Put them on the same router and all is fine.

    I think this may be a subnet mask problem.
    Here is the configuration of both routers;

    Modem Router (Netgear DG814)
    WAN: static internet IP
    LAN IP: 192.168.0.1
    DCHP addressing range 192.168.0.2 - 192.168.0.254
    Subnetmask: 255.255.255.0

    Wireless Router (Netgear WTG634U)
    WAN 192.168.0.2
    LAN IP: 192.168.1.1
    DCHP addressing range 192.168.1.2 - 192.168.1.154
    subnetmask: 255.255.255.0

    All PCs running XP
    Automatic IP assignment

    Thanks
    Steve.
     
    Steve°, Dec 13, 2004
    #1
    1. Advertisements

  2. Steve°

    Gary X Guest

    Open the dmz from the dg814 to the Wgt634U.
     
    Gary X, Dec 13, 2004
    #2
    1. Advertisements

  3. Steve°

    Gary X Guest

    Forgot to add:
    from the wgt, ensure it has a static wan ip, and that its gateway is the
    dg814, also add a primary dns server as the dg824's ip...
     
    Gary X, Dec 13, 2004
    #3
  4. Steve°

    Steve° Guest

    Gary,
    Thanks for your reply,

    I am still unable to get the two networks to see each other. The changes I have made are;

    DG814
    opened the DMZ with the IP address 192.168.0.100

    WTG634U
    WAN Static IP address of 192.168.0.100
    Gateway 192.168.0.1 (the DG814 LAN IP address)
    Primary DNS 192.168.0.1

    I have noticed I can ping PCs on the DG814 from a PC on the WTG, but not the other direction.

    Thanks
    Steve.

    Forgot to add:
    from the wgt, ensure it has a static wan ip, and that its gateway is the
    dg814, also add a primary dns server as the dg824's ip...
     
    Steve°, Dec 14, 2004
    #4
  5. Steve°

    Chuck Guest

    Steve,

    You can do this, but you'll have to make the WGT634U into a wireless hub, so all
    the computers are on the subnet of the DG814.
    1) Disable DHCP on the WGT634U.
    2) Connect a LAN port on the WGT634U to a LAN port on the DG814 (you may need a
    cross-over cable here).
    3) Change the LAN address of the WGT634U to something on the subnet of the
    DG814, but outside the scope of the DHCP server. You'll have to use a fixed ip
    address here, as NAT router LAN ports aren't DHCP clients.
     
    Chuck, Dec 15, 2004
    #5
  6. Steve°

    Gary X Guest


    the above will indeed work, but is not the ideal set up...


    imho the following (Double Nat) is what you want

    DG814:
    LAN IP 192.168.1.1
    Open the dmz to 192.168.1.2

    WGT634U:
    WAN IP 192.168.1.2
    Gateway 192.168.1.1
    Primary DNS 192.168.1.1
    Lan IP 192.168.0.1

    Using this method, all traffic is passed to the WGT634U, which then handles
    the firewall side of things.
    The DG814 will effectively become transparent, eg if you ping your public ip
    you will get a response from the WGT634U not the DG814.



    Hope this helps,

    Gary
     
    Gary X, Dec 15, 2004
    #6
  7. Steve°

    Paul E Mak Guest

    You have the DHCP on the DG814 starting at 0.2 and your WTG634U is on
    0.2. Put the 634 on a static and remove that address from the DHCP
    range on your 814. The subnet masks are fine.
     
    Paul E Mak, Dec 15, 2004
    #7
  8. Steve°

    Steve° Guest

    You have the DHCP on the DG814 starting at 0.2 and your WTG634U is on
    0.2. Put the 634 on a static and remove that address from the DHCP
    range on your 814. The subnet masks are fine.

    Thanks for all the suggestions.
    I have not had the time to spend on this problem so have not tried any as yet.
    I will let you know how I get on.
    Thanks
    Steve.
     
    Steve°, Dec 22, 2004
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.