Configuring Cisco for LACP and Trunking?

Discussion in 'Cisco' started by Usenet, Apr 4, 2008.

  1. Usenet

    Usenet Guest

    We're trying to configure our Cisco 4507 to allow a new Dell server with
    a pair of Broadcom Gig NIC's to aggregate its NIC's to give us a 2gbps
    link.

    So far we seem to have got the team and LACP up and enabled, but the
    adaptor that the Broadcom Admin Util creates for the team is only
    showing a 1gbps connection where I would have expected it to show as
    2gbps.

    The individual NICs show as connected at 1gbps.

    We're not Cisco experts so are struggling on how to get the 2 NICs to
    aggregate.

    This is what I think the relevent output from "sho conf" is, more
    available if needed.

    On the server side we've done nothing in the Broadcom drivers other than
    create a team using 802.3ad Link Aggregation using LACP.

    version 12.2
    boot system flash bootflash:cat4000-i9s-mz.122-18.EW1.bin
    !
    interface Port-channel2
    description "Main Server link"
    switchport
    switchport mode access
    !
    interface GigabitEthernet4/4
    switchport mode access
    spanning-tree portfast
    channel-group 2 mode active
    channel-protocol lacp
    !
    interface GigabitEthernet4/20
    switchport mode access
    spanning-tree portfast
    channel-group 2 mode active
    channel-protocol lacp
    !

    Any help would be appreciated
     
    Usenet, Apr 4, 2008
    #1
    1. Advertisements

  2. Hi,

    Forget about it ...

    first: you connect your 2 NICs to the same switch, and what goes wrong when
    this switch blows ?. if you want redundancy connect to two different
    switches.
    second: I would be greatly surprised if you are even close at utilizing ONE
    gigabit NIC ! so why you want two, when you can't use one ?!
    What you should go for is redundancy/resilient links, hence you should
    configure failover as an active/standby senarium. sometimecalled adapter
    fault tolerance or network fault tolerance.
    Allthough I think it's different in the broadcom chips/util'

    HTH
    Martin Bilgrav
     
    Martin Bilgrav, Apr 7, 2008
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.