configuring 2620 for ISDN dial in (no callback required)

Discussion in 'Cisco' started by Fritz Schoeler, Jun 20, 2008.

  1. hi there,

    i'm totally new to configuring cisco equipment; i got a 2620 from a
    customer in order to configure dial in via ISDN lines. they have defined
    a list of users (and passwords), which i already configured (but omitted
    in the lines below). the users should be able to call a number (MSN),
    authenticate and have access to the LAN itself. pretty straightforward...

    however, i'd like to hear some words regarding the configuration i built
    reading many documents from the cisco website.

    after some hours of fiddling around, it all boiled down to the following
    configuration. i'd like to test it in advance, but on my side i just
    don't have the appropriate equipment.

    thanks a lot in advance to everybody helping me. this is very much
    appreciated. thanks!

    best,

    fritz

    ---

    bla#sh running-config
    Building configuration...

    Current configuration:
    !
    version 11.3
    service timestamps log uptime
    service password-encryption
    !
    hostname xyzxyzxyz
    !
    !
    username foo password 7 bar
    !
    ip subnet-zero
    isdn switch-type basic-net3
    !
    process-max-time 200
    !
    interface Ethernet0/0
    description lan
    ip address 192.168.1.240 255.255.240.0
    !
    interface BRI1/0
    description bla dialin line 1
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    no cdp enable
    ppp authentication chap
    !
    interface BRI1/1
    description bla dialin line 2
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    ppp authentication chap
    !
    interface BRI1/2
    description bla dialin line 3
    no ip address
    shutdown
    isdn switch-type basic-net3
    !
    interface BRI1/3
    description bla dialin line 4
    no ip address
    shutdown
    isdn switch-type basic-net3
    !
    interface Dialer1
    description ISDN dialin
    no ip address
    encapsulation ppp
    bandwidth 64
    dialer-group 1
    no cdp enable
    !
    ip classless
    ip route 192.168.0.0 255.255.240.0 Dialer1
    !
    dialer-list 1 protocol ip permit
    !
    line con 0
    line aux 0
    line vty 0 4
    password 7 bar
    login
    !
    no scheduler allocate
    end
     
    Fritz Schoeler, Jun 20, 2008
    #1
    1. Advertisements

  2. Fritz Schoeler

    J.Cottingim Guest

    Fritz,

    One issue you will need to address is the lack of modems in the
    router... Your users are going to have to dial-in with ISDN instead of
    the standard analog Modem.
     
    J.Cottingim, Jun 20, 2008
    #2
    1. Advertisements

  3. Fritz Schoeler

    Dan Lanciani Guest

    | hi there,
    |
    | i'm totally new to configuring cisco equipment; i got a 2620 from a
    | customer in order to configure dial in via ISDN lines. they have defined
    | a list of users (and passwords), which i already configured (but omitted
    | in the lines below). the users should be able to call a number (MSN),
    | authenticate and have access to the LAN itself. pretty straightforward...
    |
    | however, i'd like to hear some words regarding the configuration i built
    | reading many documents from the cisco website.
    |
    | after some hours of fiddling around, it all boiled down to the following
    | configuration. i'd like to test it in advance, but on my side i just
    | don't have the appropriate equipment.
    |
    | thanks a lot in advance to everybody helping me. this is very much
    | appreciated. thanks!

    You probably want a "dialer pool 1" on Dialer1. You don't seem to have
    done anything about assigning IP addresses.

    Dan Lanciani
    [email protected]*com
     
    Dan Lanciani, Jun 20, 2008
    #3
  4. (config deleted)
    there's a four-port BRI card in the chassis.
    yap, that's the way it is intended to be.

    best,

    fritz
     
    Fritz Schoeler, Jun 24, 2008
    #4
  5. hi dan,

    thanks for you hint; is that IP address issue fixable by assigning a
    (static) IP address to each (used) BRI port or can a pool be defined
    that is then used on demand?

    thanks & best,

    fritz
     
    Fritz Schoeler, Jun 24, 2008
    #5
  6. Fritz Schoeler

    Dan Lanciani Guest

    | Dan Lanciani wrote:
    | > | hi there,
    | > |
    | > | i'm totally new to configuring cisco equipment; i got a 2620 from a
    | > | customer in order to configure dial in via ISDN lines. they have defined
    | > | a list of users (and passwords), which i already configured (but omitted
    | > | in the lines below). the users should be able to call a number (MSN),
    | > | authenticate and have access to the LAN itself. pretty straightforward...
    | > |
    | > | however, i'd like to hear some words regarding the configuration i built
    | > | reading many documents from the cisco website.
    | > |
    | > | after some hours of fiddling around, it all boiled down to the following
    | > | configuration. i'd like to test it in advance, but on my side i just
    | > | don't have the appropriate equipment.
    | > |
    | > | thanks a lot in advance to everybody helping me. this is very much
    | > | appreciated. thanks!
    | >
    | > You probably want a "dialer pool 1" on Dialer1. You don't seem to have
    | > done anything about assigning IP addresses.
    | >
    | > Dan Lanciani
    | > [email protected]*com
    |
    | hi dan,
    |
    | thanks for you hint; is that IP address issue fixable by assigning a
    | (static) IP address to each (used) BRI port or can a pool be defined
    | that is then used on demand?

    There are many ways to do this. You could assign a static address to
    each BRI line or you could make them unnumbered and share the Ethernet's
    address. You also need addresses for the clients. If you trust the
    clients you could let them come with addresses of their own choosing.
    You could also assign their addresses from a pool. Associating specific
    addresses with particular username/password pairs starts to get tricky
    and might require an external authentication server.

    Dan Lanciani
    [email protected]*com
     
    Dan Lanciani, Jun 25, 2008
    #6
  7. hi dan,

    thanks for your reply. IMHO it'd be the easiest solution to keep (is
    that i can keep that actual configuration, 'no ip address' on the
    appropriate BRI interfaces?) the interfaces unnumbered. do i have to NAT
    between the router's ethernet interface and the BRI interfaces?

    i'd like to keep the setup as simple as possible. there's a maximum of
    two users dialing in at the same time, and authentication should also be
    kept very non-complex. no need of assigning certain IP addresses to
    certain users or similar things.

    so, keeping the config the way it is, is there a chance to get this
    thing up and running?

    thanks & best,

    fritz
     
    Fritz Schoeler, Jun 25, 2008
    #7
  8. Fritz Schoeler

    Dan Lanciani Guest

    | thanks for your reply. IMHO it'd be the easiest solution to keep (is
    | that i can keep that actual configuration, 'no ip address' on the
    | appropriate BRI interfaces?)

    The reason you can have no ip address on the BRI interfaces is that they
    are part of a dialer pool. This just moves the requirement for an address
    to the dialer interface.

    | the interfaces unnumbered.

    The dialer interface could be unnumbered.

    | do i have to NAT
    | between the router's ethernet interface and the BRI interfaces?

    That depends entirely on what you are trying to do...

    | i'd like to keep the setup as simple as possible. there's a maximum of
    | two users dialing in at the same time,

    You realize that each BRI typically gives you two 56k or 64k channels,
    right? Four BRI ports seems like overkill for two users. Also, I just
    noticed that you don't have any spid assignments.

    | and authentication should also be
    | kept very non-complex. no need of assigning certain IP addresses to
    | certain users or similar things.
    |
    | so, keeping the config the way it is, is there a chance to get this
    | thing up and running?

    There's more to add. I could try to extract a similar configuration
    from a running system for you, but it doesn't use dialer pools (just
    one BRI).

    Dan Lanciani
    [email protected]*com
     
    Dan Lanciani, Jun 25, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.