Configure your DHCP and DNS settings on Ubuntu 10.10

Discussion in 'Linux Networking' started by Milan Groshev, Sep 18, 2012.

  1. I have problems installing Open Core IMS on Ubuntu 10.10.
    when i restart bind this is what it shows:

    [email protected]:~$ sudo /etc/init.d/bind9 restart
    * Stopping domain name service... bind9 rndc: connect failed: connection refused
    [ OK ]
    * Starting domain name service... bind9 [fail]

    This is my named.conf:

    // This is the primary configuration file for the BIND DNS server named.
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    // If you are just adding zones, please do that in /etc/bind/named.conf.local

    include "/etc/bind/named.conf.options";
    include "/etc/bind/named.conf.local";
    include "/etc/bind/named.conf.default-zones";

    zone “open-ims.test” {

    type master;

    file “/etc/bind/open-ims.dnszone”;


    include “/etc/bind/rndc.key”;

    controls {
    inet port 953
    allow {; } keys { “rndc-key”; };

    please some one HELP :)
    Milan Groshev, Sep 18, 2012
    1. Advertisements

  2. Milan Groshev

    druid Guest

    Looks like your named starts successfully at bootup.

    Does named also misbehave when you restart it step by step, i.e.
    sudo /etc/init.d/bind9 stop
    sudo /etc/init.d/bind9 start

    On my home brewn linux I found that it takes a while to shut it down and an
    immediate restart failed. Adding a delay to the init script fixed it:
    $0 stop
    sleep 1
    $0 start
    druid, Sep 19, 2012
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.