Compiling Squid-2.5.STABLE8 on Fedora Core 3

Discussion in 'Computer Support' started by dotcom, Jun 6, 2005.

  1. dotcom

    dotcom Guest

    Hi I am trying to compile Squid-2.5.STABLE8 on my Fedora Core 3 machine
    it wont compile.
    When I run the make command I get this "make: *** No targets specified
    and no makefile found. Stop.".
    I am very new to Linux so the whole process seems very daunting to me,
    If anyone could simply explain the issue and how to rectify it, I would
    appreciate it.
     
    dotcom, Jun 6, 2005
    #1
    1. Advertisements

  2. dotcom

    why? Guest

    No need to include the command you were using?

    Vanilla FC3 or patch to kernel version / gcc version / all libraries
    downloaded?

    RTFM very carefully.
    In that case look for a version packaged as an RPM.

    Me
     
    why?, Jun 6, 2005
    #2
    1. Advertisements

  3. dotcom

    why? Guest

    Not the most recent, but it may be somewhere else, try www.google.com

    Depending on if you are i386 / x86_64 , a i386 RPM
    http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386/
    [ ] squid-2.5.STABLE3-2.fc1.i386.rpm 09-Jun-2004 10:47 1.1M

    Me
     
    why?, Jun 6, 2005
    #3
  4. dotcom

    dotcom Guest

    Thnx for the RPM, Although I would like to compile it myself, although
    I dont understand what your first post means, and once installed(RPM)
    how would I go and configure it and start it up...?
     
    dotcom, Jun 7, 2005
    #4
  5. How about reading up on it? Big projects such as squid tend to have
    good documentation. I know there's a FAQ and an installation manual.

    The error you experienced sounds like something you'd get if you forgot
    to issue a ./configure. Typical installations from source go something
    like this:

    tar -xvzf install-file-something-4.0.3.tar.gz
    cd install-file-something-4.0.3
    ../configure
    make
    make install

    There's a very newbie friendly forum on www.linuxquestions.org.

    Jeroen
     
    Jeroen Wijnands, Jun 7, 2005
    #5
  6. dotcom

    dotcom Guest

    I follwed your instructions Jeroen but I still get the error when i
    type 'make'. I still get the error.
     
    dotcom, Jun 7, 2005
    #6
  7. Are you logged on as root?

    What's the EXACT output of configure and make?
     
    Jeroen Wijnands, Jun 7, 2005
    #7
  8. dotcom

    why? Guest

    As a beginner I think not.
    You didn't say what compiler, what the, if any options or commands you
    were using.

    Read the install notes / manuals , readme's etc.

    Learn about www.google.com

    http://www.squid-cache.org/Doc/FAQ/FAQ-2.html
    2. Getting and Compiling Squid

    2.1 Which file do I download to get Squid?
    .......

    2.12 I have problems compiling Squid on Platform Foo.

    Please check the page of platforms on which Squid is known to compile.
    Your problem might be listed there together with a solution. If it isn't
    listed there, mail us what you are trying, your Squid version, and the
    problems you encounter.

    http://www.squid-cache.org/Doc/FAQ/FAQ.html#toc2
    3. Installing and Running Squid

    # 3.5 How do I start Squid?
    # 3.6 How do I start Squid automatically when the system boots?
    # 3.7 How do I tell if Squid is running?


    Me
     
    why?, Jun 7, 2005
    #8
  9. dotcom

    why? Guest

    Tried a clean default everything install of FC3 DVD i386 the 03/11/04
    version (on to an Athlon 64 box). Most impressed by the speed (under 2
    minutes) , the last compile of something I did years ago took 51
    minutes.

    D/L SQUID-2.5STABLE10 the tar.gz , worked fine, going by the initial
    unpack notes on the http://squid.visolve.com/squid/sqguide.htm site.

    Now to do a quick dirty config to see if it runs.

    Me
     
    why?, Jun 7, 2005
    #9
  10. dotcom

    dotcom Guest

    Im going to try another distro instead, as I could never compile on my
    FC3 installation, what alternbates do you reccomend?
     
    dotcom, Jun 12, 2005
    #10
  11. dotcom

    why? Guest

    Doesn't sound like a distro issue, after all it's just about the same
    set of tools anyway.

    Always the same message?
    http://www.ugrad.physics.mcgill.ca/reference/Make/make_16.html
    it's a Make issue not a distro issue.

    Yopu may be missing the autoconf package, your are not in the correct
    directory, a path issue , be careful with file name case.

    On the notes mentioned earlier ,
    http://squid.visolve.com/squid/sqguide.htm
    it doesn't say to change directory first before running ./configure


    I would lookup the command line switches to create logs during the
    compile steps and review those. When I tried the Squid make, there were
    1000s of lines of output although there were some things that looked
    like warnings, it worked. That may have been because it was an AMD 64bit
    CPU.
    That seens a bit odd, have you tried some really simple examples, even
    the 'Hello World!" type? You should only need to specify 1 or 2 defaults
    if any. But it won't need any scripts trying to work out lots of
    options.

    What install type did you try, was it Workstation, Server, Everything?
    Maybe you are simply missing some of the development tools / library
    files.

    I haven't tried many since sticking with RH years ago.

    Novell SuSE and Mandriva seem popular.

    Me
     
    why?, Jun 12, 2005
    #11
  12. dotcom

    dotcom Guest

    I did a custon install, not sure which packages I installed though.
     
    dotcom, Jun 13, 2005
    #12
  13. dotcom

    why? Guest

    For a beginner that's interesting, you would at least want to start by
    including the development tools option.

    1) RTFM for rpm , rpm has a lot of query options.

    rpm -qa > installed-listing

    will create an ASCII text file you can view / search.

    2) man rpm

    3) www.google.com
    Web Results 1 - 10 of about 826,000 English pages for
    linux tutorial newbie
    (0.87 seconds)

    4)Try , Applications / System Settings / Add or Remove Applications


    Me
     
    why?, Jun 13, 2005
    #13
  14. dotcom

    dotcom Guest

    Ok its workin now, I didnt have the develop tools installed so I didnt
    have gcc or even cc. Thnx to all for your help
     
    dotcom, Jun 17, 2005
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.