Cisco WRV210 WPA2-Enterprise: no attempt to contact Radius server

Discussion in 'Network Routers' started by Joe, Oct 9, 2010.

  1. Joe

    Joe Guest

    Just in case anyone else is trying this with this router: there seems to
    be an intermittent firmware problem affecting this and other products.

    I had been trying without success to get this router working with
    Freeradius. I had figured out that the Freeradius certificate scripts
    had a problem with signing, and finally found a modified Makefile that
    signed client certificates with the root certificate (what were they
    thinking of, not to do this originally? How could it ever have worked
    with EAP-TLS?). I loaded the appropriate files onto the test client, and
    spent the next hour trying to figure out why the WRV210 was making no
    contact with the Freeradius server. I could see the details of the
    server were correct, and I had certainly been seeing contact during my
    last session on this problem. My client was associating with the router,
    then failing to authenticate. Not a byte was arriving at the Radius server.

    By chance, I came across this, about a completely different product:
    https://supportforums.cisco.com/thread/2018681

    Out of curiosity, I opened the same page on the WRV210, clicked Save,
    and suddenly it burst into life, my Freeradius debug log started
    scrolling wildly up the screen. The certificates were now OK, and I had
    connectivity.

    Back in May, a man from Cisco had tried WPA2-Enterprise on the WAP2000,
    and it had worked for him, so therefore the Cisco user was wrong. Well,
    I've managed to reproduce exactly the same fault on a completely
    different, though related, product.
     
    Joe, Oct 9, 2010
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.