Cisco router, packet size and pcAnywhere...

Discussion in 'Cisco' started by al_636, Jan 19, 2004.

  1. al_636

    al_636 Guest

    we need to use pcAnywhere for about an hour each evening.

    Our home network = ISP adsl 512/128 -> Billion 711ce modem -> Linux
    router (ipcop) -> 8 port switch -> 2 x winxp and 2 x win2k clients.

    The connection between any home client -> remote server -> any of 4
    workstations worked flawlessly with previous isp adsl 512/128.

    We connected to new isp and immediately had trouble connecting to any
    remote workstation. Sometimes it connected, most times it did not or had
    serious dropouts etc.

    We lost connection for a week or so (not new isp related) and for a
    start used a mate's cable connection for our pcAnywhere
    requirements...no problems, worked brilliantly.

    Got a short term dialup account from our new isp and would you believe
    that even though it was slow, pcAnwhere worked perfectly. Absolutely no
    problems.

    Returned to new adsl isp today and damned if we are having the same
    pcAnywhere problems. Non-connects, dropouts etc.

    I have connected the home neywork's modem directly to the home client
    used mostly (thus negating any router/cabling etc influences) but the
    same problems occur.

    In a nutshell, we can access the remote server -> remote workstations
    with everything (inc new isp dialup) but not our new isp's adsl
    connection (other than irregularly).

    I have had contact with the isp and they are looking into it, but time
    is of the essence.

    I got an email with a few questions and the tech said "...a few months
    ago we were having similar problems effecting a broader range of uses.
    People couldn't surf some times, SSL wasn't working, email wasnt
    working, etc. Problem turned out to be an IOS problem in our routers,
    though a workaround was to walk users through modifying their MTU
    settings in their PCs.

    Some people have reported similar issues to what you are experiencing
    when they run some kind of VPN, which was fixed when they reduced their
    MTU to 1400.
    My reasoning is pcAnywhere may create packets that, when passed through
    our routers, become too large, and thus get dropped by upstream
    routers."

    and also

    ".....because chances are it uses encryption of some sort, and depending
    on which layer the encryption is applied at, the packet may not be
    resized to an appropriate size when sent to our routers, hence why it
    only happens when it hits our router. I think the problem may be with
    our DSL terminating router (a 4000 i think), which plugs into a 7500. We
    run a different router (also plugs into the 7500) for dialup, hence why
    the issue doesnt exist when you're on the dialup."

    Does anyone have an opinion as to what may be happening?

    Is there a fix?

    The tech had me drop my mtu incrementally down to 1000 in an attempt to
    resize packets (I think that was it...this is really not my forte) but
    no advance on previously.

    Sorry about the length of this post, but I thought I'd give as much
    background as possible.
     
    al_636, Jan 19, 2004
    #1
    1. Advertisements

  2. <snipped>

    Does the new ISP require you to use PPPoE, and the old one didn't? If so, I
    would suspect an MTU issue.

    Regards
    Jonathan Wilson
     
    Jonathan Wilson, Jan 20, 2004
    #2
    1. Advertisements

  3. al_636

    al_636 Guest

    Thanks for reply, Jonathan.

    Both isps connections per PPPoE.
    They are both on the same national carrier here (Connect Aus), so it was simply
    a matter of configuring the router with my new ip#, the gateway ip# and the dns
    servers.
     
    al_636, Jan 20, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.