Cisco Aironet 1200 Access point

Discussion in 'Cisco' started by KevS, Aug 24, 2006.

  1. KevS

    KevS Guest

    I have a Cisco Aironet 1200B wireless access point and I would like to
    upgrade the software, I have had a good look aroung the Cisco website
    and honestly my head is spinning, could someone please explain the
    process in simple terms,I have managed to convert VXWorks to the Ion
    software but I cant get the Ion software to upgrade, I have downloaded
    the 3C Server TFTP Software. The problem is me, I have no idea what Im
    doing and would really appreciate it if someone could walk me through
    the process, thank in advance.
    KevS, Aug 24, 2006
    1. Advertisements

  2. KevS

    Merv Guest

    see the section "Working with Software Images" at

    1. connnect to the console port of access point

    2. ping IP address of TFTP server to ensure it is reachable

    3. execute archive command to copy image from TFTP server

    4. reload
    Merv, Aug 24, 2006
    1. Advertisements

  3. KevS

    KevS Guest

    Thanks for the reply Merv, this is totally new to me and I was hoping
    for a bit more simple step by step direction.
    KevS, Aug 24, 2006
  4. KevS

    Bod43 Guest

    The cisco documents are quite easy to follow once you get started.
    There will of course be terrible difficulties - what /is/ a console
    what /is/ tftp. If you have no experience of IT then you are starting
    at quite a hard place and if things go wrong it just gets harder. If
    on the other hand you do have some experience that you will
    at least be able to start following the instructions and will be
    stuck somewhere.

    What document are you reading and where are you stuck?

    As you reading Merv's instructions?
    Where are you stuck with these?

    I am not that familiar with the Aironets and so cannot
    just make up instructions, however I can follow the
    cisco documents.

    Have you seen this? :-
    Upgrade Cisco Aironet AP1200 to IOS

    Especially the "Recover from a Failure" section?
    Bod43, Aug 24, 2006
  5. KevS

    KevS Guest

    I have managed to convert the AP to ion spftware but Im stuck trying to
    upgrade the ion software, so I guess you could say Mervs point 3, I
    keep getting error messages in telnet telling me it unable to open
    archive file
    KevS, Aug 24, 2006
  6. KevS

    mcaissie Guest

    The easiest way is through the web interface , and you wont need the TFTP

    Assuming you already have a copy of the new IOS version on your PC,
    and assuming you have access to the AP configuration web interface.

    Just go in the menu at the left of the web interface and click on SYSTEM
    SOFTWARE then on Software Upgrade.
    Next using the Browse button select the new IOS filename and click on
    Upgrade .
    mcaissie, Aug 24, 2006
  7. KevS

    KevS Guest

    I already tried that and it didnt work, It actually says in the release
    notes that the http upgrade wont work as the file is to big
    KevS, Aug 24, 2006
  8. KevS

    Merv Guest

    Once you have a PC connected to the console make sure you enable
    session logging in order to capture commands entered and AP response.

    If you have any further issue, please post all of the session logs.
    Merv, Aug 24, 2006
  9. KevS

    KevS Guest

    I still cant get it to work, Man this is frustrating, this is the
    command I have been trying
    archive download-sw /overwrite /reload
    tftp://­ r.123-8.JA2.tar
    the access point is getting the message as the lights change color etc
    but it is still returning the error cant open file message
    KevS, Aug 25, 2006
  10. KevS

    Bod43 Guest

    Maybe the issue is just with tftp?
    Does you tftp server have a status info or log?
    I like tftpd32.exe partly since it has a log window that tells you
    about file opens, transfer progress, tftp client address, etc
    No install, download, unzip, execute. You need to set the
    directory that the files are to be served from and if the PC
    has more than one interface to select the one you want.

    You could possibly verify the tftp server from another (or the same?)
    c:\temp\>tftp -i my.ip.address GET c1200-k9w7-ta­ r.123-8.JA2.tar

    Should copy the file from the PC's tftp server to the current
    e.g. c:\temp.
    Bod43, Aug 25, 2006
  11. KevS

    KevS Guest

    Just got it to work and guess what the problem was? my firewall was
    stopping it, I turned the firewall off and it worked, thanks everyone
    for the help
    KevS, Aug 25, 2006
  12. KevS

    Hansang Bae Guest

    Do you have some sort of personal FW software running? Don't forget to
    disable it first.



    "Somehow I imagined this experience would be more rewarding" Calvin
    **************************ROT13 MY ADDRESS*************************
    Due to the volume of email that I receive, I may not be able to
    reply to emails sent to my account. Please post a followup instead.
    Hansang Bae, Aug 25, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.