Cisco 851 Newbie Help Please!

Discussion in 'Cisco' started by Steven Smith, Aug 1, 2007.

  1. Steven Smith

    Steven Smith Guest

    We just bought a Cisco 851 Router for the office to replace a failing D-
    Link GamerLounge.

    I got all of the configuration done (I thought!) through the web interface,
    but it will not route connections to the WAN. I verfied that the DNS server
    and T1 line are working fine by direct connection.

    The following things are plugged into our 851:
    - WAN Port: T1 line with static IP
    - Crossover cable connecting to our main switch
    - Our server
    - Our backup system

    The network part works fine. I can ping everybody, and I can VNC to our
    server. The Internet, however, doesn't work.

    I think it has to do with the fact that the 851 doesn't know how to contact
    our ISP's router. There doesn't appear to be any place to input a value for
    "default gateway." I tried putting the IP we have for the gateway into the
    "last hop" section, but I didn't know if it should be done by interface or
    by IP.

    Any suggestions? I'm not really an IT guy, but I know the most about IT at
    the company, so...


    Thanks!

    Steven Smith
     
    Steven Smith, Aug 1, 2007
    #1
    1. Advertisements

  2. Steven Smith

    hinka

    Joined:
    Jul 29, 2006
    Messages:
    22
    Likes Received:
    0
    to configure default route..

    ip route 0.0.0.0 0.0.0.0 serial0
    or
    ip route 0.0.0.0 0.0.0.0 (next hop ip)
     
    hinka, Aug 2, 2007
    #2
    1. Advertisements

  3. Steven Smith

    Peter Guest

    Hi Steve,
    We really need a lot more info here, such a full configuration dump of
    the Router, however a first VERY rough guess is that you need to
    specify a DEFAULT GATEWAY. If you can see the full Router
    configuration, then look for a line that looks like -

    ip route 0.0.0.0 0.0.0.0 <next hop address>

    99% of the time by IP address. There are some situations where an
    interface can be used but they are fairly specific.

    Cheers..................................pk.
     
    Peter, Aug 2, 2007
    #3
  4. Steven Smith

    Steven Smith Guest

    Hi Peter,

    Thanks for the advice so far.

    I think that the problem IS that the default gateway isn't defined; I
    just can't seem to figure out where I need to define it! Is there a
    console command I should use, or is there a way to do it through the GUI?

    When I went to the tab where you define the connection type
    (static/dhcp), I was able to input our IP and netmask, but I didn't see
    the usual "default gateway" option. I wondered how it could possibly
    work without one, but figured if it were needed, it would be there...

    Our external IP is 64.80.9.45, and the ISP's default gateway is
    64.80.9.1. Could I telnet into the router and just type:

    ip route 0.0.0.0 0.0.0.0 64.80.9.1

    Would that work? Or does the 64.80.9.1 need to be .45?


    I knew I should have taken those CCNA classes....
     
    Steven Smith, Aug 2, 2007
    #4
  5. Steven Smith

    Peter Guest

    Hi Steven,
    I dont use the Cisco GUI at all so I cant say.....;-) However if you
    can get into the console ENABLE mode you should end up at a
    <routername>#
    prompt. From there you can type
    show run
    to display the full running configuration (careful about posting that
    raw here, it may contain sensitive password info etc... ).

    Look for lines such as -
    <routername># ip route x.x.x.x y.y.y.y d.d.d.d
    If x & y = 0.0.0.0 then thats the default gateway.

    If there is no such line there, then type =
    <routername># config terminal
    <routername>-confg# ip route 0.0.0.0 0.0.0.0 64.80.9.1
    <routername>-confg# exit
    <routername>-confg# copy run start

    This adds the defautl gateway , the exits configure mode and saves the
    changes to the startup configuration file.
    No it should NOT be YOUR IP address. What MASK value is being used on
    that interface, that may be a clue.

    Good luck....................pk.
     
    Peter, Aug 2, 2007
    #5
  6. Steven Smith

    Steven Smith Guest

    Peter-

    It works! Thanks!

    -Steven


     
    Steven Smith, Aug 3, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.