cisco 837 BT Broadband

Discussion in 'Cisco' started by Toonie, Jan 19, 2005.

  1. Toonie

    RobO Guest

    Hi Brian!

    Before you go any further do a "show ip int brief"

    And see what the output is.
    you will see all the interfaces with their status.
    Just remember some commands will only work at certain prompts ie

    yourname#
    yourname(config)
    yourname(config-if)
    the ip name-server command is done on the "config" prompt

    :-have you got NAT setup on "int dialer1" and "int e0"

    int e0 - "ip nat inside"
    int d1 - "ip nat outside"

    Please check through the config I posted there appears to be some "ppp"
    commands you left out if your last posting of your config is complete.

    Make sure the encapsulation is set on dialer 1 and that the atm
    settings match what i have posted.

    I know there are some gaps in the config i posted but the formatting on
    these web pages aint the best so it probably isnt very clear what
    commands go where.

    Dont give up you are not far....
    my email address is: "roboravec ta hotmail tod com" if you would prefer
    to move this over email.
     
    RobO, Jan 21, 2005
    #21
    1. Advertisements

  2. Toonie

    Toonie Guest

    I have been helped quite a bit, but unfortunately I'm still
    connectionless ( also clueless ) and its probably down to me not
    understanding properly, I have managed to get the Cisco SDM working and
    used it to configure my router but without a great deal of joy although
    I understand that all interfaces are up and look to be working, I can
    Telnet from my PC to the router and from the monitor in SDM it looks
    like I'm sending packets to the internet but nothing seems to enable me
    to connect. Below is my latest running config built with sdm and also
    the show interfaces result. My ISP is BT and the router is an 837 ,has
    any one esle got this combination working and willing to teach me how I
    can get mine working.

    Building configuration...

    Current configuration : 4173 bytes
    !
    ! Last configuration change at 20:21:56 Europe/ Sun Jan 23 2005
    ! NVRAM config last updated at 20:00:32 Europe/ Sun Jan 23 2005
    !
    version 12.2
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname myname
    !
    logging queue-limit 100
    logging buffered 51200 debugging
    logging console critical
    enable secret 5 $1$E.m1$L5D7fViuWCmtztDR.5BeS0
    !
    username myname privilege 15 password 7 xxxxxxxxxxx
    clock timezone Europe/London 0
    clock summer-time Europe/London date Mar 30 2003 1:00 Oct 26 2003 2:00
    ip subnet-zero
    no ip source-route
    ip tcp synwait-time 10
    ip domain name xxxxxxx.xxx
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool sdm-pool1
    network 10.10.10.0 255.255.255.248
    default-router 10.10.10.1
    !
    !
    no ip bootp server
    ip cef
    ip inspect name DEFAULT100 cuseeme
    ip inspect name DEFAULT100 ftp
    ip inspect name DEFAULT100 h323
    ip inspect name DEFAULT100 netshow
    ip inspect name DEFAULT100 rcmd
    ip inspect name DEFAULT100 realaudio
    ip inspect name DEFAULT100 rtsp
    ip inspect name DEFAULT100 smtp
    ip inspect name DEFAULT100 sqlnet
    ip inspect name DEFAULT100 streamworks
    ip inspect name DEFAULT100 tftp
    ip inspect name DEFAULT100 tcp
    ip inspect name DEFAULT100 udp
    ip inspect name DEFAULT100 vdolive
    ip inspect name DEFAULT100 icmp
    ip audit notify log
    ip audit po max-events 100
    ip ssh time-out 60
    ip ssh authentication-retries 2
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    description $FW_INSIDE$$ETH-LAN$
    ip address 10.10.10.1 255.255.255.248
    ip access-group 100 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip route-cache flow
    ip tcp adjust-mss 1452
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    pvc 0/38
    pppoe-client dial-pool-number 1
    !
    !
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    ip access-group 101 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip nat outside
    ip inspect DEFAULT100 out
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 7 xxxxxxxxxxxx
    ppp pap sent-username password 7
    xxxxxxxxxx
    !
    ip nat inside source list 1 interface Dialer0 overload
    ip classless
    ip http server
    ip http authentication local
    ip http secure-server
    !
    logging trap debugging
    access-list 1 remark INSIDE_IF=Ethernet0
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.10.10.0 0.0.0.7
    access-list 100 remark auto generated by SDM firewall configuration
    access-list 100 remark SDM_ACL Category=1
    access-list 100 deny ip host 255.255.255.255 any
    access-list 100 deny ip 127.0.0.0 0.255.255.255 any
    access-list 100 permit ip any any
    access-list 101 remark auto generated by SDM firewall configuration
    access-list 101 remark SDM_ACL Category=1
    access-list 101 deny ip 10.10.10.0 0.0.0.7 any
    access-list 101 permit icmp any any echo-reply
    access-list 101 permit icmp any any time-exceeded
    access-list 101 permit icmp any any unreachable
    access-list 101 deny ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny ip 172.16.0.0 0.15.255.255 any
    access-list 101 deny ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny ip 127.0.0.0 0.255.255.255 any
    access-list 101 deny ip host 255.255.255.255 any
    access-list 101 deny ip host 0.0.0.0 any
    access-list 101 deny ip any any
    dialer-list 1 protocol ip permit
    no cdp run
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    !
    line con 0
    login local
    no modem enable
    transport output telnet
    stopbits 1
    line aux 0
    login local
    transport output telnet
    stopbits 1
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    scheduler interval 500
    !
    End

    Sh interface:-
    ATM0 is up, line protocol is up
    Hardware is PQUICC_SAR (with Alcatel ADSL Module)
    MTU 1500 bytes, sub MTU 1500, BW 288 Kbit, DLY 80 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ATM, loopback not set
    Encapsulation(s): AAL5 AAL2, PVC mode
    10 maximum active VCs, 1024 VCs per VP, 1 current VCCs
    VC Auto Creation Disabled.
    VC idle disconnect time: 300 seconds
    Last input 00:14:22, output 00:00:01, output hang never
    Last clearing of "show interface" counters 00:03:21
    Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: Per VC Queueing
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    63 packets input, 4472 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    23 packets output, 1610 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    ATM0.1 is up, line protocol is up
    Hardware is PQUICC_SAR (with Alcatel ADSL Module)
    MTU 1500 bytes, BW 800 Kbit, DLY 80 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ATM
    63 packets input, 4818 bytes
    23 packets output, 1610 bytes
    0 OAM cells input, 0 OAM cells output
    AAL5 CRC errors : 0
    AAL5 Oversized SDUs : 0
    Last clearing of "show interface" counters never
    Dialer0 is up, line protocol is up (spoofing)
    Hardware is Unknown
    Description: $FW_OUTSIDE$
    Internet address will be negotiated using IPCP
    MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Interface is bound to Vi1
    Last input never, output never, output hang never
    Last clearing of "show interface" counters 00:38:27
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/0/16 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 42 kilobits/sec
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    575 packets input, 21416 bytes
    269 packets output, 25800 bytes
    Bound to:
    Virtual-Access1 is up, line protocol is up
    Hardware is Virtual Access interface
    MTU 1500 bytes, BW 56 Kbit, DLY 100000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Open
    Open: IPCP
    PPPoE vaccess, cloned from Dialer0, loopback not set
    Interface is bound to Di0 (Encapsulation PPP)
    Last input 00:00:17, output never, output hang never
    Last clearing of "show interface" counters 00:14:43
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    276 packets input, 9827 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    115 packets output, 3578 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
    Ethernet0 is up, line protocol is up
    Hardware is PQUICC Ethernet, address is 000e.d774.9811 (bia
    000e.d774.9811)
    Description: $FW_INSIDE$$ETH-LAN$
    Internet address is 10.10.10.1/29
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 10Mb/s
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:00, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/100 (size/max)
    5 minute input rate 1000 bits/sec, 1 packets/sec
    5 minute output rate 2000 bits/sec, 0 packets/sec
    2753 packets input, 327691 bytes, 0 no buffer
    Received 195 broadcasts, 0 runts, 0 giants, 1 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input packets with dribble condition detected
    2478 packets output, 1092535 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    Virtual-Access1 is up, line protocol is up
    Hardware is Virtual Access interface
    MTU 1500 bytes, BW 56 Kbit, DLY 100000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, LCP Open
    Open: IPCP
    PPPoE vaccess, cloned from Dialer0, loopback not set
    Interface is bound to Di0 (Encapsulation PPP)
    Last input 00:00:17, output never, output hang never
    Last clearing of "show interface" counters 00:14:43
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    276 packets input, 9827 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    115 packets output, 3578 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
     
    Toonie, Jan 23, 2005
    #22
    1. Advertisements

  3. Toonie

    Toonie Guest

    Dave, thanks for your reply and you can guess what I'm going to ask -
    please don't be put off by all the posts I realy am trying to
    understand, will your settings work for me, ip address dns settings etc
    how do you know the ip addresses and dns address, can I somehow
    discover mine. Do you have a 837 working to BT, what information do I
    need that is different to yours and where do I find it. After all the
    help Rob has given me I feel at least capable of inputting the right
    commands if only I knew the info first.
     
    Toonie, Jan 23, 2005
    #23
  4. Toonie

    RobO Guest

    Brian,

    Cant believe I didnt notice earlier.
    Under your interface ethernet0 change the subnet mask to the same as
    your pcs ie
    ip address 10.10.10.1 255.255.255.0
    this has to match all the devices on the local network
    Then make sure you change the ip address of your gateway to 10.10.10.1

    use the config I posted it shows the correct addressing structure for
    your local network.
    ethernet0 is considered your local network therefor your subnet masks
    must match.
    Thats probably why SDM was talking about conflicts

    Rob

    Rob
     
    RobO, Jan 24, 2005
    #24
  5. Toonie

    Bob Goddard Guest

    Toonie wrote:
    [...]
    [...]

    You are not going to get very far with that access list. All you
    are allowing in is some ICMP traffic.


    B
     
    Bob Goddard, Jan 24, 2005
    #25
  6. Toonie

    Toonie Guest

    I'm going to reconfig tonight - this was built with cisco sdm. Thanks
    anyway.
    Brian
     
    Toonie, Jan 24, 2005
    #26
  7. Toonie

    Toonie Guest

    I would just like to say a very public thank you to Rob, who has helped
    and guided me thru configuring my first router.
    The router now works and 'feels' much faster.

    Thank You Rob

    Brian
     
    Toonie, Jan 25, 2005
    #27
  8. Toonie

    Dave Watson Guest

    Hello Toonie,

    The settings are working fine for me but I would definitely change the DNS
    addresses to those of BT's and if you have any problems as I did with using
    windows update, I eventually solved it by changing the MTU from 1452 to
    1458.

    Everything is working fine for me now and I'm currently looking into setting
    up a few port forwarding rules that I will need for internet services.

    Dave
     
    Dave Watson, Jan 25, 2005
    #28
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.