Cisco 836 bri-isdn

Discussion in 'Cisco' started by Christian Knoblauch, Feb 19, 2004.

  1. Dear All,

    can someone help me out with an example configuration for one of the
    german call by call isps? I cant get it work using the cisco examples.

    thank you!
    christian
     
    Christian Knoblauch, Feb 19, 2004
    #1
    1. Advertisements

  2. Dear Forum,

    hier are my error-messages from my console and my config. It seems,
    that it is trying to call the number, but it is no getting a connect.
    None of the channel
    LEDs are blinking.

    Whats wrong?
    Thank you!
    Christian

    UERY_RESPONSE
    00:19:242689786724: ISDN BR0 EVENT: UserIdle: callid 0x8029 received
    ISDN_CALL (
    0x0)
    00:19:242689786724: ISDN BR0 EVENTd: UserIdle: Call to 90101901929 at
    64 Kb/s
    00:19:242682836459: ISDN BR0 **ERROR**: isdn_get_guid: Cannot allocate
    a GUID
    00:19:242682836459: ISDN BR0 EVENTd: isdn_get_guid: Got Guid
    817046948170
    00:19:240518168576: ISDN BR0 EVENT: process_bri_call: call id 0x8029,
    called_num
    ber 90101901929, Guid 817046948170speed 64, call type DATA,
    calling_number none
    00:19:240518168576: ISDN BR0 EVENTd: process_bri_call: No name in GTD
    00:19:56: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0, TEI 64 changed
    to up
    00:19:56: ISDN BR0 Q931: TX -> SETUP pd = 65 callref = 0x27
    Channel ID i = 0x83
    Called Party Number i = 0x80, '90101901929'
    Plan:Unknown, Type:Unknown
    Shift to Codeset 6
    Codeset 6 IE 0x1 i = 0x0700
    00:20:00: ISDN BR0 Q931: TX -> DISCONNECT pd = 65 callref = 0x27
    00:20:00: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8029
    calltype 1 HOST_D
    ISCONNECT_ACK
    00:20:00: ISDN BR0 EVENTd: process_rxstate: cause=0x71 (113),
    cause_present=1
    00:20:00: ISDN BR0 EVENTd: calltrkr_call_cleared:
    isdn_info=0x81A09D2C, call_id=
    0x8029
    00:20:00: ISDN BR0 EVENTd: calltrkr_call_cleared: hndl=0l, cause=113,
    Unknown ca
    use value
    00:20:00: ISDN BR0 **ERROR**: host_disconnect_ack: Unfound B-channel
    on Disconne
    ct_Ack call id 0x8029
    00:20:04: ISDN BR0 Q931: TX -> RELEASE pd = 65 callref = 0x27
    00:20:08: ISDN BR0 Q931: TX -> RELEASE pd = 65 callref = 0x27


    !
    version 12.3
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname admin
    !
    boot-start-marker
    boot-end-marker
    !
    no logging buffered
    no logging monitor
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    !
    ip name-server 192.168.100.1
    ip ftp username elephanta
    ip ftp password 7 00011F0314530A081B20
    ip audit notify log
    ip audit po max-events 100
    ip ssh break-string
    no ftp-server write-enable
    no scripting tcl init
    no scripting tcl encdir
    isdn switch-type basic-1tr6
    isdn logging
    !
    !
    !
    no crypto isakmp enable
    !
    partition flash 2 10 2
    !

    interface Ethernet0
    ip address 192.168.1.254 255.255.255.0
    ip access-group 122 out
    ip nat inside
    ip tcp adjust-mss 1452
    !
    interface BRI0
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-1tr6
    ppp authentication pap chap callin
    !
    interface ATM0
    no ip address
    shutdown
    atm vc-per-vp 64
    no atm ilmi-keepalive
    dsl operating-mode annexb-ur2
    !
    interface FastEthernet1
    no ip address
    speed auto
    !
    interface FastEthernet2
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet3
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet4
    no ip address
    duplex auto
    speed auto
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer remote-name freenet
    dialer idle-timeout 300
    dialer string 90101901929
    dialer-group 1
    no cdp enable
    ppp authentication pap chap callin
    ppp chap hostname [email protected]
    ppp chap password 7 020A1D580415
    ppp pap sent-username [email protected] password 7 13090E11041F
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    ip http server
    no ip http secure-server
    !
    !
    logging trap debugging
    logging 192.168.1.184
    access-list 102 permit ip 192.168.1.0 0.0.0.255 any
    dialer-list 1 protocol ip permit

    line con 0
    exec-timeout 120 0
    no modem enable
    transport preferred all
    transport output all
    stopbits 1
    line aux 0
    transport preferred all
    transport output all
    line vty 0 4
    exec-timeout 120 0
    login local
    length 0
    transport preferred all
    transport input all
    transport output all
    !
    scheduler max-task-time 5000
    !
     
    Christian Knoblauch, Feb 20, 2004
    #2
    1. Advertisements

  3. Hey All,

    it needs to be "isdn switch-type basic-net3", than it starts working.

    Best
    Christian
     
    Christian Knoblauch, Feb 25, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.