Cisco 801 Problem

Discussion in 'Cisco' started by Matthias Tinnemeier, Dec 9, 2003.

  1. Hi there!

    I bought a used Cisco 801 last week. Because i never worked on a cisco
    router before, i decided to use the SmartStart software to configure the
    router.

    My setup is a small office-lan within some windows clients, a sni
    primergy 460 linux box as dhcp-/fileserver. the cisco router should do a
    dial-on-demand internet connection (dynamic IP) over isdn to T-Online
    whenever a client want to connect to the internet.

    The 801 has the ip 192.168.0.254, clients get this ip as default gw and
    the t-online nameserver 194.25.2.129 over dhcp.

    i've choosen the preconfigured "German T-Online" profile in the
    SmartStart Software but it didn't worked. So i the router won't dial in
    when i ping an internet-adress or an internet-ip from a client.

    Then i used the Cisco ConfigMaker to configure the router with the same
    result. My Config-File is attached to this posting.

    I don't understand why this won't work. Please help!

    ...sorry for my bad english...
    Matthias








    !
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    no service tcp-small-servers
    no service udp-small-servers
    !
    hostname Cisco801
    !
    enable password cisco801enable
    !
    no ip name-server
    !
    isdn switch-type basic-1tr6
    !
    ip subnet-zero
    no ip domain-lookup
    ip routing
    !
    interface Dialer 1
    description connected to Internet
    ip address negotiated
    ip nat outside
    no ip split-horizon
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 120
    dialer string 01901011
    dialer hold-queue 10
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname xxxx
    ppp chap password xxxxx
    ppp pap sent-username xxxx password xxxxx
    no ppp multilink
    no cdp enable
    !
    interface Ethernet 0
    no shutdown
    description connected to EthernetLAN
    ip address 192.168.0.254 255.255.255.0
    ip nat inside
    keepalive 10
    !
    interface BRI 0
    no shutdown
    description connected to Internet
    no ip address
    dialer rotary-group 1
    !
    ! Access Control List 1
    !
    no access-list 1
    access-list 1 permit 192.168.0.0 0.0.0.255
    !
    ! Dialer Control List 1
    !
    no dialer-list 1
    dialer-list 1 protocol ip permit
    !
    ! Dynamic NAT
    !
    ip nat translation timeout 86400
    ip nat translation tcp-timeout 86400
    ip nat translation udp-timeout 300
    ip nat translation dns-timeout 60
    ip nat translation finrst-timeout 60
    ip nat inside source list 1 interface Dialer 1 overload
    !
    router rip
    version 2
    network 192.168.0.0
    passive-interface Dialer 1
    no auto-summary
    !
    !
    ip classless
    !
    ! IP Static Routes
    ip route 0.0.0.0 0.0.0.0 Dialer 1
    no ip http server
    snmp-server community public RO
    no snmp-server location
    no snmp-server contact
    !
    line console 0
    exec-timeout 0 0
    password cisco801
    login
    !
    line vty 0 4
    password cisco801
    login
    !
    end
     
    Matthias Tinnemeier, Dec 9, 2003
    #1
    1. Advertisements

  2. Matthias Tinnemeier

    PES Guest

    You are likely having isdn issues. You need to determine which switch type
    your telco is using or emulating. Then configure this under int bri0 with
    an "isdn switch-type" command. You also may need to know your spids
    depending on the switch type. They will be configured in the same place
    with isdn spid1 ####### and isdn spid2 #######. You can view the isdn
    status with a "show isdn status". There should be two lines that say spidx
    sent, spidx valid.

    To determine isdn layer two issues, telnet to the router. Go to enable mode
    and type "term mon" (this will redirect the output to your telnet session).
    Then type debug isdn q921. The output may be a little cryptic, but you
    should see roughly the same amount of traffic both directions. If the
    problem appears to be layer 3 isdn (telco infrastructure and digit routing),
    you can use debug isdn q931 (however, you should turn off all debugging
    first "undebug all" or "no debug all")
     
    PES, Dec 9, 2003
    #2
    1. Advertisements

  3. Yep, that may well be it. He's in Germany, so no SPIDs, but his
    switchtype is set to 'basic-1tr6'. Even in Germany, that's not often
    used any more.

    He should try 'isdn switch-type basic-net3'.

    The rest (if it still doesn't work after the change) is good advice.

    Regards,

    Marco.
     
    M.C. van den Bovenkamp, Dec 9, 2003
    #3
  4. Thanks! basic-net3 was the key... it works!
     
    Matthias Tinnemeier, Dec 9, 2003
    #4
  5. Matthias Tinnemeier

    Frank Boehm Guest

    became obsolete, use

    isdn switch-type basic-net3

    do you need a working example for MSN in germany?


    cu Frank
     
    Frank Boehm, Dec 9, 2003
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.