Cisco 3750 to squid routing not working

Discussion in 'Cisco' started by eyaadh, Nov 24, 2011.

  1. eyaadh

    eyaadh

    Joined:
    Nov 24, 2011
    Messages:
    1
    Likes Received:
    0
    hello,

    I am using a cisco 3750 in my network as a gateway, and above it I use a squid machine for caching my internet. My network is like this:

    Basically I have two VLANs on my network which are VLAN10 and VLAN100, VLAN10 is the cooperate network of my office. VLAN100 is the management VLAN which i use for the switches. I keep the squid as well the client in VLAN10.

    squid (192.168.1.50)---->cisco 3750(192.168.1.123)---->Distribution Switch(cisco 2960)---->client PC (192.168.1.5)

    I have done nating on squid and internet is working pretty fine when I use the client gateway as the squid, but when I use the cisco 3750 as my gateway after adding route maps for forwarding the internet traffic coming to the cisco 3750 to squid it disconnects me from internet as well I cannot even reach the switches from the corporate network. These are the only Lines I used for the routing:

    !
    route-map proxy-redirect permit 10
    match ip address 110
    set ip next-hop 192.168.1.50
    !
    access-list 110 deny tcp any any neq www
    access-list 110 deny tcp host 192.168.1.50 any
    access-list 110 permit tcp any any
    !
    interface Vlan999
    ip address 192.168.1.123 255.255.255.0
    no ip proxy-arp
    ip policy route-map internet
    !

    can any one help me please, where have I gone wrong?
     
    eyaadh, Nov 24, 2011
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.