Cisco 3620 LAN routing performance Versus Windows 2000 Server

Discussion in 'Cisco' started by Andrew Smith, Oct 30, 2003.

  1. Andrew Smith

    Andrew Smith Guest

    We recently purchased a Cisco 3620 to replace a Windows 2000 Server.
    The only module that is loaded is a Dual Fast Ethernet NM-2FE2W.
    This is being used as a LAN router (servers one side -- workstations
    other).

    Now, I have run a number of benchmarks to check the throughput of the
    interfaces and interestingly have come up with the following:

    Windows 2000 Server
    -------------------

    Diskbench, one thread, block size 15MB, blocks 10

    Created file: \\192.168.1.5\temp\DiskBench.bin
    Size: 157286400 bytes
    Time: 118780 ms
    Transfer Rate: 1.263 MB/s

    Diskbench, one thread, block size 2MB, blocks 5

    Created file: \\192.168.1.5\temp\DiskBench.bin
    Size: 10485760 bytes
    Time: 4846 ms
    Transfer Rate: 2.064 MB/s

    Create File Bench ended

    Cisco 3620 Router - Full duplex 100Mbit
    -----------------

    Diskbench, one thread, block size 15MB, blocks 10

    Created file: \\192.168.1.5\temp\DiskBench.bin
    Size: 157286400 bytes
    Time: 633501 ms
    Transfer Rate: 0.237 MB/s

    Diskbench, one thread, block size 2MB, blocks 5

    Created file: \\192.168.1.5\temp\DiskBench.bin
    Size: 10485760 bytes
    Time: 33238 ms
    Transfer Rate: 0.301 MB/s

    So basically - a very big difference in throughput.
    100Mbit/s divided by 8 bits is 12MB/sec.
    Take into account 20% overhead for TCP and we are down to 9.6MB/sec.
    Full duplex should alloow 9.6MB/sec either way.

    I then did a test by forcing the interfaces into half duplex mode:

    Diskbench, one thread, block size 2MB, blocks 5

    Created file: \\192.168.1.5\temp\DiskBench.bin
    Size: 10485760 bytes
    Time: 7540 ms
    Transfer Rate: 1.326 MB/s

    Still below the Windows 2000 Server routing performance, but improved
    from full duplex mode.

    Output from show ver:

    Cisco Internetwork Operating System Software
    IOS (tm) 3600 Software (C3620-I-M), Version 12.1(5)T7, RELEASE
    SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/cgi-bin/ibld/view.pl?i=support
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Mon 16-Apr-01 21:43 by ccai
    Image text-base: 0x60008950, data-base: 0x60A28000

    ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE
    SOFTWARE (f
    c1)
    ROM: 3600 Software (C3620-I-M), Version 12.1(5)T7, RELEASE SOFTWARE
    (fc1)

    C3620-ROUTER1 uptime is 2 weeks, 1 day, 9 hours, 30 minutes
    System returned to ROM by power-on
    System image file is "flash:c3620-i-mz.121-5.T7.bin"

    cisco 3620 (R4700) processor (revision 0x81) with 27648K/5120K bytes
    of memory.
    Processor board ID 13891241
    R4700 CPU at 80Mhz, Implementation 33, Rev 1.0
    Bridging software.
    X.25 software, Version 3.0.0.
    2 FastEthernet/IEEE 802.3 interface(s)
    DRAM configuration is 32 bits wide with parity disabled.
    29K bytes of non-volatile configuration memory.
    8192K bytes of processor board System flash (Read/Write)

    Configuration register is 0x2102

    Output from sh run:

    Current configuration : 1190 bytes
    !
    version 12.1
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname xxxxxxxxx
    !
    no logging buffered
    logging rate-limit console 10 except errors
    no logging console
    no logging monitor
    enable secret 5 xxxxxxxxxxxxxxx
    !
    ip subnet-zero
    ip cef
    !
    !
    no ip finger
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.45 255.255.255.128
    speed 100
    half-duplex
    !
    interface FastEthernet0/1
    ip address 192.168.2.1 255.255.255.0
    speed 100
    half-duplex
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    no ip http server
    !
    !
    line con 0
    password xxxxxxx
    logging synchronous
    login
    transport input none
    line aux 0
    line vty 0 4
    password xxxxxxx
    logging synchronous
    login
    !
    end

    I've tried turning on CEF, turning off CEF, using no ip route-cache
    same-interface, Full Duplex and Half Duplex modes and I cannot get the
    Cisco router to perform better than the Windows 2000 Server.

    The router is currently setup simply with static routing so there is
    little CPU overhead.

    Anyone care to comment on possible reasons for the W2K box to
    outperfom the Cisco?? I thought the 3600 series would be at least on
    par.
    I spoke to an engineer from a company that does work for BT and told
    him of the planned usage of the 3620 on our LAN and he never mentioned
    that it would lack in performance.

    Any ideas would be greatly appreciated.

    Regards

    Andrew Smith
     
    Andrew Smith, Oct 30, 2003
    #1
    1. Advertisements

  2. :We recently purchased a Cisco 3620 to replace a Windows 2000 Server.
    :The only module that is loaded is a Dual Fast Ethernet NM-2FE2W.
    :This is being used as a LAN router (servers one side -- workstations
    :eek:ther).

    :Windows 2000 Server
    : Transfer Rate: 1.263 MB/s

    :Cisco 3620 Router - Full duplex 100Mbit
    : Transfer Rate: 0.237 MB/s

    With that kind of transfer rate, I'd say that you almost certainly
    have a duplex conflict.

    Do not trust autonegotiation on Windows 2000: I have personally
    seen Windows 2K Server lie about it's settings. It was claiming
    that it had negotiated 100 full duplex, but my network probe showed it
    was really only 100 half duplex. Forcing both ends of the link
    to full-duplex cleared up that particular problem.
     
    Walter Roberson, Oct 30, 2003
    #2
    1. Advertisements

  3. Andrew Smith

    Thomas Larus Guest

    I agree. It is almost certainly an auto-negotiation issue. This is just
    about the most common LAN problem on Earth. I think that often the
    performance is not as bad as what you are seeing and measuring, so the
    problem can go a while without being detected.


    Best regards,

    Tom Larus, CCIE #10,014
    Author of CCIE Warm-Up: Advice and Learning Labs
    http://www.ipexpert.com/products_services/product.asp?sku=ip7777
     
    Thomas Larus, Oct 31, 2003
    #3
  4. Andrew Smith

    chris Guest

    For starters, stop using file transfers to measure network
    performance. It adds too many extra bottlenecks like disk, pci-bus,
    windows crappy file server performance, etc. Try running ttcp or
    ttcpw which just transfers raw data and gives better numbers. There
    is a java version of ttcp that runs on any platform with java.

    -Chris
     
    chris, Oct 31, 2003
    #4
  5. Andrew Smith

    Andrew Smith Guest

    Further to this I did use Netlatency's SwitchMonitor and it showed one
    interface as HALF-DUPLEX. I had actually forced the Fast Ethernet
    interface to full duplex and a 'show int' command showed both
    interfaces as FULL-DUPLEX.

    As SwitchMonitor is picking up this status via SNMP I just assumed
    that SwitchMonitor got it wrong, as the Cisco was showing both
    interfaces as FULL-DUPLEX.

    I will check to see whether the switch port that the cisco interface
    is connected to could possibly be faulty.

    Can anyone confirm though that the Cisco 3620 would outperform a
    Windows 2000 Server ?? I would of thought the 3600 series would at
    least by on par (3620 = 40kpps vs W2K supposed 50kpps).

    Thanks for your advice.

    Andrew
     
    Andrew Smith, Oct 31, 2003
    #5
  6. Andrew Smith

    Andre Beck Guest

    Besides from the probable duplex mismatch you seem to have:

    IMO that's rather simple when you indeed compare a pretty old non
    distributed router chassis like the 3620 (which is mostly a WAN router
    design) to a somehwat new PC with somewhat decent CPU and I/O bus setup
    (lets say at least multiple PCI buses and non-gameware NICs, i.e. no
    RTL 8139s, but Intel EEPro or Tulips). It's just a matter of brute force.
    Routing two times 100Base Ethernet? I don't have numbers handy, but I
    don't have too good a feeling with that. Newer members of the 26xx
    family have better CPUs than the 3620 and might get a grip here. Or
    have a closer look on the 366x - this is a complete redesign, years
    newer than the 36[24]0.
    Did you mention you are planning to route *Fast* Ethernet with this box
    and expect line speed throughput?
    Boxes that can route even significantly more than just two 100Base
    interfaces would be the Cat3550 or even more charming the Cat3750
    series. You will get almost all features the 3620 has with respect
    to routing if chosing the EI images. But you don't get WAN. Then
    again, you get a decent switch as a bonus ;)
     
    Andre Beck, Nov 1, 2003
    #6
  7. Andrew Smith

    Andrew Smith Guest

    Ok, after performing a number of different tests I settled on using
    netcps to benchmark raw tcp transfer speed.

    By forcing both the FastEthernet interface on the Cisco 3620 router
    and the switch port on my switch to half-duplex I was able to get 4.6
    Megabytes/sec transfer speeds.

    Forcing full duplex dropped the throughput down to an average of 0.6
    Megabytes/sec.

    Funny enough if I change both the switch AND the router to duplex auto
    then transfer speeds do reach 4.6 Megabytes/sec but the switch reports
    the interface to be FULL DUPLEX while the router reports HALF DUPLEX.
    Data transfers without errors however.

    If I force a mismatch then the router goes crazy with transfer errors.

    Weird. But I'm happy with 4.6 Megabytes/sec for now.
    This is much faster than the average 2.0 Megabytes/sec we were getting
    with a Windows 2000 Server configured as a LAN router.

    Cheers,
    Andrew.

     
    Andrew Smith, Nov 14, 2003
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.