Cisco 2611 and Cisco 1721 : Why , why , why ?????

Discussion in 'Cisco' started by sam, Apr 28, 2005.

  1. sam

    sam Guest

    Hello,

    Again i post about my problem (see below)

    I tried with two other IOS : 12.2(16) & 12.2(1a) instead of the
    12.3(5.a) because someone told me of a possible bug of my ios version.
    The pb is still the same.
    Someone else seems to have the same pb as me with a cisco 1721 with an
    ethernet wic card.

    Anybody can help ?
    Thanks
    Sam


    A cisco 2611 is connected to the Internet on interface Ethernet0/1
    with an ethernet ADSL modem.
    When you turn on the cisco, after his boot initialization, it get his
    ip address.
    But the ISP change the Internet address every two or three days, but
    the Cisco doesn't detect the new IP address send by the new ISP
    DHCP/Gateway.
    I must shut / no shut the ethernet0/1 interface and the it take the
    new address.
    The ISP have IP address sometimes in range 62.147.x.y , sometimes
    82.252.X.Y,etc... , but the Gateway (which is too the DHCP server for
    this subnet) is always 62.147.X.254 or 82.252.X.254 or etc .....

    What's wrong in my configuration below ?
    I paste examples (after config file) of :
    - show dhcp lease
    - dhcp debug details

    Thanks a lot for your help !!

    Here is the configuration
    *****
    toto.free.fr#show run
    Building configuration...

    Current configuration : 3494 bytes
    !
    ! Last configuration change at 18:26:10 PCTime Sun Apr 17 2005
    ! NVRAM config last updated at 18:29:19 PCTime Sun Apr 17 2005
    !
    version 12.3
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname toto.free.fr
    !
    boot-start-marker
    boot-end-marker
    !
    enable password 7 xxxxxxx
    !
    clock timezone PCTime 1
    clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
    no aaa new-model
    ip dhcp-client network-discovery informs 2 discovers 2 period 15
    ip subnet-zero
    no ip source-route
    ip cef
    !
    !
    no ip domain lookup
    ip dhcp excluded-address 192.168.0.1 192.168.0.200
    ip dhcp excluded-address 192.168.0.210 192.168.0.254
    !
    ip dhcp pool wifi
    host 192.168.0.250 255.255.255.0
    client-identifier 0100.4005.d042.b8
    !
    ip dhcp pool 1
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.244
    dns-server 212.27.32.177 194.149.160.9
    !
    no ip bootp server
    ip audit notify log
    ip audit po max-events 100
    no ftp-server write-enable
    !
    !
    !
    !
    interface Null0
    no ip unreachables
    !
    interface Ethernet0/0
    description connected to EthernetLAN
    ip address 192.168.0.244 255.255.255.0
    ip access-group 100 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    half-duplex
    !
    interface Ethernet0/1
    description connected to Internet
    ip address dhcp
    ip access-group 103 in
    no ip proxy-arp
    ip nat outside
    half-duplex
    no cdp enable
    !
    ****I removed this part*****
    router rip
    version 1
    passive-interface Ethernet0/1
    network 192.168.0.0
    no auto-summary
    **************************
    !
    ip nat inside source list 1 interface Ethernet0/1 overload
    ip nat inside source static udp 192.168.0.10 5555 interface
    Ethernet0/1 5555
    ip nat inside source static tcp 192.168.0.10 5555 interface
    Ethernet0/1 5555
    ip nat inside source static udp 192.168.0.10 6666 interface
    Ethernet0/1 6666
    ip nat inside source static tcp 192.168.0.10 6666 interface
    Ethernet0/1 6666
    no ip http server
    ip classless
    !
    !
    access-list 1 remark Regle NAT genereale
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 100 remark LAN In
    access-list 100 permit udp any any eq bootpc
    access-list 100 deny ip host 255.255.255.255 any
    access-list 100 deny ip 127.0.0.0 0.255.255.255 any
    access-list 100 permit ip any any
    access-list 103 remark ENTRANT Interface Wan
    access-list 103 permit udp any eq bootpc host 192.168.0.244 eq bootpc
    access-list 103 deny udp any any eq bootps
    access-list 103 deny udp any any eq snmp
    access-list 103 deny udp any any eq snmptrap
    access-list 103 permit ip any any
    snmp-server community public RO 1
    snmp-server enable traps tty
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!
    ****** Acces reserve - Deconnectez vous immediatement ****!^C
    !
    line con 0
    exec-timeout 0 0
    password 7 xxxxxx
    login
    line aux 0
    line vty 0 4
    access-class 1 in
    password 7 xxxx
    login
    !
    ntp clock-period 17208826
    ntp server 195.83.132.135
    ntp server 138.195.130.71
    ntp server 195.83.66.36
    ntp server 207.46.130.100
    !
    !
    end
    *********


    And for information

    toto.free.fr#show dhcp server
    DHCP server: ANY (255.255.255.255)
    Leases: 423
    Offers: 2 Requests: 426 Acks: 423 Naks: 0
    Declines: 0 Releases: 3 Bad: 0
    DNS0: 213.228.0.212, DNS1: 212.27.32.177
    Subnet: 255.255.255.0

    toto.free.fr#show dhcp lease
    Temp IP addr: 82.252.134.XXX for peer on Interface: Ethernet0/1
    Temp sub net mask: 255.255.255.0
    DHCP Lease server: 82.252.134.254, state: 3 Bound
    DHCP transaction id: 364230A
    Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    Temp default-gateway addr: 82.252.134.254
    Next timer fires after: 00:00:32
    Retry count: 0 Client-ID: cisco-0008.ZZZZ.YYYY-Et0/1
    Hostname: toto.free.fr
    toto.free.fr#


    toto.free.fr#show dhcp lease
    Temp IP addr: 82.252.134.xxx for peer on Interface: Ethernet0/1
    Temp sub net mask: 255.255.255.0
    DHCP Lease server: 82.252.134.254, state: 4 Rebinding
    DHCP transaction id: 3D6C09F
    Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    Temp default-gateway addr: 82.252.134.254
    No timer running
    Retry count: 1 Client-ID: 0008.21ea.aa81
    Hostname: toto.free.fr


    Notice the No timer running that don't understand.
    I again do a shut/no shut on the E0/1 interface and now this is the
    new show dhcp lease command :
    toto.free.fr#show dhcp lease
    Temp IP addr: 62.147.217.XXX for peer on Interface: Ethernet0/1
    Temp sub net mask: 255.255.255.0
    DHCP Lease server: 62.147.217.254, state: 5 Renewing
    DHCP transaction id: 8E99607
    Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    Temp default-gateway addr: 62.147.217.254
    Next timer fires after: 00:07:45
    Retry count: 1 Client-ID: 0008.21ea.aa81
    Hostname: toto.free.fr
    toto.free.fr#

    and now there is a Next timer fires after: 00:07:45


    toto.free.fr#debug dhcp detail
    DHCP client activity debugging is on (detailed)
    toto.free.fr#
    2d22h: DHCP: QScan: Bound..T1 fired..Renewing
    2d22h: DHCP: SRequest attempt # 1 for entry:
    2d22h: Temp IP addr: 82.252.138.229 for peer on Interface:
    Ethernet0/1
    2d22h: Temp sub net mask: 255.255.255.0
    2d22h: DHCP Lease server: 82.252.138.254, state: 5 Renewing
    2d22h: DHCP transaction id: B0C85C3
    2d22h: Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    2d22h: Temp default-gateway addr: 82.252.138.254
    2d22h: Next timer fires after: 00:08:59
    2d22h: Retry count: 1 Client-ID: cisco-0008.21ea.aa81-Et0/1
    2d22h: Hostname: toto.free.fr
    2d22h: DHCP: SRequest - ciaddr: 82.252.138.229
    2d22h: DHCP: SRequest placed lease len option: 600
    2d22h: DHCP: SRequest: 310 bytes
    2d22h: DHCP: SRequest: 310 bytes
    2d22h: DHCP: Received a BOOTREP pkt
    2d22h: DHCP: Scan: Message type: DHCP Ack
    2d22h: DHCP: Scan: Server ID Option: 82.252.138.254 = 52FC8AFE
    2d22h: DHCP: Scan: Renewal time: 60
    2d22h: DHCP: Scan: Rebind time: 600
    2d22h: DHCP: Scan: Lease Time: 600
    2d22h: DHCP: Scan: Subnet Address Option: 255.255.255.0
    2d22h: DHCP: Scan: Router Option: 82.252.138.254
    2d22h: DHCP: Scan: DNS Name Server Option: 213.228.0.212,
    212.27.32.177
    2d22h: DHCP: rcvd pkt source: 82.252.138.254, destination:
    82.252.138.229
    2d22h: UDP sport: 43, dport: 44, length: 556
    2d22h: DHCP op: 2, htype: 1, hlen: 6, hops: 0
    2d22h: DHCP server identifier: 82.252.138.254
    2d22h: xid: B0C85C3, secs: 0, flags: 0
    2d22h: client: 0.0.0.0, your: 82.252.138.229
    2d22h: srvr: 82.252.138.254, gw: 0.0.0.0
    2d22h: options block length: 308

    2d22h: DHCP Ack Message
    2d22h: DHCP: Lease Seconds: 600 Renewal secs: 60 Rebind secs:
    600
    2d22h: DHCP: Server ID Option: 82.252.138.254
    2d22h: DHCP: Applying DHCP options:
    2d22h: DHCP: Releasing ipl options:
    2d22h: Setting default_gateway to 82.252.138.254
    2d22h: Adding DNS server address 213.228.0.212
    2d22h: Adding DNS server address 212.27.32.177
    2d22h: DHCP Client Pooling: ***Allocated IP address: 82.252.138.229
    toto.free.fr#no debug dhcp
    DHCP client activity debugging is off
    toto.free.fr#

    toto.free.fr#show arp
    Protocol Address Age (min) Hardware Addr Type Interface
    Internet 62.147.221.83 11 0007.cb09.a2b7 ARPA
    Ethernet0/1
    Internet 192.168.0.9 9 00e0.4cbc.b3fb ARPA
    Ethernet0/0
    Internet 62.147.221.254 30 0007.cb09.a2b7 ARPA
    Ethernet0/1
    Internet 192.168.0.244 - 0008.21ea.aa80 ARPA
    Ethernet0/0
    Internet 62.147.221.205 - 0008.21ea.aa81 ARPA
    Ethernet0/1

    (notice that 0007.cb09.a2b7 is Mac address of ethernet ADSL modem
    and 0008.21ea.aa81 is Mac Address of the Ethernet0/1


    toto.free.fr#traceroute 212.27.32.177

    Type escape sequence to abort.
    Tracing the route to 212.27.32.177

    1 192.168.254.254 36 msec 32 msec 37 msec
    2 212.27.37.61 36 msec 36 msec 36 msec
    3 212.27.51.81 40 msec 36 msec 36 msec
    4 212.27.32.177 36 msec 36 msec 36 msec
    toto.free.fr#


    toto.free.fr#show ip interface
    Ethernet0/0 is up, line protocol is up
    Internet address is 192.168.0.244/24
    Broadcast address is 255.255.255.255
    Address determined by non-volatile memory
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Multicast reserved groups joined: 224.0.0.9
    Outgoing access list is not set
    Inbound access list is 100
    Proxy ARP is disabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are never sent
    ICMP unreachables are never sent
    ICMP mask replies are never sent
    IP fast switching is enabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP CEF switching is enabled
    IP CEF Feature Fast switching turbo vector
    IP multicast fast switching is enabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are Fast, CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is enabled, interface in domain inside
    WCCP Redirect outbound is disabled
    WCCP Redirect inbound is disabled
    WCCP Redirect exclude is disabled
    BGP Policy Mapping is disabled
    Ethernet0/1 is up, line protocol is up
    Internet address is 62.147.221.205/24
    Broadcast address is 255.255.255.255
    Address determined by DHCP
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Outgoing access list is not set
    Inbound access list is 103
    Proxy ARP is disabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is enabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP CEF switching is enabled
    IP CEF Feature Fast switching turbo vector
    IP multicast fast switching is enabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are Fast, CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is enabled, interface in domain outside
    WCCP Redirect outbound is disabled
    WCCP Redirect inbound is disabled
    WCCP Redirect exclude is disabled
    BGP Policy Mapping is disabled
    toto.free.fr#
    toto.free.fr#show interfaces
    Ethernet0/0 is up, line protocol is up
    Hardware is AmdP2, address is 0008.21ea.aa80 (bia 0008.21ea.aa80)
    Description: connected to EthernetLAN
    Internet address is 192.168.0.244/24
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:06, output 00:00:03, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
    0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    4172347 packets input, 1220388978 bytes, 0 no buffer
    Received 53153 broadcasts, 0 runts, 0 giants, 0 throttles
    21 input errors, 0 CRC, 0 frame, 0 overrun, 21 ignored
    0 input packets with dribble condition detected
    5623482 packets output, 935378313 bytes, 0 underruns
    0 output errors, 34856 collisions, 3 interface resets
    0 babbles, 0 late collision, 54663 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    Ethernet0/1 is up, line protocol is up
    Hardware is AmdP2, address is 0008.21ea.aa81 (bia 0008.21ea.aa81)
    Description: connected to Internet
    Internet address is 62.147.221.205/24
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:09, output 00:00:01, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
    0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    5642038 packets input, 941936111 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    2 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input packets with dribble condition detected
    4243738 packets output, 1212690519 bytes, 0 underruns
    202 output errors, 38583 collisions, 9 interface resets
    0 babbles, 0 late collision, 188974 deferred
    202 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    toto.free.fr#

    Something new to understand my problem.
    This morning, i don't have internet because the wan ip change. So i
    write with debug dhcp detail mode on
    toto.free.fr#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    toto.free.fr(config)#ip dhcp-client network-discovery informs 2
    discovers 2 period 15

    And this is what the Cisco do :

    toto.free.fr(config)#
    21:30:02: DHCP: DHCP client process started: 12
    21:30:03: DHCP: SInform
    21:30:03: B'cast on Ethernet0/0 interface from
    192.168.0.244
    21:30:03: B'cast on Ethernet0/1 interface from
    82.252.140.191^Z
    toto.free.fr#
    21:30:18: DHCP: SInform
    21:30:18: B'cast on Ethernet0/0 interface from
    192.168.0.244
    21:30:18: B'cast on Ethernet0/1 interface from
    82.252.140.191
    21:30:19: %SYS-5-CONFIG_I: Configured from console by console
    21:30:33: DHCP: SInform as discover
    21:30:33: B'cast on Ethernet0/0 interface from
    192.168.0.244
    21:30:33: B'cast on Ethernet0/1 interface from
    82.252.140.191
    21:30:48: DHCP: SInform as discover
    21:30:48: B'cast on Ethernet0/0 interface from
    192.168.0.244
    21:30:48: B'cast on Ethernet0/1 interface from
    82.252.140.191
    21:31:03: DHCP: Shutting down from get_netinfo()
    21:31:03: DHCP: Attempting to shutdown DHCP Client

    And like the others time , i shut / no shut the interface because I
    still don't have the connection.... :-(


    toto.free.fr#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    toto.free.fr(config)#interface ethernet0/1
    toto.free.fr(config-if)#shut

    21:32:11: DHCP: SRelease attempt # 1 for entry:
    21:32:11: Temp IP addr: 82.252.140.191 for peer on Interface:
    Ethernet0/1
    21:32:11: Temp sub net mask: 255.255.255.0
    21:32:11: DHCP Lease server: 82.252.140.254, state: 7 Releasing
    21:32:11: DHCP transaction id: 2289
    21:32:11: Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    21:32:11: Temp default-gateway addr: 82.252.140.254
    21:32:11: Next timer fires after: 00:00:00
    21:32:11: Retry count: 1 Client-ID: cisco-0008.21ea.aa81-Et0/1
    21:32:11: Hostname: toto.free.fr
    21:32:11: DHCP: SRelease placed Server ID option: 82.252.140.254
    21:32:11: DHCP: SRelease: 279 bytes
    21:32:11: DHCP: SRelease attempt # 2 for entry:
    21:32:11: Temp IP addr: 82.252.140.191 for peer on Interface:
    Ethernet0/1
    21:32:11: Temp sub net mask: 255.255.255.0
    21:32:11: DHCP Lease server: 82.252.140.254, state: 7 Releasing
    21:32:11: DHCP transaction id: 2289
    21:32:11: Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    21:32:11: Temp default-gateway addr: 82.252.140.254
    21:32:11: Next timer fires after: 00:00:00
    21:32:11: Retry count: 2 Client-ID: cisco-0008.21ea.aa81-Et0/1
    21:32:11: Hostname: toto.free.fr
    21:32:11: DHCP: SRelease placed Server ID option: 82.252.140.254
    21:32:11: DHCP: SRelease: 279 bytes
    21:32:11: DHCP: Releasing ipl options:
    21:32:11: Clearing default gateway and route to 82.252.140.254
    21:32:11: Clearing DNS address 213.228.0.212
    21:32:11: Clearing DNS address 212.27.32.177
    21:32:12: DHCP: SRelease attempt # 3 for entry:
    21:32:12: Temp IP addr: 82.252.140.191 for peer on Interface:
    Ethernet0/1
    21:32:12: Temp sub net mask: 255.255.255.0
    21:32:12: DHCP Lease server: 82.252.140.254, state: 7 Releasing
    21:32:12: DHCP transaction id: 2289
    21:32:12: Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    21:32:12: Next timer fires after:
    toto.free.fr(config-if)# 00:00:01
    21:32:12: Retry count: 3 Client-ID: cisco-0008.21ea.aa81-Et0/1
    21:32:12: Hostname: toto.free.fr
    21:32:12: DHCP: SRelease placed Server ID option: 82.252.140.254
    21:32:12: DHCP: SRelease: 279 bytes
    21:32:13: RAC: DHCP stopped on interface Ethernet0/1
    21:32:15: %LINK-5-CHANGED: Interface Ethernet0/1, changed state to
    administratively down
    21:32:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1,
    changed state to down
    toto.free.fr(config-if)#no shut
    toto.free.fr(config-if)#
    21:32:29: DHCP: DHCP client process started: 10
    21:32:29: RAC: Starting DHCP discover on Ethernet0/1
    21:32:29: DHCP: Try 1 to acquire address for Ethernet0/1
    21:32:29: DHCP: allocate request
    21:32:29: DHCP: zapping entry in DHC_PURGING state for Et0/1
    21:32:29: DHCP: new entry. add to queue
    21:32:29: DHCP: SDiscover attempt # 1 for entry:
    21:32:29: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet0/1
    21:32:29: Temp sub net mask: 0.0.0.0
    21:32:29: DHCP Lease server: 0.0.0.0, state: 1 Selecting
    21:32:29: DHCP transaction id: 475
    21:32:29: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
    21:32:29: Next timer fires after: 00:00:02
    21:32:29: Retry count: 1 Client-ID: cisco-0008.21ea.aa81-Et0/1
    21:32:29: Hostname: toto.free.fr
    21:32:29: DHCP: SDiscover: sending 304 byte length DHCP packet
    21:32:29: DHCP: SDiscover 304 bytes
    21:32:29: B'cast on Ethernet0/1 interface from 0.0.0.0
    21:32:29: DHCP: Received a BOOTREP pkt
    21:32:29: DHCP: Scan: Message type: DHCP Offer
    21:32:29: DHCP: Scan: Server ID Option: 82.252.145.254 = 52FC91FE
    21:32:29: DHCP: Scan: Renewal time: 60
    21:32:29: DHCP: Scan: Rebind time: 600
    21:32:29: DHCP: Scan: Lease Time: 600
    21:32:29: DHCP: Scan: Subnet Address Option: 255.255.255.0
    21:32:29: DHCP: Scan: Router Option: 82.252.145.254
    21:32:29: DHCP: Scan: DNS Name Server Option: 213.228.0.212,
    212.27.32.177
    21:32:29: DHCP: rcvd pkt source: 82.252.145.254, destination:
    255.255.255.255
    21:32:29: UDP sport: 43, dport: 44, length: 556
    21:32:29: DHCP op: 2, htype: 1, hlen: 6, hops: 0
    21:32:29: DHCP server identifier: 82.252.145.254
    21:32:29: xid: 475, secs: 0, flags: 0
    21:32:29: client: 0.0.0.0, your: 82.252.145.104
    21:32:29: srvr: 82.252.145.254, gw: 0.0.0.0
    21:32:29: options block length: 308

    21:32:29: DHCP Offer Message Offered AInterface Ethernet0/1 assigned
    DHCP address 82.252.145.104, mask 255.255.255.0
    ddress: 82.252.145.104
    21:32:29: DHCP: Lease Seconds: 600 Renewal secs: 60 Rebind
    secs: 600
    21:32:29: DHCP: Server ID Option: 82.252.145.254
    21:32:29: DHCP: offer received from 82.252.145.254
    21:32:29: DHCP: SRequest attempt # 1 for entry:
    21:32:29: Temp IP addr: 82.252.145.104 for peer on Interface:
    Ethernet0/1
    21:32:29: Temp sub net mask: 255.255.255.0
    21:32:29: DHCP Lease server: 82.252.145.254, state: 2 Requesting
    21:32:29: DHCP transaction id: 475
    21:32:29: Lease: 600 secs, Renewal: 0 secs, Rebind: 0 secs
    21:32:29: Next timer fires after: 00:00:01
    21:32:29: Retry count: 1 Client-ID: cisco-0008.21ea.aa81-Et0/1
    21:32:29: Hostname: toto.free.fr
    21:32:29: DHCP: SRequest- Server ID option: 82.252.145.254
    21:32:29: DHCP: SRequest- Requested IP addr option: 82.252.145.104
    21:32:29: DHCP: SRequest placed lease len option: 600
    21:32:29: DHCP: SRequest: 322 bytes
    21:32:29: DHCP: SRequest: 322 bytes
    21:32:29: B'cast on Ethernet0/1 interface from 0.0.0.0
    21:32:29: DHCP: Received a BOOTREP pkt
    21:32:29: DHCP: Scan: Message type: DHCP Ack
    21:32:29: DHCP: Scan: Server ID Option: 82.252.145.254 = 52FC91FE
    21:32:29: DHCP: Scan: Renewal time: 60
    21:32:29: DHCP: Scan: Rebind time: 600
    21:32:29: DHCP: Scan: Lease Time: 600
    21:32:29: DHCP: Scan: Subnet Address Option: 255.255.255.0
    21:32:29: DHCP: Scan: Router Option: 82.252.145.254
    21:32:29: DHCP: Scan: DNS Name Server Option: 213.228.0.212,
    212.27.32.177
    21:32:29: DHCP: rcvd pkt source: 82.252.145.254, destination:
    255.255.255.255
    21:32:29: UDP sport: 43, dport: 44, length: 556
    21:32:29: DHCP op: 2, htype: 1, hlen: 6, hops: 0
    21:32:29: DHCP server identifier: 82.252.145.254
    21:32:29: xid: 475, secs: 0, flags: 0
    21:32:29: client: 0.0.0.0, your: 82.252.145.104
    21:32:29: srvr: 82.252.145.254, gw: 0.0.0.0
    21:32:29: options block length: 308

    21:32:29: DHCP Ack Message
    21:32:29: DHCP: Lease Seconds: 600 Renewal secs: 60 Rebind
    secs: 600
    21:32:29: DHCP: Server ID Option: 82.252.145.254
    21:32:31: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
    21:32:32: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1,
    changed state to up
    21:32:32: DHCP Client Pooling: ***Allocated IP address: 82.252.145.104
    21:32:32: Allocated IP address = 82.252.145.104 255.255.255.0
    ^Z
    toto.free.fr#
    21:32:42: %SYS-5-CONFIG_I: Configured from console by console
    21:32:43: DHCP: QScan: Purging entry
    21:32:43: DHCP: deleting entry 81067950 82.252.140.191 from list
    21:32:43: Temp IP addr: 82.252.140.191 for peer on Interface: unknown
    21:32:43: Temp sub net mask: 255.255.255.0
    21:32:43: DHCP Lease server: 82.252.140.254, state: 8 Purging
    21:32:43: DHCP transaction id: 2289
    21:32:43: Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    21:32:43: No timer running
    21:32:43: Retry count: 0 Client-ID:
    21:32:43: Hostname: toto.free.fr
    toto.free.fr#show ip interface brief
    Interface IP-Address OK? Method Status
    Protocol
    Ethernet0/0 192.168.0.244 YES NVRAM up
    up
    Ethernet0/1 82.252.145.104 YES DHCP up
    up
    toto.free.fr#
    21:33:32: DHCP: QScan: Bound..T1 fired..Renewing
    21:33:32: DHCP: SRequest attempt # 1 for entry:
    21:33:32: Temp IP addr: 82.252.145.104 for peer on Interface:
    Ethernet0/1
    21:33:32: Temp sub net mask: 255.255.255.0
    21:33:32: DHCP Lease server: 82.252.145.254, state: 5 Renewing
    21:33:32: DHCP transaction id: 475
    21:33:32: Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    21:33:32: Temp default-gateway addr: 82.252.145.254
    21:33:32: Next timer fires after: 00:08:59
    21:33:32: Retry count: 1 Client-ID: cisco-0008.21ea.aa81-Et0/1
    21:33:32: Hostname: toto.free.fr
    21:33:32: DHCP: SRequest - ciaddr: 82.252.145.104
    21:33:32: DHCP: SRequest placed lease len option: 600
    21:33:32: DHCP: SRequest: 310 bytes
    21:33:32: DHCP: SRequest: 310 bytes
    21:33:32: DHCP: Received a BOOTREP pkt
    21:33:32: DHCP: Scan: Message type: DHCP Ack
    21:33:32: DHCP: Scan: Server ID Option: 82.252.145.254 = 52FC91FE
    21:33:32: DHCP: Scan: Renewal time: 60
    21:33:32: DHCP: Scan: Rebind time: 600
    21:33:32: DHCP: Scan: Lease Time: 600
    21:33:32: DHCP: Scan: Subnet Address Option: 255.255.255.0
    21:33:32: DHCP: Scan: Router Option: 82.252.145.254
    21:33:32: DHCP: Scan: DNS Name Server Option: 213.228.0.212,
    212.27.32.177
    21:33:32: DHCP: rcvd pkt source: 82.252.145.254, destination:
    82.252.145.104
    21:33:32: UDP sport: 43, dport: 44, length: 556
    21:33:32: DHCP op: 2, htype: 1, hlen: 6, hops: 0
    21:33:32: DHCP server identifier: 82.252.145.254
    21:33:32: xid: 475, secs: 0, flags: 0
    21:33:32: client: 0.0.0.0, your: 82.252.145.104
    21:33:32: srvr: 82.252.145.254, gw: 0.0.0.0
    21:33:32: options block length: 308

    21:33:32: DHCP Ack Message
    21:33:32: DHCP: Lease Seconds: 600 Renewal secs: 60 Rebind
    secs: 600
    21:33:32: DHCP: Server ID Option: 82.252.145.254
    21:33:32: DHCP Client Pooling: ***Allocated IP address: 82.252.145.104
    toto.free.fr#no debug dhcp
    DHCP client activity debugging is off
    toto.free.fr#


    Notice that this test is with another version of IOS (Version
    12.2(16))
    because someone told me that it is possible the 12.3(5a) i used thus
    now is perhaps boggus

    PLEASE HELP !!!! I'm going mad with this problem !!!
    Thanks !


    If you need anything else... ask me.

    Thanks very much
     
    sam, Apr 28, 2005
    #1
    1. Advertisements

  2. sam

    anybody43 Guest

    "But the ISP change the Internet address every two or three days, but
    the Cisco doesn't detect the new IP address send by the new ISP
    DHCP/Gateway.
    I must shut / no shut the ethernet0/1 interface and the it take the
    new address. "

    I am not an expert on DHCP, however I would be surprised
    if a DHCP server (your ISP) should be able to
    change addresses already assigned to clients.
    If you read the RFC and post the relevant sections here
    indicating that the behaviour that you are seeing
    is correct then I will endevour to assist further.

    If this is the case then the problem is with
    your ISP and is not a Cisco issue.

    As to workarounds, you could write a script
    to shut and no shut the interface that you run on a
    computer that is attached to the network.

    Some new IOS reputedly has some "kron" like
    scheduling.

    You could connect a clockwork timer to the ethernet cable
    that disconnects it and reconnects it as required.

    You could get a new ISP.
     
    anybody43, Apr 28, 2005
    #2
    1. Advertisements

  3. sam

    sam Guest

    In france, the Internet provider are almost depending of the national
    Telecom provider. And for technical reasons, dslams are reseted every
    2 or 3 days , and that's why (i think) , for all alternative internet
    providers , French people haven't fixe ip address with a standart
    adsl subscription.
    As you can see in the logs i had posted after my config, i don't have
    always the same ip ... Here is example of ip address i have in the
    past : 82.252.140.191 , 82.252.145.104 , 62.147.218.233 ,
    62.147.221.11 , etc ....
    So , can you assist me further ?
    I don't think you're right ... It works pretty well with other routers
    like bewan , draytek, netgear , dlink , level1 . (I had PERSONNALY
    tested for all of these !)
    And it seems that some IOS 12.3 have the bug
    http://www.cisco.com/cgi-bin/Support/Bugtool/onebug.pl?bugid=CSCeh46817&Submit=Search

    But i tried with two 12.2 and it is the same... So i search in my ACL
    to see if there is an error ... but i don't detect it.
    In this situation , it is not very possible to do it (different
    windows pc ) and i don't know how to do it in a script.

    I don't know how to do it. Can you help me ?
    I don't know how to do this ... Can you explain ?
    Not possible. There is a duration of commitment of the Adsl
    subscription. And even, this is the only ISP in this region of france
    that offer free unlimited VoIP .
     
    sam, Apr 28, 2005
    #3
  4. sam

    sam Guest

    And as you can see , i'am not the same to report the pb :

    Subject: DHCP Client problem
    Message-ID: <4270bb83$0$2572$>

    Thanks for your help
    Sam
     
    sam, Apr 28, 2005
    #4
  5. sam

    thrill5 Guest

    It's obvious from the many, many posts you have submitted on this forum that
    you have not been able to solve this problem. I suggest you open a TAC
    case. If this is a bug than opening a TAC case is only way it is going to
    be resolved, if it's not a bug, the TAC will certainly be able to help you.

    Scott
     
    thrill5, Apr 29, 2005
    #5
  6. sam

    sam Guest

    Yes , i'm very suprised that nobody can help me on that problem, and
    that it is only with cisco hardware that i have the problem...
    In one answer of someone here , i understand that to open a TAC , you
    MUST have a support contract with Cisco ... no ? And i don't have it :
    this cisco 2611 is a second-hand equipment...

    Can someone tell me if my config file seems contain error(s) ?
     
    sam, Apr 29, 2005
    #6
  7. sam

    sam Guest

    Is this can help my problem ? Can someone explain me ?
    in another post i see something like that

    interface FastEthernet1/0
    description Connected to LAN
    no ip address
    speed 100
    full-duplex
    !
    interface FastEthernet1/0.1
    description Data VLAN
    encapsulation dot1Q 1 native
    ip address 10.0.0.254 255.255.255.0
    ip nat inside
    no snmp trap link-status

    and i don't really understand.... but if i think like configuration i
    had seen with ATM / dialers , i ask myself if there won't be a
    solution like that :

    interface Ethernet0/1
    description Connected to WAN
    no ip address
    speed 100
    full-duplex
    !
    interface Ethernet0/1.1
    description WAN
    ip address negotiated (or dhcp ) ???

    Can someone explain me and tell me wha t about that ?
    Thanks
    Sam
     
    sam, Apr 29, 2005
    #7
  8. sam

    sam Guest

    I get log when there is a renew of the ip address . Below the most
    interesting part :
    **********
    toto.free.fr#show dhcp lease
    Temp IP addr: 62.147.213.95 for peer on Interface: Ethernet0/1
    Temp sub net mask: 255.255.255.0
    DHCP Lease server: 62.147.213.254, state: 5 Renewing
    DHCP transaction id: 5AE4
    Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    Temp default-gateway addr: 62.147.213.254
    Next timer fires after: 00:04:26
    Retry count: 1 Client-ID: cisco-0008.21ea.aa81-Et0/1
    Hostname: toto.free.fr
    toto.free.fr#
    toto.free.fr#
    toto.free.fr#
    toto.free.fr#
    01:12:20: DHCP: QScan: Renewal..T2 fired..Rebinding
    01:12:20: DHCP: SRequest attempt # 1 for entry:
    01:12:20: Temp IP addr: 62.147.213.95 for peer on Interface:
    Ethernet0/1
    01:12:20: Temp sub net mask: 255.255.255.0
    01:12:20: DHCP Lease server: 62.147.213.254, state: 4 Rebinding
    01:12:20: DHCP transaction id: 5AE4
    01:12:20: Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    01:12:20: Temp default-gateway addr: 62.147.213.254
    01:12:20: No timer running
    01:12:20: Retry count: 1 Client-ID: cisco-0008.21ea.aa81-Et0/1
    01:12:20: Hostname: toto.free.fr
    01:12:20: DHCP: SRequest - ciaddr: 62.147.213.95
    01:12:20: DHCP: SRequest placed lease len option: 600
    01:12:20: DHCP: SRequest: 310 bytes
    01:12:20: DHCP: SRequest: 310 bytes
    01:12:20: DHCP: Received a BOOTREP pkt
    01:12:20: DHCP: Scan: Message type: DHCP Nak
    01:12:20: DHCP: Scan: Server ID Option: 82.252.136.254 = 52FC88FE
    01:12:20: DHCP: rcvd pkt source: 82.252.136.254, destination:
    62.147.213.95
    01:12:20: UDP sport: 43, dport: 44, length: 556
    01:12:20: DHCP op: 2, htype: 1, hlen: 6, hops: 0
    01:12:20: DHCP server identifier: 82.252.136.254
    01:12:20: xid: 5AE4, secs: 0, flags: 0
    01:12:20: client: 0.0.0.0, your: 0.0.0.0
    01:12:20: srvr: 0.0.0.0, gw: 0.0.0.0
    01:12:20: options block length: 308

    01:12:20: DHCP Nak Message
    01:12:20: DHCP: Server ID Option: 82.252.136.254
    01:12:20: DHCP: rcv nak 82.252.136.254 is not our server
    62.147.213.254
    ******************

    Notice the end : it seems that it refuse the new dhcp server
    How to correct this ????
    Thanks
    Sam
     
    sam, Apr 29, 2005
    #8
  9. sam

    sam Guest

    I get log when there is a renew of the ip address . Below the most
    interesting part :
    **********
    toto.free.fr#show dhcp lease
    Temp IP addr: 62.147.213.95 for peer on Interface: Ethernet0/1
    Temp sub net mask: 255.255.255.0
    DHCP Lease server: 62.147.213.254, state: 5 Renewing
    DHCP transaction id: 5AE4
    Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    Temp default-gateway addr: 62.147.213.254
    Next timer fires after: 00:04:26
    Retry count: 1 Client-ID: cisco-0008.21ea.aa81-Et0/1
    Hostname: toto.free.fr
    toto.free.fr#
    toto.free.fr#
    toto.free.fr#
    toto.free.fr#
    01:12:20: DHCP: QScan: Renewal..T2 fired..Rebinding
    01:12:20: DHCP: SRequest attempt # 1 for entry:
    01:12:20: Temp IP addr: 62.147.213.95 for peer on Interface:
    Ethernet0/1
    01:12:20: Temp sub net mask: 255.255.255.0
    01:12:20: DHCP Lease server: 62.147.213.254, state: 4 Rebinding
    01:12:20: DHCP transaction id: 5AE4
    01:12:20: Lease: 600 secs, Renewal: 60 secs, Rebind: 600 secs
    01:12:20: Temp default-gateway addr: 62.147.213.254
    01:12:20: No timer running
    01:12:20: Retry count: 1 Client-ID: cisco-0008.21ea.aa81-Et0/1
    01:12:20: Hostname: toto.free.fr
    01:12:20: DHCP: SRequest - ciaddr: 62.147.213.95
    01:12:20: DHCP: SRequest placed lease len option: 600
    01:12:20: DHCP: SRequest: 310 bytes
    01:12:20: DHCP: SRequest: 310 bytes
    01:12:20: DHCP: Received a BOOTREP pkt
    01:12:20: DHCP: Scan: Message type: DHCP Nak
    01:12:20: DHCP: Scan: Server ID Option: 82.252.136.254 = 52FC88FE
    01:12:20: DHCP: rcvd pkt source: 82.252.136.254, destination:
    62.147.213.95
    01:12:20: UDP sport: 43, dport: 44, length: 556
    01:12:20: DHCP op: 2, htype: 1, hlen: 6, hops: 0
    01:12:20: DHCP server identifier: 82.252.136.254
    01:12:20: xid: 5AE4, secs: 0, flags: 0
    01:12:20: client: 0.0.0.0, your: 0.0.0.0
    01:12:20: srvr: 0.0.0.0, gw: 0.0.0.0
    01:12:20: options block length: 308

    01:12:20: DHCP Nak Message
    01:12:20: DHCP: Server ID Option: 82.252.136.254
    01:12:20: DHCP: rcv nak 82.252.136.254 is not our server
    62.147.213.254
    ******************

    Notice the end : it seems that it refuse the new dhcp server
    How to correct this ????
    Thanks
    Sam
     
    sam, Apr 30, 2005
    #9
  10. sam

    thrill5 Guest

    You can purchase a support contract for all Cisco equipment even if that
    equipment is purchase second-hand.

    A 1-year support contract can be had for your router for $280 list. This
    includes hardware replacement. Sounds like a bargain!

    CON-SNT-2611ADSL SMARTNET 8X5XNBD 2611XM ADSL Bundle $280

    Scott
     
    thrill5, May 1, 2005
    #10
  11. sam

    sam Guest

    Thanks for the information ... Where do you find it ? I can't find out
    on cisco's site ? (have you a link to give ? ) Because it 's a 2611
    NOT a 2611XM that i have....

    Have you read the new information i posted about the DHCP Nack message
    in the same thread ?
    01:12:20: DHCP Nak Message
    01:12:20: DHCP: Server ID Option: 82.252.136.254
    01:12:20: DHCP: rcv nak 82.252.136.254 is not our server
    62.147.213.254



    and about a possibility using ethernet0/1.1 in the same thread to ?

    Thanks
     
    sam, May 1, 2005
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.