Cisco 1841 with ADSL backup

Discussion in 'Cisco' started by j.kost, Jan 8, 2008.

  1. j.kost

    j.kost Guest

    Hello,

    I'm having trouble configuring a Cisco 1841 with an SDSL connection.
    The idea is that when the SDSL connection goes down, the ADSL
    connections comes up, and takes over.

    I already have this working with an ADSL connection with ISDN backup.
    This works fine.

    I'm using the following config:

    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname XXXX
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 warnings
    enable secret bonbon
    !
    no aaa new-model
    ip cef
    !
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool solcon
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 212.45.32.3
    !
    !
    ip sla monitor 1
    type echo protocol ipIcmpEcho 212.45.32.3
    timeout 1000
    threshold 2
    frequency 3
    ip sla monitor schedule 1 life forever start-time now
    username solcon password bonbon
    !
    !
    controller DSL 0/0/0
    mode atm
    line-term cpe
    line-mode 2-wire line-zero
    dsl-mode shdsl symmetric annex B
    line-rate auto
    !
    !
    track 1 rtr 1 reachability
    !
    !
    interface FastEthernet0/0
    description LAN klant
    ip address 192.168.1.1 255.255.255.0
    duplex auto
    speed auto
    no keepalive
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    no keepalive
    !
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    pvc 0 0/36
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface ATM0/1/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0 0/36
    encapsulation aal5mux ppp dialer
    dialer pool-member 2
    !
    !
    interface Dialer0
    mtu 1492
    ip unnumbered FastEthernet0/0
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username XXXX password XXXX
    !
    interface Dialer1
    mtu 1492
    ip unnumbered FastEthernet0/0
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 2
    dialer-group 2
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username XXXX password XXXX
    !
    ip local policy route-map LOCAL-POLICY
    ip route 0.0.0.0 0.0.0.0 Dialer0 track 1
    ip route 0.0.0.0 0.0.0.0 Dialer1 254
    !
    no ip http server
    ip http authentication local
    ip http timeout-policy idle 5 life 86400 requests 10000
    !
    access-list 101 permit icmp any host 212.45.32.3
    dialer-list 1 protocol ip permit
    dialer-list 2 protocol ip permit
    route-map LOCAL-POLICY permit 10
    match ip address 101
    set interface Dialer0 Null0
    !
    !
    control-plane
    !
    !
    line con 0
    login local
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input telnet
    line vty 5 15
    privilege level 15
    login local
    transport input telnet
    !
    scheduler allocate 20000 1000
    end

    This is used in an MPLS enviroment. That is the reason the local IP-
    adresses are used.
    The problem i am having in comparisation to the ADSL/ISDN config, is
    that because i'm not using DDR, both ADSL lines are always up.

    When i have another location in the same MPLS enviroment, and I ping
    the IP-address of this location (192.168.1.1) the route is shorter via
    the ADSL connection (supposed to be backup), instead of going through
    the SDSL connection.

    I cannot change the routes. This is the providers core networks, so
    that is not possible.

    What i am looking to use is an dialer idle-timeout. So that the ADSL
    connection goes down when not used, and goes up when the SDSL
    connection fails.
    I tried it, but because of LCP echo (part of PPP), the ADSL connection
    keeps receiving packets, and therefore is not idle.

    Anybody got any ideas?
     
    j.kost, Jan 8, 2008
    #1
    1. Advertisements

  2. j.kost

    j.kost Guest

    Please, anybody??
     
    j.kost, Jan 14, 2008
    #2
    1. Advertisements

  3. You can't do what you are trying. I submitted a bug report maybe like
    8 years ago asking for such-a-thing, and it came back as not a feature
    they're going to support. DSL is an always on technology, not going to
    be a dial-up technology.

    You'll have to setup router-tracking to ping out the various links and
    do static routing failover if needed.

    In my setups, I frequently control both ends, and setup floating routes
    on the CPE side, and do some metric shuffling for the internal dynamic
    routing protocol to prefer one link vs. the other to do what you want.

    You probably don't get to have that level of control though.
     
    Doug McIntyre, Jan 14, 2008
    #3
  4. j.kost

    j.kost Guest

    I am using router-tracking and static routing failover (see my config)
    The problem is not the outgoing traffic, but the incoming traffic.

    The traffic is incoming over the 'backup' interface, because in the
    MPLS enviroment, this is the shortest route.
    It's not possible to change the routing in the MPLS enviroment.

    Is there no other option?
     
    j.kost, Jan 16, 2008
    #4
  5. j.kost

    j.kost Guest

    Anyone?
     
    j.kost, Jan 22, 2008
    #5
  6. j.kost

    j.kost Guest

    Please, guys (or girls), help me out here a bit :)
     
    j.kost, Jan 28, 2008
    #6
  7. j.kost

    j.kost Guest

    bump :)
     
    j.kost, Feb 6, 2008
    #7
  8. j.kost

    Mike Rahl Guest

    To advertise a backup route over the Internet, either you or your ISP
    must advertise, using BGP metrics (such as Local preference) that 1
    route takes preference over the other. Most likely, you will have to
    request a service that puts BGP on your local router, but the ISP
    (especially if both links are with the same provider) may be willing
    to do it on their routers. This will require static IPs on both
    routers as well as BGP
     
    Mike Rahl, Feb 6, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.