Cisco 1841 - Trying to assign all 5 static IPs to network

Discussion in 'Cisco' started by extremesanity, Feb 26, 2007.

  1. On my business SBC static plan I have 5 static ips.

    I have the 2wire modem setup as a bridge, a gateway address assigned
    to the cisco router, a public ip assigned to the cisco router, and a
    public ip assigned to the firewall that then does NAT to private
    addresses.

    I setup the cisco router to assign an IP from SBC automatically via
    PPPOE on the Dialer1 interface that is assigned to the 0/1 ethernet
    interface. The address assigned is xx.xx.xx.230/32.

    I TRY to set the 0/0 ethernet statically to xx.xx.xx.225
    255.255.255.248, which is the subnet SBC provides me. The router
    throws an error: xx.xx.xx.224 overlaps with Dialer1.

    I can set the router to xx.xx.xx.225 or xx.xx.xx.226 with subnet
    255.255.255.252, and everything works.

    However I need all of my 5 IP addresses. Setting the subnet mask to
    255.255.255.252 does not allow me the full range: 225 to 229.

    Anyone have any idea what is going on here?

    Current configuration : 1248 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname xxxxxxxxxx
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 xxxxxxxxxxxxxx
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    --More--  !
    !
    !
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    !
    no ftp-server write-enable
    !
    !
    !
    !
    interface FastEthernet0/0
    description LAN
    ip address xx.xx.xx.225 255.255.255.252
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description WAN
    no ip address
    speed auto
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    encapsulation ppp
    no ip mroute-cache
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp chap hostname
    ppp chap password 0 apasswordishere
    ppp pap sent-username 0
    apasswordishere
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    !
    !
    dialer-list 1 protocol ip permit
    !
    control-plane
    !
    !
    line con 0
    password apasswordishere
    login
    line aux 0
    line vty 0 4
    password apasswordishere
    login
    !
    end
     
    extremesanity, Feb 26, 2007
    #1
    1. Advertisements

  2. extremesanity

    T-RoyNewBE

    Joined:
    Jul 25, 2011
    Messages:
    1
    Likes Received:
    0
    Location:
    Bmore
    try /29 255.255.255.248
     
    T-RoyNewBE, Jul 25, 2011
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.