cisco 1803 shdsl config problems

Discussion in 'Cisco' started by Alex, Aug 2, 2007.

  1. Alex

    Alex Guest

    hey, im configuring my first shdsl router and i am struggling a bit
    with the configuration. currently the dsl light shows solid green but
    i cannot access the internet.

    heres the show run

    sho run

    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname router
    !
    boot-start-marker
    boot-end-marker
    !
    security authentication failure rate 3 log
    security passwords min-length 6
    logging buffered 51200 debugging
    logging console critical
    enable secret 5 password
    no aaa new-model
    !
    resource policy
    !
    clock timezone PCTime 0
    clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
    no ip source-route
    !
    !
    ip cef
    ip tcp synwait-time 10
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool sdm-pool1
    import all
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    !
    !
    no ip bootp server
    no ip domain lookup
    ip domain name yourdomain.com
    username user privilege 15 secret 5 password
    !
    !
    controller DSL 0
    mode atm
    line-term cpe
    line-mode 2-wire line-zero
    dsl-mode shdsl symmetric annex B
    line-rate auto
    !
    !
    !
    interface FastEthernet0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    shutdown
    duplex auto
    speed auto
    !
    interface BRI0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    encapsulation hdlc
    ip route-cache flow
    shutdown
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    !
    interface FastEthernet5
    !
    interface FastEthernet6
    !
    interface FastEthernet7
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    !
    interface ATM0.1 point-to-point
    description $ES_WAN$$FW_OUTSIDE$
    ip nat outside
    no snmp trap link-status
    pvc 0/38
    pppoe-client dial-pool-number 1
    !
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$$ES_LAN$$FW_INSIDE$
    ip address 10.10.10.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip route-cache flow
    ip tcp adjust-mss 1412
    !
    interface Dialer0
    interface Dialer0
    ip address dhcp
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname username
    ppp chap password 7 password
    ppp pap sent-username username password 7 password
    !
    !
    ip http server
    ip http authentication local
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 1 interface ATM0.1 overload
    !
    logging trap debugging
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.10.10.0 0.0.0.255
    dialer-list 1 protocol ip permit
    no cdp run
    !
    control-plane
    !
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    !
    line con 0
    login local
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    privilege level 15
    login local
    transport input telnet
    line vty 5 15
    privilege level 15
    login local
    transport input telnet
    !
    scheduler allocate 4000 1000
    scheduler interval 500
    end


    thanks

    Alex
     
    Alex, Aug 2, 2007
    #1
    1. Advertisements

  2. Alex

    Bod43 Guest

    < snipped >

    I am in the UK and this is PPPoA.

    Are you geting an address on Dialer 0?

    sh ip int brie

    If so then the only problem is your NAT.

    ip nat inside source list 1 interface dialer0 overload


    Otherwise this may assist.

    ! This ATM is what we have in a WORKING one

    interface ATM0
    no ip address
    ip virtual-reassembly
    atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1

    ! #### OR IF YOU PREFER ###

    interface ATM0
    no ip address
    no atm ilmi-keepalive
    !
    interface ATM0.1 point-to-point
    description $ES_WAN$$FW_OUTSIDE$
    ip nat outside
    no snmp trap link-status
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1


    ip nat inside source list 1 interface dialer0 overload


    interface Dialer0
    description
    ip address negotiated ! <-- ########
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1400
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname your.username
    ppp chap password your.password
    ppp ipcp dns request ! <-- optionsl?


    #####

    For pppoe on ADSL I have used

    pvc x/yy
    pppoe-client dial-pool-number 1

    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    priority-group 1
    ppp authentication pap chap callin
    ppp chap hostname xxxx
    ppp chap password yyyyy

    Good luck.
     
    Bod43, Aug 2, 2007
    #2
    1. Advertisements

  3. What other DSL modes are possible here? The 1803 has an SDSL modem, hasn't
    it? But I'm afraid it's not able to also "talk" ADSSL?

    TIA

    fw
     
    Frank Winkler, Aug 3, 2007
    #3

  4. I haven't seen any DSL router be able to talk SHDSL and ADSL at the
    same time just by a register change. In general, from what I've seen
    the controller chips in use are made specific to the
    application. Ie. the 1803 has a SHDSL controller on it. The 1801 has
    an ADSL controller on it.
     
    Doug McIntyre, Aug 3, 2007
    #4
  5. Alex

    Alex Guest

    hi, the problem was there was no routing setup so i added a default
    route (ip route 0.0.0.0 0.0.0.0 dialer0) and now all works fine
    and as to the actual interface yes that is correct that they are not
    interchangeable.

    Alex
     
    Alex, Aug 5, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.