Cisco 1721 routing public and private ips?

Discussion in 'Cisco' started by Ajar, Oct 24, 2007.

  1. Ajar

    Ajar

    Joined:
    Oct 24, 2007
    Messages:
    1
    Likes Received:
    0
    What an amazing resource... thank you all... I'm fairly new to all this, however I can get around ok.... I'm sure this is really simple but I've searched alot for the answer and I can't get anything that works...

    What we're trying to do here is keep routing our our private IPs for our office workstations, adding the routing of public IPs for our servers. We've currently got FastEthernet0 bound to 192.168.1.155. We'd like to add 11.22.117.195 as a secondary IP to that interface and whatever else would be needed to route the our servers with public 11.22.117.xxx ips.

    Also, I want to add... If I try:

    ip address 11.22.117.195 255.255.255.192 secondary

    I get:

    % 11.22.117.192 is assigned to Serial0.2

    Thanks in advance for your help....

    Ajar

    Current configuration : 1876 bytes
    !
    version 12.3
    service nagle
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $xxxxxxxxxxxxxxxxxxxxxxxx
    !
    no aaa new-model
    ip subnet-zero
    no ip source-route
    !
    !
    ip dhcp excluded-address 11.22.117.193
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    !
    interface FastEthernet0
    ip address 192.168.1.155 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    speed auto
    no keepalive
    !
    interface Serial0
    no ip address
    ip nat outside
    ip virtual-reassembly
    encapsulation frame-relay IETF
    service-module t1 timeslots 1-24
    service-module t1 fdl both
    frame-relay lmi-type ansi
    !
    interface Serial0.1 point-to-point
    ip nat outside
    ip virtual-reassembly
    frame-relay interface-dlci 16 ppp Virtual-Template1
    !
    interface Serial0.2 point-to-point
    ip address 11.22.117.193 255.255.255.192
    no cdp enable
    !
    interface Virtual-Template1
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    ppp chap hostname [email protected]
    ppp chap password xxxxxxxxxxxxxxxxxxxxxx
    ppp ipcp dns request
    ppp ipcp route default
    ppp ipcp address accept
    !
    ip classless
    no ip http server
    !
    ip nat pool LegalPool 11.22.117.194 11.22.117.199 netmask 255.255.255.192
    ip nat inside source list 20 pool LegalPool overload
    !
    access-list 20 permit 192.168.1.0 0.0.0.255
    !
    control-plane
    !
     
    Last edited: Oct 24, 2007
    Ajar, Oct 24, 2007
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.