Cisco 1605R maximum throughput on cable modem?

Discussion in 'Cisco' started by Jaap Hubert, Jan 17, 2005.

  1. Jaap Hubert

    Jaap Hubert Guest

    Hello All,

    I just purchased two Cisco 1605R routers and I installed a fairly recent IOS
    (12.2(1b)) that was still able to fit on the 4 MB Flash.

    I have connected my lan (8 PC's) successfully to the cable modem and
    everything is working like a charm. The IP-address is assigned by using DHCP
    and I have installed several accesslists on the 1605R. The trouble is that
    the performance is less then I was used to and before I used a Linksys
    router (WRT54G).

    With the Linksys I managed to get 6.4 Mbit/sec out of my Motorola
    cablemodem, but with the Cisco 1605R the throughput is always between 4.4 en
    4.8 Mbit/sec. When I connect the modem straight to one of the PC's the speed
    is 6.4 Mbit/sec as well.

    Is it possible that the Cisco 1605R is not up to the task and is unable to
    cope with these speeds?

    This is my output of Sh Ver:

    Cisco Internetwork Operating System Software
    IOS (tm) 1600 Software (C1600-Y-M), Version 12.2(1b), RELEASE SOFTWARE (fc1)
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Fri 15-Jun-01 05:47 by pwade
    Image text-base: 0x02005000, data-base: 0x0260A8AC

    ROM: System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)
    ROM: 1600 Software (C1600-RBOOT-R), Version 12.0(3)T, RELEASE SOFTWARE
    (fc1)

    Edge1 uptime is 2 days, 16 hours, 3 minutes
    System returned to ROM by reload
    System image file is "flash:c1600-y-mz.122-1b.bin"

    cisco 1605 (68360) processor (revision C) with 9728K/512K bytes of memory.
    Processor board ID 26403914, with hardware revision 00000004
    Bridging software.
    X.25 software, Version 3.0.0.
    2 Ethernet/IEEE 802.3 interface(s)
    System/IO memory with parity disabled
    8192K bytes of DRAM onboard 2048K bytes of DRAM on SIMM
    System running from RAM
    7K bytes of non-volatile configuration memory.
    4096K bytes of processor board PCMCIA flash (Read/Write)

    I did strip the Access-lists of the interfaces and there was no difference.
    During a download of 100 Mbytes the 5 second CPU utilization is reported by
    "sh proc cpu" as: 50%/12%

    Can anyone shed some light on this issue?

    With regards,

    Jaap Hubert
     
    Jaap Hubert, Jan 17, 2005
    #1
    1. Advertisements

  2. :With the Linksys I managed to get 6.4 Mbit/sec out of my Motorola
    :cablemodem, but with the Cisco 1605R the throughput is always between 4.4 en
    :4.8 Mbit/sec. When I connect the modem straight to one of the PC's the speed
    :is 6.4 Mbit/sec as well.

    :Is it possible that the Cisco 1605R is not up to the task and is unable to
    :cope with these speeds?

    First question would be whether you are referring to raw bits/s
    or to payload bits/s: i.e., are you talking about "download speed"
    or are you talking about a figure that includes ethernet overheads?

    The 1605R is rated to 2.05 megabits per second with 64 byte
    packets. 4000 packets per second; the performance you see would
    correspond to an average of 150 bytes/packet.

    Check to see if you have CEF turned on. If you do not, then your
    maximum performance would be 600 pps. At an effective packet size
    of 1540 (including preamble and intra-packet gap), that would
    be a *maximum* raw performance of 7.4 Mbit/s; your measured rate
    would correspond to about 65% of that, which is plausible if you
    are using any features (e.g., you probably have NAT turned on),
    and again plausible because the average packet size is usually much
    smaller -- except when you are doing a sustained ftp transfer or the
    like, packet sizes tend to follow a bimodal distribution with
    -roughly- 2/3 of the packets being fairly small (64 bytes or not much
    bigger) and the rest tending to be near maximum size.


    I just pulled a nice link out of the newsgroup archives to a
    Cisco document that I had never seen before (and I'd looked
    for this kind of information!) that compares the performance
    of the various models of routers:

    http://www.cisco.com/warp/public/765/tools/quickreference/routerperformance.pdf

    [Thanks for posting that, Aaron!]
     
    Walter Roberson, Jan 18, 2005
    #2
    1. Advertisements

  3. Jaap Hubert

    Jaap Hubert Guest

    Hi,
    Thanks for your reply!
    I am talking about "download speed"

    As far as I gathered CEF is not available on an Cisco 1605

    Edge1#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Edge1(config)#ip cef
    ^
    % Invalid input detected at '^' marker.

    This is my current configuration on the Cisco 1605R

    Edge1#sh run
    Building configuration...

    Current configuration : 3137 bytes
    !
    version 12.2
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Edge1
    !
    logging rate-limit console 10 except errors
    enable secret 5 $1$DCc6$yQwW26CMfuBogc1F/Xm23/
    enable password xxxx
    !
    clock timezone CET 16
    ip subnet-zero
    no ip finger
    ip name-server 83.80.1.160
    ip name-server 83.80.1.164
    !
    no ip dhcp-client network-discovery
    !
    !
    !
    interface Loopback0
    description area 0
    ip address 172.16.1.1 255.255.255.0
    !
    interface Ethernet0
    description Casema Internet
    ip address dhcp
    ip access-group INPUT in
    ip access-group OUTPUT out
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache policy
    no cdp enable
    !
    interface Ethernet1
    description Bras26 intern
    ip address 192.168.0.105 255.255.255.0
    ip access-group NODHCP in
    ip access-group NODHCP out
    no ip redirects
    ip route-cache policy
    !
    ip nat inside source list 1 interface Ethernet0 overload
    ip nat inside source static tcp 192.168.0.2 21 interface Ethernet0 21
    ip nat inside source static tcp 192.168.0.2 3389 interface Ethernet0 119
    ip nat inside source static tcp 192.168.0.105 23 interface Ethernet0 23
    ip classless
    ip http server
    !
    !
    ip access-list extended INPUT
    permit tcp any any eq www
    permit tcp any any eq ftp
    permit tcp any any eq telnet
    permit tcp any any eq 8080
    remark Sta remote desktop verkeer toe via poort 119
    permit tcp any any eq nntp
    permit tcp any any established
    permit icmp any any
    permit udp any any eq domain
    permit tcp any any gt 1024
    permit udp any any gt 1024
    permit udp any any eq bootpc
    remark permit vpn verkeer naar x
    permit udp any any eq isakmp
    deny ip any any log
    remark Sta remote desktop verkeer toe via poort 119
    remark permit vpn verkeer naar x
    ip access-list extended NODHCP
    deny udp any any eq bootpc log
    permit ip any any
    ip access-list extended OUTPUT
    permit tcp any any eq www
    permit tcp any any eq ftp
    permit tcp any any eq pop3
    permit tcp any any eq smtp
    permit tcp any any gt 1024
    permit tcp any any eq nntp
    permit tcp any any eq 443
    permit icmp any any
    permit udp any any eq domain
    remark permit vpn verkeer naar x
    permit udp any any eq isakmp
    deny ip any any log
    remark permit vpn verkeer naar x
    logging trap debugging
    logging 192.168.1.1
    logging 192.168.0.11
    access-list 1 permit 192.168.0.0 0.0.0.255
    snmp-server engineID local 8000000903000002FD6574D6
    snmp-server community xxxxx RO
    snmp-server community xxxxxx RW
    banner motd ^CC
    *************************************************************************



    Internet-gateway

    Bras26 Edge-router 1



    *************************************************************************
    ^C
    !
    line con 0
    transport input none
    line vty 0 4
    password xxxxx
    login
    !
    end
     
    Jaap Hubert, Jan 18, 2005
    #3
  4. Walter Roberson, Jan 18, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.