CHAP request & reject

Discussion in 'Cisco' started by dt1649651, Apr 28, 2005.

  1. dt1649651

    dt1649651 Guest

    I am working on an ISDN circuit. Layer 1 and 2 are up, and Layer 3 is
    having problem. I turn on debug Q931 and it shows the problem is at a
    higher level so I turn on the PPP debug.

    The debug shows that my router sends CONFREQ for CHAP, and the ISP also
    sends CONFREQ for CHAP, but after that the ISP rejects the CHAP request
    from my router. I paste the debug output below.

    Why both sides request for CHAP and then reject it ?

    Could you please share me some advice ?

    Thanks,

    DT

    *Mar 1 20:11:29.182: BR0/0:1 LCP: O CONFREQ [REQsent] id 231 len 15
    *Mar 1 20:11:29.182: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)
    *Mar 1 20:11:29.182: BR0/0:1 LCP: MagicNumber 0x0D391935
    (0x05060D391935)
    *Mar 1 20:11:29.222: BR0/0:1 LCP: I CONFREQ [REQsent] id 1 len 34
    *Mar 1 20:11:29.222: BR0/0:1 LCP: VendorSpecific OUI (0x00040000)
    *Mar 1 20:11:29.222: BR0/0:1 LCP: MRU 1524 (0x010405F4)
    *Mar 1 20:11:29.222: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)
    *Mar 1 20:11:29.222: BR0/0:1 LCP: MRRU 1524 (0x110405F4)
    *Mar 1 20:11:29.226: BR0/0:1 LCP: EndpointDisc 3 00d0.5202.397e
    (0x13090300D05202397E)
    *Mar 1 20:11:29.226: BR0/0:1 LCP: LinkDiscriminator 50180
    (0x1704C404)
    *Mar 1 20:11:29.226: BR0/0:1 LCP: O CONFREJ [REQsent] id 1 len 16
    *Mar 1 20:11:29.226: BR0/0:1 LCP: VendorSpecific OUI (0x00040000)
    *Mar 1 20:11:29.226: BR0/0:1 LCP: MRRU 1524 (0x110405F4)
    *Mar 1 20:11:29.226: BR0/0:1 LCP: LinkDiscriminator 50180
    (0x1704C404)
    *Mar 1 20:11:29.230: BR0/0:1 LCP: I CONFREJ [REQsent] id 231 len 9
    *Mar 1 20:11:29.230: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)
    *Mar 1 20:11:29.230: BR0/0:1 LCP: O CONFREQ [REQsent] id 232 len 15
    *Mar 1 20:11:29.230: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)
    *Mar 1 20:11:29.230: BR0/0:1 LCP: MagicNumber 0x0D391935
    (0x05060D391935)
    *Mar 1 20:11:29.262: BR0/0:1 LCP: I CONFREQ [REQsent] id 2 len 22
    *Mar 1 20:11:29.262: BR0/0:1 LCP: MRU 1524 (0x010405F4)
    *Mar 1 20:11:29.262: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)
    *Mar 1 20:11:29.262: BR0/0:1 LCP: EndpointDisc 3 00d0.5202.397e
    (0x13090300D05202397E)
    *Mar 1 20:11:29.266: BR0/0:1 LCP: O CONFACK [REQsent] id 2 len 22
    *Mar 1 20:11:29.266: BR0/0:1 LCP: MRU 1524 (0x010405F4)
    *Mar 1 20:11:29.266: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305).
    *Mar 1 20:11:29.266: BR0/0:1 LCP: EndpointDisc 3 00d0.5202.397e
    (0x13090300D05202397E)
    *Mar 1 20:11:29.266: BR0/0:1 LCP: I CONFREJ [ACKsent] id 232 len 9
    *Mar 1 20:11:29.270: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)
    *Mar 1 20:11:29.270: BR0/0:1 LCP: O CONFREQ [ACKsent] id 233 len 15
    *Mar 1 20:11:29.270: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)
    *Mar 1 20:11:29.270: BR0/0:1 LCP: MagicNumber 0x0D391935
    (0x05060D391935)
    *Mar 1 20:11:29.330: BR0/0:1 LCP: I CONFREJ [ACKsent] id 233 len 9
    *Mar 1 20:11:29.334: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)
    *Mar 1 20:11:29.334: BR0/0:1 LCP: O CONFREQ [ACKsent] id 234 len 15
    *Mar 1 20:11:29.334: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)
    *Mar 1 20:11:29.334: BR0/0:1 LCP: MagicNumber 0x0D391935
    (0x05060D391935)
    *Mar 1 20:11:29.370: BR0/0:1 LCP: I CONFREJ [ACKsent] id 234 len 9
     
    dt1649651, Apr 28, 2005
    #1
    1. Advertisements

  2. dt1649651

    dt1649651 Guest

    Thanks for Clifford Kite 's advice. This case is one-way authentication
    by peer. I turned off "ppp authentication chap" and turn on "ppp
    authentication chap callin" to fix the problem.

    DT
     
    dt1649651, Apr 29, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.