cd writer + linux = damn thing wont work

Discussion in 'NZ Computing' started by Andrew, Aug 31, 2005.

  1. Andrew

    Andrew Guest

    Ive just put in a cd writer into a linux box (redhat 9)

    already have a dvd rom drive in the machine

    Trying to use cdrecord to burn to it.

    What i can do:
    i can mount the drives and read cds that i put into the drive

    what i cant do is burn to the writer

    if i run cdrecord -scanbus i dont see the drives:
    Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
    Linux sg driver version: 3.1.25
    Using libscg version 'schily-0.7'
    cdrecord: Warning: using inofficial libscg transport code version
    (schily - Red Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c
    1.75 02/10/21 Copyright 1997 J. Schilling').
    scsibus0:
    0,0,0 0) 'IBM-ESXS' 'ST318305LW !#' 'B244' Disk
    0,1,0 1) *
    0,2,0 2) *
    0,3,0 3) *
    0,4,0 4) *
    0,5,0 5) *
    0,6,0 6) *
    0,7,0 7) *


    im trying to work out the missing part of this command:
    cdrecord -v dev=??? speed=32 -data data.iso

    dvd drive is in /mnt/cdrom and the writer is /mnt/cdrom1

    fstab says:
    {834} > cat /etc/fstab
    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    LABEL=/local1 /local1 ext3 defaults 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/sda2 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom udf,iso9660
    noauto,owner,kudzu,ro 0 0
    /dev/fd0 /mnt/floppy auto
    noauto,owner,kudzu 0 0
    /var/swap/swapfile-1 swap swap defaults 0 0
    /var/swap/swapfile-2 swap swap defaults 0 0
    /dev/cdrom1 /mnt/cdrom1 udf,iso9660
    noauto,owner,kudzu,ro 0 0
     
    Andrew, Aug 31, 2005
    #1
    1. Advertisements

  2. Andrew

    Shane Guest

    I cant use cdrecord for sh*t, have you tried K3B?
    On my slackware box for the life of me I couldnt get cdrecord to burn cds,
    but K3B does it perfectly

    http://www.k3b.org/
    HTH
     
    Shane, Aug 31, 2005
    #2
    1. Advertisements

  3. Andrew

    Andrew Guest

    k3b is on another machine around here (these machiens are not mine, they
    are my work machines)

    Someone here attempted to put k3b on but my machine complained about not
    having qt something, not exactly sure what it is

    ive been using cdrecord from my machine to burn using another machiens
    drives, but that machien has retired and that drive has been put into my
    machine...

    so i have a couple of options - try to get kb3 to work or work out why
    cdrecord is being a pain
     
    Andrew, Aug 31, 2005
    #3
  4. Andrew

    Shane Guest

    no qt means no kde?
    perhaps xcdroast could help (another frontend for cdrecord)
    http://www.xcdroast.org/


    what kernel is your box running?
    http://cdrecord.berlios.de/old/private/cdrecord.html
    has some interesting info
     
    Shane, Aug 31, 2005
    #4
  5. Andrew

    Andrew Guest

    i am using kde
    Kernel is 2.4.26-31

    I have actually got it sorted now
    I added this line:
    hdc=ide-scsi hdd=ide-scsi

    To the lilo.conf file

    and now scanbus sees them :)
    cdrecord works too

    yay

    - i will look at kb3 a bit later - that way i can make use of the dvd
    burner in my machine, not that it matters as there are other machines
    with dvd burners in them nearby
     
    Andrew, Aug 31, 2005
    #5
  6. Andrew

    Fran Guest

    K3B uses cdrecord etc to do the work.
    It's just a nice gui front-end.

    The ide-scsi line isn't needed with 2.6.x kernels - much easier and cdrecord
    used the /dev/hdc type of device properly.
    Only put ide-scsi for drives that are writers.

    Fran
    :):):)
     
    Fran, Aug 31, 2005
    #6
  7. Andrew

    ChrisOD Guest

    I think you need to put the kernel parameter
    hdc=ide-scsi" in your boot manager
    eg
    in lilo
    append hdc="ide-scsi"
    this assumes hdc is your cdrom
    hda is primary master
    hdb is primary slave
    ....

    Of course after editing lilo.conf
    do a
    lilo -v
     
    ChrisOD, Aug 31, 2005
    #7
  8. Andrew

    Shane Guest

    er.. that line is said to be required for my slackware box with a 2.4
    kernel, but, I dont have it, and I use k3b (and yes it is a gui for
    cdrecord)
    cdrw here to

    moral of the story.. k3b rocks :)
     
    Shane, Aug 31, 2005
    #8
  9. Andrew

    Allistar Guest

    This is no longer needed if you are running a 2.6 series kernel.

    Allistar.
     
    Allistar, Aug 31, 2005
    #9
  10. Andrew

    Fran Guest

    Yes k3b rocks.
    And so does Slackware.

    Fran
    :):):)
     
    Fran, Aug 31, 2005
    #10
  11. Andrew

    ChrisOD Guest

    That's right, but the OP did say RH9.
    Bit old I know.
     
    ChrisOD, Aug 31, 2005
    #11
  12. Andrew

    Andrew Guest

    Unforntunatly im unable to upgrade to 2.6 yet - Im not a home user, We
    have tested 2.6 kernel and it does not work for us correctly as of yet
    so have reverted back to 2.4

    That really suckked actually, we upgraded our renderwall to 2.6 and it
    caused issues, kickstarting 1000's of machines twice within a week is
    not cool
     
    Andrew, Sep 4, 2005
    #12
  13. Andrew

    Andrew Guest

    Yes.. we have only just recently moved to RH9 too... unforntatly we cant
    just upgrade boxes - they have to be fully tested before anything is
    rolled out
     
    Andrew, Sep 4, 2005
    #13
  14. Andrew

    Andrew Guest

    Yes it does, KB3 is on one of the other machines in this room and its
    great :)

    however we tend to just use the windows box for dvd writing anyway
     
    Andrew, Sep 4, 2005
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.