Catalyst switches and Broadcom NICs

Discussion in 'Cisco' started by Richard Graves, May 13, 2005.

  1. Hi All,

    Has anyone had any problems connecting servers or PCs that use a Broadcom
    570x 10/100/1000 Gigabit NIC to any of the Catalyst 2900, 4500, 6500 series?
    For some time we have been experiencing speed and/or duplex problems when
    connecting the above NICs to any of the above switches. We hard-code the
    speed and duplex on both ends, yet the problem still exists. In some cases,
    if you set one side or the other to "auto/auto" then you get whatever speed
    and duplex the other side is set to. Sometime this works, sometimes it
    doesn't. This problem is not specific to one type of port on the Catalyst.
    It affects both the FastE and the GigE ports.

    To answer the obvious questions, yes we have tried different NICs, and
    different patch cables, and even entirely different cable runs. We have
    tried multiple ports on multiple switches to no avail. To only thing that
    we are running that might be considered "non-standard" is spanning-tree
    portfast on the ports. I don't recall if we have tried running a test
    without this, but I don't think that it would cause the symptoms that we are
    seeing. Other NIC brands (Intel, 3Com, etc) are not effected.

    Any ideas? All thoughts are appreciated!!!


    Richard Graves
    Richard Graves, May 13, 2005
    1. Advertisements

  2. Richard Graves

    thrill5 Guest

    I have not seen any problems with setting the speed and duplex at 10 or 100
    on broadcom NICs. To connect at Gigabit, you MUST set both sides to auto or
    it won't work.

    thrill5, May 13, 2005
    1. Advertisements

  3. Hi !

    Today I experienced the same problem as yours... It was with a Broadcom
    570x (I don't remember exactly which one it was) and a Cisco Catalyst
    4500. When autonegociation is used, the link speed is 100 Half Duplex.
    When set to 100 M Full on both sides, it works...

    But I experienced another problem : with servers using Broadcom NIC, we
    are losing packets, particularly when TCP connection take a long time. In
    fact, we have problem with 2 SMTP servers. Mails incoming on the first
    server (which have broadcom NIC) don't encountered any problem (it seems).
    But when the first server delivers mails to the second (which has no
    Broadcom NIC), several connections are correctly established but never
    freed. A packet capture shows me that after a certain amount of data, the
    connection stays open and never closes. The ACK/FIN is never sent. And
    when the number of blocked connections reach 20, the mail trafic between
    the servers is stopped (the second server authorize only 20 connections).

    The packet capture shows us that there were a lot of TCP retransmission
    from the broadcom NIC too.

    Do you think my problems come from an incompatibility between the switch
    and the NIC ? Or are these NIC a little bit bugged ??

    We had tried the latest drivers for the NIC and it wasn't better... The OS
    of server is Win2000...

    Thx for your answers and sorry for my bad english


    Le Fri, 13 May 2005 01:07:26 +0000, Richard Graves a écrit :
    PLANCKAERT Nicolas, May 17, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.